[问题]启动VBOX时,提示错误,请帮助。

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

[问题]启动VBOX时,提示错误,请帮助。

#1

帖子 atyditsh » 2008-06-07 12:04

The VirtualBox support driver which is running is from a different version of VirtualBox. You can correct this by stopping all running instances of VirtualBox and reinstalling the software..
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).


返回 代码:
0x80004005
组件:
Console
界面:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

意思是virtualbox的支持驱动运行着另个的版本,因为我先装了OSE的版本,然后我删除了,我又试装了SUN的版本,可以用,就又删除了。用GET装回OSE版本,现在就这个,我不知道彼搞好。
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 atyditsh » 2008-06-07 13:59

为什么这么久都没有人回答?都不会吗?
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 atyditsh » 2008-06-07 14:58

我把它们都掉了。装回SUM的了。可是用同样的winXP.vdi,说已经注册过了,怎么把这个错误的信息删除?是在LINUX注册表里吗/
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 atyditsh » 2008-06-07 15:11

重启后,启动VBOX,它提示出错,按测试,就可以把WINXP.vdi删除了。
不过有另一个问题,就是键盘用不了。我已经安装了qt和qt4了,不知道为什么。
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 atyditsh » 2008-06-07 15:52

装回OSE,还是提示
The VirtualBox support driver which is running is from a different version of VirtualBox. You can correct this by stopping all running instances of VirtualBox and reinstalling the software..
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#6

帖子 cnkilior » 2008-06-07 15:55

看看内核模块有什么关于vbox的东西,先卸下再说!

看看能否运行?

不行不知道了!
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 atyditsh » 2008-06-07 16:01

怎么看?
我都用sudo apt-get autoremove virtualbox,删除了很多软件了。
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#8

帖子 cnkilior » 2008-06-07 16:17

。。。

我记得卸下内核模块是不是rmmod xxx?
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 atyditsh » 2008-06-07 17:15

我通过搜索所有在/下的 virtualbox,并删除光。重启。再安装vbox,还是一样:
The VirtualBox support driver which is running is from a different version of VirtualBox. You can correct this by stopping all running instances of VirtualBox and reinstalling the software..
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 atyditsh » 2008-06-07 17:19

试过了。还是不行,不存在这个模块。。

这是个官方的中文论坛吧?就有没有人提供技术支持吗?今天是星期六,这个问题问了一个下午了。晕。
dayfree
帖子: 63
注册时间: 2006-11-09 21:31
送出感谢: 0
接收感谢: 0

#11

帖子 dayfree » 2008-06-07 20:08

用新历得,查virtualbox 选virtualbox-ose virtualbox-ose-modules-generi 24.0.3这两个,会安装3个包,另外卸载scim这东西和vb有冲突 ,装fcitx就没事了装好重启。
lingyunxs
帖子: 105
注册时间: 2007-04-21 11:57
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 lingyunxs » 2008-06-09 1:59

scim是和Virtualbox有冲突,如果你只用拼音就好办了,把scim下的 scim-table删除,就万事大吉了。
atyditsh
帖子: 27
注册时间: 2007-06-18 21:11
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 atyditsh » 2008-06-12 22:56

多删除了SCIM,用了FCITX,确实解决了这个问题。
头像
linuin
帖子: 404
注册时间: 2008-06-15 14:47
来自: beijing
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 linuin » 2008-06-21 23:22

我的也是这问题
很郁闷
我都正了几个星期了
回复

回到 “虚拟机和虚拟化”