当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 在ubuntu下安装vmware,无法config的问题
帖子发表于 : 2008-06-29 9:25 
头像

注册: 2008-06-27 15:02
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
在ubuntu 8.04下面安装了vmware 5.5 for linux,可以顺利安装,但是在config的时候出现错误导致vmware无法使用。

代码:
Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.24-18-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-18-generic'
  CC [M]  /tmp/vmware-config0/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config0/vmmon-only/./include/vmware.h:25,
                 from /tmp/vmware-config0/vmmon-only/linux/driver.c:48:
/tmp/vmware-config0/vmmon-only/./include/vm_basic_types.h:160: 错误: 与‘uintptr_t’类型冲突
include/linux/types.h:40: 错误: ‘uintptr_t’的上一个声明在此
在包含自 /tmp/vmware-config0/vmmon-only/linux/driver.h:20 的文件中,
                 从 /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:37:5: 警告: “VMW_HAVE_EPOLL”未定义
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:43:5: 警告: “VMW_HAVE_EPOLL”未定义
In file included from /tmp/vmware-config0/vmmon-only/linux/driver.h:20,
                 from /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:60: 错误: 与‘poll_initwait’类型冲突
include/linux/poll.h:65: 错误: ‘poll_initwait’的上一个声明在此
In file included from /tmp/vmware-config0/vmmon-only/linux/driver.c:80:
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: 错误: expected declaration specifiers or ‘...’ before ‘compat_exit’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: 错误: expected declaration specifiers or ‘...’ before ‘exit_code’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: 警告: 在‘_syscall1’的声明中,类型默认为‘int’
/tmp/vmware-config0/vmmon-only/linux/driver.c:145: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config0/vmmon-only/linux/driver.c:149: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config0/vmmon-only/linux/driver.c: 在函数‘LinuxDriver_Ioctl’中:
/tmp/vmware-config0/vmmon-only/linux/driver.c:1661: 错误: ‘struct mm_struct’没有名为‘dumpable’的成员
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-18-generic'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.


大概是内核版本的问题,如果有谁遇到了类似的问题,帮忙给个答复,多谢。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-29 12:46 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
这个需要安装补丁的。找同板块的帖子看。

安装6.4版本目前不需要补丁。
你装5.5想开3D啊?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-29 21:47 
头像

注册: 2008-06-27 15:02
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
sheji 写道:
这个需要安装补丁的。找同板块的帖子看。

安装6.4版本目前不需要补丁。
你装5.5想开3D啊?


也不是想开3D,只要是手头只有5.5的版本,而且有序列号。

6.4的有序列号吗?


_________________
ASUS F9 @ ubuntu 8.04


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-30 21:14 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
7JDF5-56E0J-W0J4G-4MTXP


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译