当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : VMware Workstation 6.5 开3D 问题
帖子发表于 : 2008-07-06 14:01 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
昨天,听到消息 VMware Workstation 6.5 可以开3D了,就立即安装了 VMware Workstation 6.5 for windows,没曾想效果这么好,刚装完,调用了6.4下的一个镜像,就立即可开3D了。d3d测试全部通过。
后即新安装了一套windows2003,三卡驱动装完,打上dirctX补丁,立即测试,d3d全部通过。

因此,立即转到 ubuntu平台,彻底卸载原来的6.4,安装了 VMware Workstation 6.5 for linux 。装毕,调试,并解决速度慢的问题。然后调用原6.4 (for linux 的)的一个镜像,但发现3D不能打开的错误提示。进入系统后当然打不开3d。
提示如下:
This computer does not have a 3D graphics system supported by VMware Workstation.

以为是原系统设置问题,遂将影像转换至6.5格式,结果仍无效。
接着新装一个windows2003,[装毕就提示]This computer does not have a 3D graphics system supported by VMware Workstation. (已经打完3D补丁)因为安装系统之前就设置了3D方式,而且这也是6.5 for linux 的默认设置。一个全新的虚拟系统,没有做过人为的修改设置(指内部文件)。进入系统后仔细检查,没有发现与windows下的虚拟机设置有差别,同样默认设置了 128M显存,加速全开。

本人英文文盲,经翻译还是不能确定:
VMware 不具有 这台电脑的3D图形系统 的支持
这台电脑不具有 适用于 VMware 的3D图形系统

本人套用其他语种的翻译规则,倾向于 后者的翻译内容。

请各位指正一下翻译内容。

检查了ubuntu下的nv设置(我装的是厂家的显卡驱动),把能调动nv卡的功能几乎都打开试过。

无奈呀。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-06 14:34 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
6.5的一个说明:
The guest operating system in the virtual machine is Windows XP, Windows Vista, or Linux.

但6.5 for windows 版本却能够很好的支持3D,,,也是同样的说明。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-06 15:31 

注册: 2008-04-13 9:47
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
应意译为”这台机没有一个由VMWare Workstation 支持的3D图型系统“,并不是说你的机没有3D图型系统。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-06 15:40 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
ninyun 写道:
应意译为”这台机没有一个由VMWare Workstation 支持的3D图型系统“,并不是说你的机没有3D图型系统。


谢谢了。
还是后者的意思,那就有点麻烦了。我现在显卡已经是官方的“正宗”驱动了,真不知道如何设置ubuntu的显示系统才能让VM6.5支持呢。

VM6.5也真是,难道自己就不会处理一下显卡吗?同样的硬件,同样的VM版本号,windows就没问题。

贴一下vmx内容,也方便自己对照看:
#!/usr/bin/vmware
.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "7"
scsi0.present = "TRUE"
scsi0.virtualDev = "lsilogic"
memsize = "768"
mem.hotadd = "TRUE"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "175.vmdk"
ide1:0.present = "TRUE"
ide1:0.fileName = "/dev/scd0"
ide1:0.deviceType = "cdrom-raw"
floppy0.fileType = "device"
floppy0.fileName = ""
floppy0.clientDevice = "FALSE"
ethernet0.present = "TRUE"
ethernet0.connectionType = "custom"
ethernet0.vnet = "/dev/vmnet0"
ethernet0.wakeOnPcktRcv = "FALSE"
usb.present = "TRUE"
usb.generic.allowHID = "TRUE"
ehci.present = "TRUE"
sound.present = "TRUE"
mks.enable3d = "TRUE"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
roamingVM.exitBehavior = "go"
displayName = "175"
guestOS = "winnetenterprise"
nvram = "175.nvram"
virtualHW.productCompatibility = "hosted"
ft.secondary0.enabled = "TRUE"
tools.upgrade.policy = "useGlobal"

extendedConfigFile = "175.vmxf"

vmci0.unrestricted = "TRUE"
unity.useCustomColor = "TRUE"
unity.customColor = "|23f0e485"

ethernet0.addressType = "generated"
tools.syncTime = "FALSE"
uuid.location = "56 4d 39 7c 0a 69 5b 74-c5 e5 1b b6 83 0e 1d 6d"
uuid.bios = "56 4d 39 7c 0a 69 5b 74-c5 e5 1b b6 83 0e 1d 6d"
scsi0:0.redo = ""
vmotion.checkpointFBSize = "134217728"
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "16"
usb.pciSlotNumber = "32"
ethernet0.pciSlotNumber = "33"
sound.pciSlotNumber = "34"
ehci.pciSlotNumber = "35"
vmci0.pciSlotNumber = "36"
usb:0.present = "TRUE"
usb:1.present = "TRUE"
ethernet0.generatedAddress = "00:0c:29:0e:1d:6d"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "-2096226963"
USB:1.deviceType = "hub"
USB:0.deviceType = "mouse"
floppy0.autodetect = "TRUE"
scsi0:1.present = "FALSE"
scsi0:1.fileName = "/home/hh/VMware/PRO1/Windows Server 2003 Enterprise Edition-cl1.vmdk"
scsi0:1.redo = ""

scsi0:2.present = "FALSE"
scsi0:2.fileName = "/home/hh/VMware/123/123.vmdk"

scsi0:3.present = "FALSE"
scsi0:3.fileName = "/home/hh/VMware/122B/122B.vmdk"

floppy0.present = "FALSE"
scsi0:2.redo = ""
scsi0:3.redo = ""

svga.autodetect = "FALSE"
svga.vramSize = "134217728"


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-06 15:55 

注册: 2008-04-13 9:47
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
据我所知VMware的BIOS是Phinex类,可以在Windows下提取的,提取后的BIOS在Windows 和Ubuntu下是通用的。VMware的MotherBoard和显示卡以前是IntelBx4400,与你的显卡无关。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-06 17:27 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
问题是同是VM6.5的版本,而且内部的显卡驱动、以及模拟的硬件、bios都一样,连相关设置都一样。出错的信息也是说 对硬件(或平台)的图形显示, VMWare 不能支持。但在windows环境却很好支持。那只有一个环节不一样,就是平台,或者说是和平台的显示系统的设置有关。当然也有可能该版本的 VM for linux 本身支持就有问题。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-08 14:03 
头像

注册: 2006-02-10 16:36
帖子: 2656
系统: Xubuntu14.04/Deepin
送出感谢: 13
接收感谢: 25
麻烦楼主给个for linux的下载连接和注册码吧,我也测试一下。 :D :twisted:


_________________
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-08 14:18 

注册: 2006-09-24 4:37
帖子: 2138
送出感谢: 0 次
接收感谢: 1
装了6.5的Tools没?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-08 16:09 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
jimmin 写道:
装了6.5的Tools没?


肯定装了,不装的话三卡都没了,默认的显卡连1024都开不了。

这次的tools携带的SVGA II 已经是更新过的,以往在2003系统环境都是自己添加的SVGA II的驱动。

对了,Uniti 没有问题,可以正常将VM的多应用程序变为ubuntu下的多窗口。就是内部d3d通不过。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-07-08 16:13 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
百草谷居士 写道:
麻烦楼主给个for linux的下载连接和注册码吧,我也测试一下。 :D :twisted:


这里人气差,你应该在前面几个帖子中就可以找到下载地址以及注册码(也是我发的)(可以用一阵子,但奇怪windows版可以完美注册,但linux版只能注册到8月31号)(不过到时候再换一个注册码,不知道是否。。。)


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-07-09 7:56 
头像

注册: 2006-02-10 16:36
帖子: 2656
系统: Xubuntu14.04/Deepin
送出感谢: 13
接收感谢: 25
我下载了一个测试版的,找了一个可以用30天的注册码。
过去在virtualbox上不能玩的游戏可以玩了,但是没有声音。
不过启动速度比virtualbox 慢多了。


_________________
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-07-09 11:32 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
百草谷居士 写道:
我下载了一个测试版的,找了一个可以用30天的注册码。
过去在virtualbox上不能玩的游戏可以玩了,但是没有声音。
不过启动速度比virtualbox 慢多了。


VM下声音问题容易解决,毕竟是一台虚拟的集成电脑,啥都不缺。如果你用的是2003系统,估计声卡就找不到,这个是VM的问题,奇怪一直都没有解决,似乎有些年头了~~ 我在这里发过这个补丁,就是声卡驱动。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-07-09 12:20 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
sheji 写道:
百草谷居士 写道:
麻烦楼主给个for linux的下载连接和注册码吧,我也测试一下。 :D :twisted:


这里人气差,你应该在前面几个帖子中就可以找到下载地址以及注册码(也是我发的)(可以用一阵子,但奇怪windows版可以完美注册,但linux版只能注册到8月31号)(不过到时候再换一个注册码,不知道是否。。。)

那个vmware虚拟机论坛有过序列号注册机,可惜是window的,在linux下面跑不了。
我曾经打开过3D,可是它会导致我每次开虚拟机总是有一点debug消息,所以还是把3D关了


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-07-09 16:55 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
用VM 6.4我可以打开d3d,只是假的,不完全,只通过了 Direct7 ,通不过 Direct 8和9。
这次VM6.5可以看出是全新构造了,而且已经显示可以开d3d。也许你可以试试能够成功。
注册机可以在虚拟机下跑啊。我就是用的注册机。感觉VM对于linux有些意思。。。不但注册方法改了,功能也很隐蔽,,,

出现 debug消息,我想肯定通不过测试,可能连3D都还没打开呢,呵呵

没信心搞这个了。
windows版的VM很完美。但在Windows下VM ubuntu,一点价值都没有,也根本没这个必要。U有的软件,W全有。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-07-09 17:30 
头像

注册: 2006-02-10 16:36
帖子: 2656
系统: Xubuntu14.04/Deepin
送出感谢: 13
接收感谢: 25
确实有个什么DEBUG信息,看不清楚。
另外没有长期注册码也没有关系,只要有试用注册码就行:可以使用workstation构造一个虚拟机,以后使用vmware player运行,只是不能修改虚拟机配置。不过一般也不用修改的。


_________________
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译