[原创]在不同系统中使用相同的VMWare虚拟系统

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
blueshine
帖子: 8
注册时间: 2007-02-27 13:31
送出感谢: 0
接收感谢: 0

[原创]在不同系统中使用相同的VMWare虚拟系统

#1

帖子 blueshine » 2008-07-18 18:36

本人最近在现有系统下新装了Ubuntu8.04,原系统为Vista SP1,现为双系统。
由于工作需要,很多任务要在Windows2003下完成,而且要保持同步,因此在两个系统中都装了VMWare,初次安装时,在Ubuntu下的VMWare里怎么都不能加载Vista下创建的win2003系统,坛中相关主题也没有解决方法,摸索了几天,终于解决了问题,现将处理步骤分享如下:
1. 在Ubuntu中用VMWare按照需要正常安装windows2003系统
2. 将生成的系统虚拟磁盘文件拷贝到Vista下的分区中
3. 在VMWare里删除刚才创建的系统,重新创建,在创建过程中选择定制方式加载已拷贝到Vista系统中的虚拟硬盘
4. 在VMWare中启动Windows2003虚拟系统,检验系统是否正常,在Ubuntu中的处理完成
5. 重启机器,进入Vista,打开VMWare创建Windows2003虚拟系统,要选择定制方式,以便加载Ubuntu中创建的虚拟硬盘
6. 启动虚拟系统,检验系统是否正常
7. 完成两个系统中的VMWare通用同一个虚拟系统的设置
Enjoy :P
sheji
帖子: 431
注册时间: 2008-04-30 21:40
送出感谢: 0
接收感谢: 0

#2

帖子 sheji » 2008-07-19 3:03

定制方式

好经验。
lsq2003
帖子: 155
注册时间: 2007-09-21 12:13
送出感谢: 0
接收感谢: 0

#3

帖子 lsq2003 » 2008-07-20 11:28

这个对我有用..谢谢..
blueshine
帖子: 8
注册时间: 2007-02-27 13:31
送出感谢: 0
接收感谢: 0

#4

帖子 blueshine » 2008-07-21 12:51

我在使用Ubuntu时,也是看了坛子中的许多相关帖子才搞定了一些问题的
我要说的是 Ubuntu =分享,我喜欢 :D
2ine
帖子: 200
注册时间: 2008-05-02 15:55
送出感谢: 0
接收感谢: 0

#5

帖子 2ine » 2008-07-21 14:30

这估计是Linux和Win下的VM提供的虚拟机文件格式不同
我觉得不用删除重添加那么麻烦,
可以Win下弄个虚拟机加载这个虚拟盘保存为Win2K3-win
再在Linux下用同样的方法保存为Win2K3-Linux
用的时候跟据系统分别加载就行
ninyun
帖子: 185
注册时间: 2008-04-13 9:47
送出感谢: 0
接收感谢: 0

#6

帖子 ninyun » 2008-07-21 15:06

在创建虚拟机的操作系统所在位置只要两个Host都认识的盘,一般来说VMWARE的格式是可以通用的。也就是说建立在fat,ntfs上的虚拟机盘应可以通用。因为Win和linux都认识fat & Ntfs.
华铸
帖子: 58
注册时间: 2005-07-12 16:04
来自: 中国 珠海
送出感谢: 0
接收感谢: 0

#7

帖子 华铸 » 2008-07-21 15:46

我也经常在双系统下到弄虚拟机,但我好像没有遇到楼主的问题。
但由于Linux和Windows对于硬件设备的表述方式不一样,所以如果虚拟机中用光驱、软驱等设备的,在启动时,一般会有错误提示,解决办法是打开硬件设置窗口,保存一下就行了。
另外一个我遇到过的情况是,虚拟机存放于NTFS下,Ubuntu打开时会遇到麻烦,甚至打不开,建议在FAT32下创建虚拟机。
blueshine
帖子: 8
注册时间: 2007-02-27 13:31
送出感谢: 0
接收感谢: 0

#8

帖子 blueshine » 2008-07-22 14:59

7楼所说的问题,我也遇到了,所以试用我所描述的这种方式,结果成功。
总 的来说,虚拟硬盘文件文件必须放到Windows系统下的分区,然后Ubuntu和win分别创建各自的系统,调用同一个虚拟硬盘文件,系统描述文件必须保存到自己的分区中,因为Windows不能识别Ubuntu的分区
回复

回到 “虚拟机和虚拟化”