各位大爷,小弟在线等待各位爷帮忙

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
12074839
帖子: 2
注册时间: 2008-07-22 1:24
送出感谢: 0
接收感谢: 0

各位大爷,小弟在线等待各位爷帮忙

#1

帖子 12074839 » 2008-07-26 11:10

问题和这里的帖子一样,不过照做不行
http://forum.ubuntu.org.cn/viewtopic.ph ... f2dd2d8fc1


zhoutao@zhoutao:~$ sudo apt-get install linux-headers-`uname -r`
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
linux-headers-2.6.24-20-generic 已经是最新的版本了。
已经不需要下列自动安装的软件包:
xserver-xorg-video-amd
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
zhoutao@zhoutao:~$ sudo /etc/init.d/vboxdrv setup
* Usage: /etc/init.d/vboxdrv {start|stop|restart|status}
zhoutao@zhoutao:~$ sudo apt-get install linux-headers-$(uname -r)
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
linux-headers-2.6.24-20-generic 已经是最新的版本了。
已经不需要下列自动安装的软件包:
xserver-xorg-video-amd
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
zhoutao@zhoutao:~$ sudo apt-get install linux-restricted-modules-$(uname -r)
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
linux-restricted-modules-2.6.24-20-generic 已经是最新的版本了。
已经不需要下列自动安装的软件包:
xserver-xorg-video-amd
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
zhoutao@zhoutao:~$ sudo /etc/init.d/vboxdrv setup
* Usage: /etc/init.d/vboxdrv {start|stop|restart|status}
zhoutao@zhoutao:~$ sudo /etc/init.d/vboxdrv statrt
* Usage: /etc/init.d/vboxdrv {start|stop|restart|status}
zhoutao@zhoutao:~$ sudo /etc/init.d/vboxdrv start
* Starting VirtualBox kernel module vboxdrv
* No suitable module for running kernel found.
zhoutao@zhoutao:~$ sudo /etc/init.d/vboxdrv restart
* Stopping VirtualBox kernel module vboxdrv [ OK ]
* Starting VirtualBox kernel module vboxdrv
头像
daf3707
论坛版主
帖子: 12672
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#2

帖子 daf3707 » 2008-07-26 11:17

各位大爷,小弟……
这是怎么论的辈份 :D
用新立得找这个包

代码: 全选

virtualbox-ose module for linux-image-2.6.24-19-generic


2.6.24-19是你的内核版本号,换成你的,安装。
或者

代码: 全选

 sudo apt-get install virtualbox-ose-module-$(uname -r) 


(我的2.6.24-20好像没有)去它的官网看看
回复

回到 “虚拟机和虚拟化”