当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : virtualbox虚拟xp要访问共享文件夹,提示需要用户名和密码?(已解决)
帖子发表于 : 2008-08-20 0:15 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
virtualbox虚拟xp要访问共享文件夹,提示需要用户名和密码?

但是输入什么都进不去,为什么?如何解决?

host 是ubuntu 8.04

虚拟xp系统,

vbox版本是sun xvm virtualbox 1.64


最后由 xhxiang 编辑于 2008-08-23 8:38,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-20 19:36 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
上传个截图


附件:
Screenshot-vcom [正在运行] - Sun xVM VirtualBox-1.png
Screenshot-vcom [正在运行] - Sun xVM VirtualBox-1.png [ 273.75 KiB | 被浏览 1963 次 ]

Screenshot-vcom [正在运行] - Sun xVM VirtualBox.png
Screenshot-vcom [正在运行] - Sun xVM VirtualBox.png [ 253.88 KiB | 被浏览 1938 次 ]

页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-21 13:39 
头像

注册: 2008-07-28 15:32
帖子: 25
地址: http://www.leftsoft.cn
送出感谢: 0 次
接收感谢: 0 次
UBUNTU 共享选项里有个 允许匿名访问 勾上即可


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-21 21:03 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
leftsoft 写道:
UBUNTU 共享选项里有个 允许匿名访问 勾上即可


在那里呢?我没有找到


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-21 22:36 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
按照3楼所说的应该是samba服务的设置,这个方法我试过了,不行的,虚拟机访问的根本不是samba服务。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: virtualbox虚拟xp要访问共享文件夹,提示需要用户名和密码?
帖子发表于 : 2008-08-22 10:08 
头像

注册: 2008-07-28 15:32
帖子: 25
地址: http://www.leftsoft.cn
送出感谢: 0 次
接收感谢: 0 次
xhxiang 写道:
virtualbox虚拟xp要访问共享文件夹,提示需要用户名和密码?

但是输入什么都进不去,为什么?如何解决?

host 是ubuntu 8.04

虚拟xp系统,

vbox版本是sun xvm virtualbox 1.64


为什么不使用SAMBA呢,他可以提供更强大的访问控制,看下我的抓图:


附件:
Screenshot.png
Screenshot.png [ 194.42 KiB | 被浏览 1917 次 ]

页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-22 19:32 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
请告诉我虚拟机的xp如何访问host的ub的samba服务?

我设置网卡模式是nat,得到的是10.0.2.0的网段,和我ubuntu的真实网段192.168.0.0的不一样。

应该用那种模式????


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-23 8:38 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
已解决,安装了samba之后,竟然能在虚拟xp的网上邻居里面找到ub的共享.反而用\\vboxsvr的机器明进不去了.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-23 21:57 
头像

注册: 2008-04-18 17:29
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
有的时候设置允许匿名登录... 会提示错误


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-08-25 13:22 

注册: 2008-08-25 12:12
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
请问楼主,我在虚拟XP时遇到了同样的问题(ubuntu8.04主机),设置共享里要求输入用户名和密码,按上述方法安装了samba后仍然不能访问映射到主机共享文件夹,是不是还有什么没有设置到,比如需不需要增加多个主机的用户名?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译