当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 惨了!帮帮忙
帖子发表于 : 2008-08-24 12:08 

注册: 2008-01-21 23:33
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
安装了virtualBOX,准备虚拟OS的时候,发现权限不对,所以用下面的命令将user(也就是我)添加到virtualbox用户组:
usermod -G vboxusers user
logout后,再次登录,发现很多原来可以的功能都用不了,比如不能虚拟原有的vista硬盘,也不能打开声卡、并且sudo命令根本不起作用。
cat /etc/group后发现user组下面没有user用户,vboxusers里面有,这个正常吗?
而是又用下面的命令:
usermod -g user user
尝试添加到原来的用户组,grous显示如下:
user vboxusers
重启后还是不行,于是尝试卸载掉virtualBOX,但是发现新立得也不能用了,输入root的密码提示说无法使用

该怎么办?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-24 12:22 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
用livecd改/etc/group吧...


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-24 12:41 

注册: 2008-01-21 23:33
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
能解释我哪里做错了吗?是不是usermod命令没有用对


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-24 15:05 

注册: 2008-01-21 23:33
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
利用recovery模式将group文件改回来了
在user一行增加了user用户,去掉了virtualbox组中的user用户,但是发现还是不行。
sudo时,都是提示输入user的密码,而不是root的密码;synaptic提示说当前的权限设置不允许user运行


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-24 17:06 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
sudo组有user吗?


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-24 18:43 

注册: 2008-01-21 23:33
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
通过google发现可能是sudoers文件里面没有user的权限,按照里面的方法在recovery模式下增加了user。重启后发现新立得是可以用了,声卡还是不行,想到应该还是group的问题,于是用sudo把user添加到audio组里面(附加组),logout重新登录后发现好了。
奇怪的是sudo的时候还是提醒我输入user的密码而不是root的密码,但是命令似乎又是生效了。

等下试试HuntXu的方法,谢谢了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译