当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 8.04.1 上安装 Bochs 2.3.7 源码包
帖子发表于 : 2008-10-03 8:18 

注册: 2008-09-27 12:42
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
Bochs的rpm包是不带远程调试的,如果要开发操作系统的话,需要自己重新编译,步骤如下:

1.下载Bochs 2.3.7(目前最新)源码包:
http://bochs.sourceforge.net/cgi-bin/topper.pl?name=See+All+Releases&url=http://sourceforge.net/project/showfiles.phpqmrkgroup_ideq12580 下载 bochs-2.3.7.tar.gz 至 /opt(目录随你自己)

2.解压,然后进入目录/opt/bochs-2.3.7

3.
代码:
./configure --enable-gdb-stub

配置过程中应该会报错,然后中断,最后提示好像是没有g++,解决办法:
代码:
sudo apt-get install g++

还会推荐安装g++-multilib,反正我装了。

4. 然后再次
代码:
./configure --enable-gdb-stub

应该又会报错“X windows gui was selected, but X windows libraries were not found.”
解决办法:
代码:
sudo apt-get install xorg-dev


5. 再次
代码:
./configure --enable-gdb-stub
应该OK了

6.
代码:
make

7.
代码:
make install

8. 终端最后一行有:“install -m 644 ./.bochsrc /usr/local/share/doc/bochs/bochsrc-sample.txt”
这是bochs配置文件,一定要用配套的,有些老配置文件的参数新版本不支持。
把bochsrc-sample.txt复制到你的工作目录。

我碰到问题后也乱装了一些其它包,但只有安装了上述包后才解决问题,所以应该就是这样。

Good Luck! :em11


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu 8.04.1 上安装 Bochs 2.3.7 源码包
帖子发表于 : 2008-10-11 11:08 

注册: 2008-08-19 16:21
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
玩操作系统的人少
顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶
:em06 :em06


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu 8.04.1 上安装 Bochs 2.3.7 源码包
帖子发表于 : 2008-10-26 11:14 
头像

注册: 2008-05-10 21:37
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
顶啊, 在学习linux内核,正需要了 :em11 :em11


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译