当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 8.10 安装vmware server 2 失败 如何解决?
帖子发表于 : 2008-10-28 18:27 

注册: 2008-07-18 9:32
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
ubuntu 8.10 安装vmware server 2 失败 ,内核版本不支持,请问谁知道如何解决?可不可以降低内核版本?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 8.10 安装vmware server 2 失败 如何解决?
帖子发表于 : 2008-10-29 10:32 

注册: 2008-07-18 9:32
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
换回ubuntu8.04.1了。没办法


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 8.10 安装vmware server 2 失败 如何解决?
帖子发表于 : 2008-11-01 12:41 

注册: 2008-11-01 12:34
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
换回ubuntu8.04.1,就可以用了吗?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 8.10 安装vmware server 2 失败 如何解决?
帖子发表于 : 2008-11-01 22:47 
头像

注册: 2008-05-03 1:53
帖子: 951
送出感谢: 19
接收感谢: 11
我的是8.04,刚装了vmware server 2.0,也出了问题,我找到解决办法了
可能对你有用,我的主要是内核问题,
下面是我找的解决问题的帖子
我上传不了pdf,贴这里了
**********************************************************************************
problem with vmware-config.pl ...
Kimnguon 4 posts since
Oct 27, 2008
Today i updated my Ubuntu 8.04 kernel to the latest release 2.6.24-21-rt.
VMware ask me to run vmware-config.pl again, but this never success.
i got problem with kernel version 2.6.24-21-rt that is not support by VMware.
How can i fix this problem, please help.
Below is the message generate when i run vmware-config.pl
$ sudo /usr/bin/vmware-config.pl
Making sure services for VMware Server are stopped.
Stopping VMware autostart virtual machines:
Virtual machines failed
Stopping VMware management services:
VMware Virtual Infrastructure Web Access
VMware Server Host Agent failed
Stopping VMware services:
VMware Authentication Daemon done
VM communication interface socket family: done
Virtual machine communication interface done
Virtual machine monitor done
Bridged networking on /dev/vmnet0 done
Host network detection done
DHCP server on /dev/vmnet1 done
Host-only networking on /dev/vmnet1 done
DHCP server on /dev/vmnet8 done
NAT service on /dev/vmnet8 done
Host-only networking on /dev/vmnet8 done
Virtual ethernet done
None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? yes
Using compiler "/usr/bin/gcc". Use environment variable CC to override.
Your kernel was built with "gcc" version "4.2.3", while you are trying to use
"/usr/bin/gcc" version "4.2.4". This configuration is not recommended and
VMware Server may crash if you'll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.2.4" anyway? no yes
What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/src/linux-headers-2.6.24-21/include
The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does not match
your running kernel (version 2.6.24-21-rt). Even if the module were to compile
successfully, it would not load into the running kernel.
What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]
btone 96 posts since
************************************************************************************
Dec 9, 2007 1. Re: problem with vmware-config.pl Oct 28, 2008 4:39 AM
did you try to install linux-headers-2.6.24-21-rt ?
what is the output of
dpkg -l | grep 2.6.24
on your system?
Kimnguon 4 posts since
*****************************************************************************************
Oct 27, 2008 2. Re: problem with vmware-config.pl Oct 28, 2008 6:20 PM
in response to: btone
Thanks for your reply,
The following the the ouput of dpkg -l | grep 2.6.24
ii linux-headers-2.6.24-16 2.6.24-16.30 Header files related to Linux kernel version 2.6.24
ii linux-headers-2.6.24-16-generic 2.6.24-16.30 Linux kernel headers for version 2.6.24 on x86/x86_64
ii linux-headers-2.6.24-18 2.6.24-18.32 Header files related to Linux kernel version 2.6.24
ii linux-headers-2.6.24-18-generic 2.6.24-18.32 Linux kernel headers for version 2.6.24 on x86/x86_64
ii linux-headers-2.6.24-19 2.6.24-19.41 Header files related to Linux kernel version 2.6.24
ii linux-headers-2.6.24-19-generic 2.6.24-19.41 Linux kernel headers for version 2.6.24 on x86/x86_64
ii linux-headers-2.6.24-21 2.6.24-21.43 Header files related to Linux kernel version 2.6.24
ii linux-headers-2.6.24-21-generic 2.6.24-21.43 Linux kernel headers for version 2.6.24 on x86/x86_64
ii linux-headers-generic 2.6.24.21.23 Generic Linux kernel headers
ii linux-image-2.6.24-16-generic 2.6.24-16.30 Linux kernel image for version 2.6.24 on x86/x86_64
ii linux-image-2.6.24-17-generic 2.6.24-17.31 Linux kernel image for version 2.6.24 on x86/x86_64
ii linux-image-2.6.24-18-generic 2.6.24-18.32 Linux kernel image for version 2.6.24 on x86/x86_64
ii linux-image-2.6.24-19-generic 2.6.24-19.41 Linux kernel image for version 2.6.24 on x86/x86_64
ii linux-image-2.6.24-21-generic 2.6.24-21.43 Linux kernel image for version 2.6.24 on x86/x86_64
ii linux-image-2.6.24-21-rt 2.6.24-21.43 Linux kernel image for version 2.6.24 on Ingo Molnar's full real time
preemption patch (2.6.24.3-rt3)
ii linux-image-generic 2.6.24.21.23 Generic Linux kernel image
ii linux-image-rt 2.6.24.21.23 Real time Linux kernel image
ii linux-libc-dev 2.6.24-21.43 Linux Kernel Headers for development
ii linux-restricted-modules-2.6.24-16-generic 2.6.24.12-16.34 Non-free Linux 2.6.24 modules on x86/x86_64
ii linux-restricted-modules-2.6.24-18-generic 2.6.24.13-18.41 Non-free Linux 2.6.24 modules on x86/x86_64
ii linux-restricted-modules-2.6.24-19-generic 2.6.24.13-19.45 Non-free Linux 2.6.24 modules on x86/x86_64
ii linux-restricted-modules-2.6.24-21-generic 2.6.24.14-21.51 Non-free Linux 2.6.24 modules on x86/x86_64
ii linux-restricted-modules-2.6.24-21-rt 2.6.24.14-21.51 Non-free Linux 2.6.24 modules on x86/x86_64
ii linux-restricted-modules-common 2.6.24.14-21.51 Non-free Linux 2.6.24 modules helper script
ii linux-restricted-modules-generic 2.6.24.21.23 Restricted Linux modules for generic kernels
ii linux-restricted-modules-rt 2.6.24.21.23 Restricted Linux modules for rt kernels
ii linux-rt 2.6.24.21.23 Complete rt Linux kernel
ii linux-ubuntu-modules-2.6.24-16-generic 2.6.24-16.23 Ubuntu supplied Linux modules for version 2.6.24 on
x86/x86_64
ii linux-ubuntu-modules-2.6.24-17-generic 2.6.24-17.25 Ubuntu supplied Linux modules for version 2.6.24 on
x86/x86_64
ii linux-ubuntu-modules-2.6.24-18-generic 2.6.24-18.26 Ubuntu supplied Linux modules for version 2.6.24 on
x86/x86_64
ii linux-ubuntu-modules-2.6.24-19-generic 2.6.24-19.28 Ubuntu supplied Linux modules for version 2.6.24 on
x86/x86_64
ii linux-ubuntu-modules-2.6.24-21-generic 2.6.24-21.32 Ubuntu supplied Linux modules for version 2.6.24 on
x86/x86_64
ii linux-ubuntu-modules-2.6.24-21-rt 2.6.24-21.32 Ubuntu supplied Linux modules for version 2.6.24 on x86/x86_64
btone 96 posts since
*******************************************************************************
Dec 9, 2007 3. Re: problem with vmware-config.pl Oct 29, 2008 12:51 AM
in response to: Kimnguon ok, that the problem. try to install linux-headers-2.6.24-21-rt.
aptitude install linux-headers-2.6.24-21-rt
*********************************************************************
这里如果没有上面那个包又可以连上源,可直接安装,用命令:
sudo apt-get install linux-headers
***********************************************************************
and run vmware-config.pl again
Kimnguon 4 posts since
**********************************************************************************
一般不出问题到这里就解决了
**************************************************************************************
Oct 27, 2008 4. Re: problem with vmware-config.pl Oct 29, 2008 7:11 PM
in response to: btone
Thanks for your helpful instruction.
I installed the linux-headers-2.6.24-21-rt successfully, then I run the vmware-config.pl, it end up with Execution
aborted.
Below is the ouput of vmware-config.pl
$ sudo /usr/bin/vmware-config.pl
Making sure services for VMware Server are stopped.
Stopping VMware autostart virtual machines:
Virtual machines failed
Stopping VMware management services:
VMware Virtual Infrastructure Web Access
VMware Server Host Agent failed
Stopping VMware services:
VMware Authentication Daemon done
VM communication interface socket family: done
Virtual machine communication interface done
Virtual machine monitor done
Bridged networking on /dev/vmnet0 done
Host network detection done
DHCP server on /dev/vmnet1 done
Host-only networking on /dev/vmnet1 done
DHCP server on /dev/vmnet8 done
NAT service on /dev/vmnet8 done
Host-only networking on /dev/vmnet8 done
Virtual ethernet done
None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? yes
Using compiler "/usr/bin/gcc". Use environment variable CC to override.
Your kernel was built with "gcc" version "4.2.3", while you are trying to use
"/usr/bin/gcc" version "4.2.4". This configuration is not recommended and
VMware Server may crash if you'll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.2.4" anyway? no yes
What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.24-21-rt/build/include]
Extracting the sources of the vmmon module.
Building the vmmon module.
Unknown VMware Server 2.0.0 build 116503 detected. Building for Server 1.0.0.
Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config2/vmmon-only'
make -C /lib/modules/2.6.24-21-rt/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-21-rt'
CC [M] /tmp/vmware-config2/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config2/vmmon-only/linux/driverLog.o
CC [M] /tmp/vmware-config2/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config2/vmmon-only/common/comport.o
CC [M] /tmp/vmware-config2/vmmon-only/common/cpuid.o
In file included from include/asm/bitops.h:2,
from /tmp/vmware-config2/vmmon-only/./include/vcpuset.h:74,
from /tmp/vmware-config2/vmmon-only/./include/modulecall.h:23,
from /tmp/vmware-config2/vmmon-only/common/vmx86.h:19,
from /tmp/vmware-config2/vmmon-only/common/hostif.h:18,
from /tmp/vmware-config2/vmmon-only/common/cpuid.c:15:
include/asm/bitops_32.h:9:2: error: #error only <linux/bitops.h> can be included directly
make[2]: *** [/tmp/vmware-config2/vmmon-only/common/cpuid.o] Error 1
make[1]: *** _module_/tmp/vmware-config2/vmmon-only Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-21-rt'
make: *** http://vmmon.ko Error 2
make: Leaving directory `/tmp/vmware-config2/vmmon-only'
Unable to build the vmmon module.
For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/go/unsup-linux-products" and
"http://www.vmware.com/go/unsup-linux-tools".
Execution aborted.
btone 96 posts since
***********************************************************************************************
Dec 9, 2007 5. Re: problem with vmware-config.pl Oct 30, 2008 2:52 AM
in response to: Kimnguon I am wondering about the compiler version warning. what the output from:
dpkg -l|grep gcc
ls -la /usr/bin/gcc*
btone 96 posts since
****************************************************************************************************************
Dec 9, 2007 6. Re: problem with vmware-config.pl Oct 30, 2008 3:15 AM
in response to: btone ok, checked on my system, it seem that the hardy-update repository installed 4.2.4 where
the regular hardy repository includes 4.2.3:
http://packages.ubuntu.com/hardy/gcc-4.2
http://packages.ubuntu.com/hardy-updates/gcc-4.2
I think you have two options:
1) use old gcc
• remove your current gcc: sudo aptitude purge gcc
• then remove all hardy-updates from /etc/apt/source.list
• run sudo aptitude update && sudo aptitude upgrade
• install gcc again - now it should install gcc 4.2.3
2) use other kernel
• try to install kernel 2.6.24-19: sudo aptitude install linux-image-2.6.24-19-server or
linux-image-2.6.24-19-generic
• for these two kernels the modules are included in vmware server 2 so no need to compile them avoiding all
the problems you got.
• of course you need to boot this kernel then...
regards
btone
Kimnguon 4 posts since
*****************************************************************************************
Oct 27, 2008 7. Re: problem with vmware-config.pl Oct 30, 2008 3:24 AM
in response to: btone It works! thanks so much for your help!
Kimnguon
btone 96 posts since
Dec 9, 2007 8. Re: problem with vmware-config.pl Oct 30, 2008 3:42 AM
in response to: Kimnguon useless post ...


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu 8.10 安装vmware server 2 失败 如何解决?
帖子发表于 : 2008-11-02 21:26 

注册: 2006-01-18 18:11
帖子: 254
送出感谢: 0 次
接收感谢: 0 次
ubuntu 8.10下可以正常安装vmware server 2.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu 8.10 安装vmware server 2 失败 如何解决?
帖子发表于 : 2009-05-25 10:30 

注册: 2009-05-23 14:11
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
:em01


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译