有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?(已测试,可以兼容)

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
华铸
帖子: 58
注册时间: 2005-07-12 16:04
来自: 中国 珠海
送出感谢: 0
接收感谢: 0

有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?(已测试,可以兼容)

#1

帖子 华铸 » 2008-10-31 23:58

由于经常需要用到网上银行,所以我高度依赖虚拟机,昨天晚上就下载8.10了,但就是不敢装,生怕跟VMware Server 2.0不兼容,白天用虚拟机装了个8.10,准备测试在其下安装VMware Server 2.0,但安装必备包时,总报告找不到 linux-kernel-devel这个包,我试过几个源了,都没有,不知道有哪位高人知道为什么,有装好的吗?
上次由 华铸 在 2008-11-04 12:19,总共编辑 1 次。
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#2

帖子 xhy » 2008-11-01 0:38

virtualbox 挺好
目前负债150多万
华铸
帖子: 58
注册时间: 2005-07-12 16:04
来自: 中国 珠海
送出感谢: 0
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#3

帖子 华铸 » 2008-11-01 9:37

虽然我没有用过virtualbox,但我相信它一定挺好的,群众的眼睛是雪亮的,但萝卜青菜各有所好。

当你需要将公司的业务系统部署于虚拟机之上,弄不好会失业时,我想你就会考虑究竟选萝卜还是青菜了。 :em09
alteeno
帖子: 254
注册时间: 2006-01-18 18:11
送出感谢: 0
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#4

帖子 alteeno » 2008-11-02 21:29

应该不需要linux-kernel-devel包,你安装linux-headers包没有?这个是必需的.
lalo
帖子: 1
注册时间: 2006-12-11 0:37
送出感谢: 0
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#5

帖子 lalo » 2008-11-03 16:48

我之前也不成功 后来去官方下了最新的版本 安装成功! 你试试
华铸
帖子: 58
注册时间: 2005-07-12 16:04
来自: 中国 珠海
送出感谢: 0
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#6

帖子 华铸 » 2008-11-03 17:10

linux-headers包是安装好的了。

这几天没留意,VMware Server出了新版本,VMware Server 2 for Linux Operating Systems.
Version 2.0.0 | 122956 - 10/29/08,我下载试试,有结果后反馈回来。

谢谢。
华铸
帖子: 58
注册时间: 2005-07-12 16:04
来自: 中国 珠海
送出感谢: 0
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#7

帖子 华铸 » 2008-11-03 17:13

忘记说一点,总是报告内核版本不对,如何解决。

The directory of kernel headers (version 2.6.27-7-generic) does not match your
running kernel (version 2.6.27-7-server). Even if the module were to compile
successfully, it would not load into the running kernel.
华铸
帖子: 58
注册时间: 2005-07-12 16:04
来自: 中国 珠海
送出感谢: 0
接收感谢: 0

Re: 有人试过在Ubuntu 8.10 下安装VMware Server 2.0吗?

#8

帖子 华铸 » 2008-11-04 11:06

已成功安装并测试,一切正常。经过测试,Ubuntu 8.10桌面版+VMware Server 2.0是完全兼容的。

之所以出现上面的问题,是因为:
1.由于我担心Ubuntu 8.10与VMware Server 2.0不兼容,所以我用VMware EXS 3i创建里一个虚拟机,装了8.10服务器版,并在其上装VMware Server 2.0进行测试,由于我以前装VMware Server时,都安装linux-kernel-devel包(经过测试,这个包确实不是必需的),而8.10的源里又没有这个包,造成第一个问题。
2.由于我安装的是Ubuntu Server版,所以我用linux-kernel-headers包安装的内核头文件与当前内核版本不一致,只要安装linux-headers-2.6.27-7-server包即可解决版本不一致的问题。
回复

回到 “虚拟机和虚拟化”