当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-04 19:04 

注册: 2008-07-15 12:51
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
在vmware station 6.5 build 118166中装ubuntu8.10后的无法启动桌面的3D效果,不知道怎么才能解决问题,请高手指教。不知道是不是显示卡驱动的问题,如果是,怎么才能安装上驱动啊,我的显示卡是NV GF4 MX4000的,分辨率现在可以用1024*768。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-04 19:44 

注册: 2008-06-14 9:29
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
虚拟机里开不了3D


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-04 20:51 

注册: 2008-06-14 15:01
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
呵呵,大家可能还不知道,从vmware6.5版本起就可以在虚拟机开3D了,不过楼主的问题还是待高手解决吧


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-05 9:03 

注册: 2008-11-05 9:00
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也有同样的问题需要解决, 希望有高手过来解决下! 非常感谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-07 21:27 

注册: 2008-05-01 20:34
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
不会是没装VM-TOOLS


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-07 22:59 

注册: 2005-11-28 0:25
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
开点窗口透明之类的是可以的,但开compiz-fusion,不行。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-07 23:23 

注册: 2008-10-30 13:11
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
等待高手解决,目前也遇到了这个问题

是在不行打算直接光盘安装了阿!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-08 10:15 
头像

注册: 2008-09-07 14:47
帖子: 194
送出感谢: 0 次
接收感谢: 0 次
同意5楼意见。没装vmware-tools就等于是没装虚拟系统的驱动程序。虚拟系统中的显卡驱动和你真实系统的显卡不相干的。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-08 12:35 
头像

注册: 2008-10-23 19:01
帖子: 458
地址: 乌有之乡
送出感谢: 0 次
接收感谢: 0 次
且仅且是开”3D“。vmware-tools装约等于没装,但移动文件方便了,不像是驱动的所为。想开真正的3D效果,还是等下下个版本吧。


_________________
心中自是的,便是愚昧人


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-09 11:32 

注册: 2008-04-13 9:47
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
Workstation 3-D好像只在Guest 为Windows 可以,


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-09 17:53 

注册: 2008-11-09 14:10
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
在vmware里安装完window xp后是默认没开启的,首先在硬件方面物理机的显卡必须有OpenGL 2.0加速功能 下面开始正题

1.确保vmware里的windows XP处于关闭或者power off状态

2.选择此虚拟机,并在菜单中选择”VM”>”Settings”>”Hardware”>”Display.

3在”Monitors”选项中,如果虚拟机被设成使用多个显示器,此设置却只对一个显示器有效.

4 在”3D Graphics”选项,确保选择框已选上,并且单击”OK”

5开启虚拟机的电源,安装VMware Tools.一般就开启Direct3D了(可用dxdiag查看)

6.现在能3-D应用程序了
另外可安装DirectX 9.0c 下载
www.microsoft.com/downloads/search.aspx ... tegoryid=2


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-14 7:22 

注册: 2008-07-15 12:51
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我安装了vm-toolS工具了,可是还是不能启用3D效果 :em20


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-14 16:32 

注册: 2008-11-14 15:27
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我的也是,我用的VM版本跟你的一样,而且我也正确安装了vmware tools,3D选项也正确选择上了,就是无法启动特效,就是运行视觉效果里的正常和扩展也不行,一运行就提示无法启用桌面效果,我在网上查了一下,可能vmware6.5只支持XP中的3D,也就是说虚拟的系统必须是XP才支持,其它的好像还不可以,也不知道是不是这样,真希望有高手能够解决这个问题,不会又要让我们等待下一个版本吧。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-14 17:01 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
maples 写道:
在vmware里安装完window xp后是默认没开启的,首先在硬件方面物理机的显卡必须有OpenGL 2.0加速功能 下面开始正题

1.确保vmware里的windows XP处于关闭或者power off状态

2.选择此虚拟机,并在菜单中选择”VM”>”Settings”>”Hardware”>”Display.

3在”Monitors”选项中,如果虚拟机被设成使用多个显示器,此设置却只对一个显示器有效.

4 在”3D Graphics”选项,确保选择框已选上,并且单击”OK”

5开启虚拟机的电源,安装VMware Tools.一般就开启Direct3D了(可用dxdiag查看)

6.现在能3-D应用程序了
另外可安装DirectX 9.0c 下载
http://www.microsoft.com/downloads/sear ... tegoryid=2

这个基本是正解,但是只对XP或者vista客户机有效。
实际上vmware的官方文档中说了,现在客户机可以支持Direct3D了,但还不支持OpenGL,而Compiz用的正是OpenGL,所以……
vista的DWM用的是Direct3D,要是虚拟机中装vista的话应该可以支持3D flip桌面特效,大家可以测试一下 :em01


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 求助!在vmware station 6.5 build 118166中装ubuntu8.10后的3D效果问题
帖子发表于 : 2008-11-15 12:19 

注册: 2008-11-03 11:43
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
楼上说的已经很详尽了,基本就是这样的,虚拟机的驱动和硬件无关,用的是VM的驱动封装包。目前的6.5版暂时还不支持Open GL。无法在ubuntu里启用3D特效的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译