求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [未解决]

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
xiaoshut
帖子: 23
注册时间: 2008-11-01 23:38
送出感谢: 0
接收感谢: 0

求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [未解决]

#1

帖子 xiaoshut » 2008-11-05 15:11

安装一路回车后 使用 vmware 命令 出现错误提示:
vmware is installed, but it has not been (correctly) configured
for this system. To (re-)configure it, invoke the following command:
/usr/bin/vmware-config.pl.

貌似需要进入/usr/bin/ 下 ./vmware-config.pl
按照提示进入/usr/bin 下输入 ./vmware-config.pl 出现:
Stopping VMware services:
Virtual machine monitor done

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the theme icons?
[/usr/share/icons] /usr/share/icons 回车~!
翻译 : 在哪个目录,你想要安装的主题图标?

The path "/usr/share/applications/VMware.desktop" does not exist currently.
This program is going to create it, including needed parent directories. Is
this what you want? [yes] yes
这个计划是要创建它,包括所需的父目录。是这就是你想要的?

In which directory do you want to install the application's icon?
[/usr/share/pixmaps] /usr/share/pixmaps
在哪个目录,你要安装应用程序的图标?

Trying to find a suitable vmmon module for your running kernel.
None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]
试图找到一个合适的vmmon模块为您的运行内核。
没有预先建立vmmon模块VMware工作站是适合您
运行内核。你想这个计划,试图建立vmmon模块
您的系统(你需要有一个C编译器安装在您的系统) ?
这里出现问题咯:选择YES 输入如下:
None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.27-7-generic/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Unknown VMware Workstation 6.0.5 build 109488 detected. Building for Workstation 6.0.0.
Using 2.6.x kernel build system.
make:进入目录'/tmp/vmware-config6/vmmon-only'
make -C /lib/modules/2.6.27-7-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.27-7-generic'
CC [M] /tmp/vmware-config6/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config6/vmmon-only/./include/x86.h:24,
from /tmp/vmware-config6/vmmon-only/linux/driver.h:15,
from /tmp/vmware-config6/vmmon-only/linux/driver.c:53:
/tmp/vmware-config6/vmmon-only/./include/x86paging.h:61:1: warning: "PTE_PFN_MASK" redefined
In file included from include/asm/paravirt.h:7,
from include/asm/irqflags.h:55,
from include/linux/irqflags.h:57,
from include/asm/system.h:11,
from include/asm/processor.h:17,
from include/linux/prefetch.h:14,
from include/linux/list.h:6,
from include/linux/module.h:9,
from /tmp/vmware-config6/vmmon-only/linux/driver.c:16:
include/asm/page.h:22:1: warning: this is the location of the previous definition
In file included from /tmp/vmware-config6/vmmon-only/linux/vmhost.h:13,
from /tmp/vmware-config6/vmmon-only/linux/driver.c:84:
/tmp/vmware-config6/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: 没有该文件或目录
/tmp/vmware-config6/vmmon-only/linux/driver.c:171: 错误: 初始值设定项里有未知的字段‘nopage’
/tmp/vmware-config6/vmmon-only/linux/driver.c:172: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config6/vmmon-only/linux/driver.c:175: 错误: 初始值设定项里有未知的字段‘nopage’
/tmp/vmware-config6/vmmon-only/linux/driver.c:176: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config6/vmmon-only/linux/driver.c: 在函数‘__LinuxDriver_Ioctl’中:
/tmp/vmware-config6/vmmon-only/linux/driver.c:1781: 错误: 提供给函数‘smp_call_function’的实参太多
make[2]: *** [/tmp/vmware-config6/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config6/vmmon-only] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.27-7-generic'
make: *** [vmmon.ko] 错误 2
make:离开目录“/tmp/vmware-config6/vmmon-only”
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.
上次由 xiaoshut 在 2008-11-07 18:56,总共编辑 2 次。
xiaoshut
帖子: 23
注册时间: 2008-11-01 23:38
送出感谢: 0
接收感谢: 0

Re: 求解:ubuntu8.10 中安装vmware 6 配置中出现的问题

#2

帖子 xiaoshut » 2008-11-05 19:25

:em09 终于解决~!
wget -c http://www.insecure.ws/warehouse/vmware ... 7-2.tar.gz
下载了这个就好了, 重新配置完成~

参考地址: http://ubuntu-tutorials.com/2008/11/01/ ... 7-generic/
头像
snleo
帖子: 50
注册时间: 2008-05-29 6:49
送出感谢: 0
接收感谢: 0
联系:

Re: 求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [已解决]

#3

帖子 snleo » 2008-11-05 21:38

我也有同样的问题。试过了不少方法。不过到最后还是无法解决问题。要么运行的时候报告vmmod版本不符,要么就是换成另一种错误。

情急之下,下个新的vmware 6.5,图形化安装,问题一下子解决。
xiaoshut
帖子: 23
注册时间: 2008-11-01 23:38
送出感谢: 0
接收感谢: 0

Re: 求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [已解决]

#4

帖子 xiaoshut » 2008-11-05 23:06

要么运行的时候报告vmmod版本不符 我也碰到了, 好郁闷`1还要对 vmmod动手脚,郁闷哈 `1 解决不了,等待高手回帖`!
刘文学
帖子: 2
注册时间: 2008-11-04 16:32
送出感谢: 0
接收感谢: 0

Re: 求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [已解决]

#5

帖子 刘文学 » 2008-11-06 9:38

2楼的你确认一下能用不能,我之前跟你一样,虽然编译过去了,虽然能够打开vmware但是启动不了里面的虚拟机。
cootme
帖子: 7
注册时间: 2008-10-30 11:38
送出感谢: 0
接收感谢: 0

Re: 求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [已解决]

#6

帖子 cootme » 2008-11-07 15:48

hi,大家好。
我也装过好几次vmware了。但是每次装完后,在虚拟winxp系统的时候 出现键盘 的键功能不对。
比如:笔记本键盘上的 上下左右键 功能都不对。按向下的键,结果 windows 的开始菜单出来了!!!!!不知道大家有没有这样的键盘不对的问题?

我的系统:
ubuntu: Linux cootme-laptop 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux
vmware: VMware-workstation-6.0.5-109488.i386.tar.gz

有任何的建议可以直接联系我:QQ (1015319987)
xiaoshut
帖子: 23
注册时间: 2008-11-01 23:38
送出感谢: 0
接收感谢: 0

Re: 求解:ubuntu8.10 中安装vmware 6 配置中出现的问题 [已解决]

#7

帖子 xiaoshut » 2008-11-07 18:55

刘文学 写了:2楼的你确认一下能用不能,我之前跟你一样,虽然编译过去了,虽然能够打开vmware但是启动不了里面的虚拟机。
忘记 把 已解决去掉了 , 我错了, 4楼我已经回答了,和3楼一样的问题,麻烦
回复

回到 “虚拟机和虚拟化”