求助:虚拟机安装的上网问题

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
zcy
帖子: 4
注册时间: 2006-06-03 14:06
送出感谢: 0
接收感谢: 0

求助:虚拟机安装的上网问题

#1

帖子 zcy » 2006-06-04 13:39

用虚拟机VMware安装了Ubuntu,网络连接选择的是NAT,但是还是上不了网,请问还需要做什么设置阿,
主机里的本地连接需要和虚拟机的共享么?
garconcn
帖子: 14
注册时间: 2006-01-13 22:10
送出感谢: 0
接收感谢: 0

#2

帖子 garconcn » 2006-06-07 21:32

我也有这个问题,求教
LaoBai_2006
帖子: 4
注册时间: 2006-06-24 15:05
送出感谢: 0
接收感谢: 0

#3

帖子 LaoBai_2006 » 2006-06-24 15:35

我没有做更多设置,直接在 VMWare Workstation 5.5 上安装的 Ubuntu 6.06,安装完成就可以上网了,只要保证主机的 Internet 连接有效,Manage Virtual Networks 没有更改、没有出问题就应该没问题。我现在就是在用虚拟机中的 Ubuntu 里用 FireFox 浏览本网站的。如果是在有 DHCP 的网络里我会选桥接(Bridged),这样主机和虚拟机可以有两个有效 IP。
zyanplus
帖子: 7
注册时间: 2006-07-05 15:45
送出感谢: 0
接收感谢: 0

#4

帖子 zyanplus » 2006-07-06 16:11

我也遇到相同的问题了!
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

#5

帖子 qianwx » 2006-07-08 15:03

启动虚拟机之前最好保证你的网络已经拨号连通Internet。反正我这么做之后,安装完Ubuntu便能立即上网
江风山月
帖子: 5
注册时间: 2006-07-23 16:28
送出感谢: 0
接收感谢: 0

#6

帖子 江风山月 » 2006-07-24 13:29

我用NAT的啊,装完就可以上网了。
反倒是本来想用Static IP的,后来没有配置成功。
还在学习 Ubuntu过程中^_^
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#7

帖子 5451vs5451 » 2006-07-24 23:12

江风山月 写了:我用NAT的啊,装完就可以上网了。
反倒是本来想用Static IP的,后来没有配置成功。
还在学习 Ubuntu过程中^_^
用NAT最好把虚拟机的网络接口设成dhcp。
当然也可以用静态IP,然后指定网关。
但是不要把网关搞错了。NAT服务器用的不是主机的IP。
一般情况,如果主机IP是192.168.46.1,
那么NAT服务器的IP就是192.168.46.2。
Joseph.Lea
帖子: 39
注册时间: 2006-08-29 15:03
送出感谢: 0
接收感谢: 0

#8

帖子 Joseph.Lea » 2006-09-24 3:37

你们是怎么用NAT的,我的NAT显示的是灰色,不能选啊!
jasonding
帖子: 46
注册时间: 2006-09-30 22:54
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 jasonding » 2006-10-01 9:42

Joseph.Lea 写了:你们是怎么用NAT的,我的NAT显示的是灰色,不能选啊!
先将虚拟机关闭,再选择编辑,这个时候应该可以选NAT了
回复

回到 “虚拟机和虚拟化”