当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : KVM-79 released
帖子发表于 : 2008-11-16 0:39 

注册: 2008-04-08 9:27
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
78版本不稳定,在安装XP的时候,选择格式化分区,键盘上下键老不好用,而且装完系统后,老是有
windows writing delay的问题。

79已出,试试
kvm-79 [12 nov 2008]

* merge qemu-svn
o fix qcow2 problems with scsi
o 'info chardev' monitor command
* device assignment userspace (Amit Shah, Muli Ben Yehudah, Ben-Ami Yassour, Weidong Han, Or Sagi, Nir Peleg, Glauber Costa, Xiantao Zhang)
* multiple processor infrastructure for ppc (Hollis Blanchard)
*

fix error handling in eventfd() emulation (Mark McLoughlin)
*

handle large mtu with virtio-net (Mark McLoughlin)
* move x86 specific device assignment code to x86 files (Christian Ehrhardt)
* fix 'pci_add' command descriptor (Weidong Han)
* enable pci function level reset for device assignment (Sheng Yang)
* fix incorrect handling of aliases gfns (Izik Eidus)
* ppc optimizations (Hollis Blanchard, Christian Ehrhardt)
* disallow guests from setting memory type when using EPT (Sheng Yang)
* fix cpuid leaf 11 loop termination (Nitin A Kamble)
* fix cpuid multiple leaf iteration (Nitin A Kamble)
* fix ia64 uniprocessor build (Xiantao Zhang)
* fix ppc Kbuild constraints (Hollis Blanchard)
* fix pit initialization memory leak


_________________
XP on Thinkpad T43
ubuntu on Thinkpad X61 with XP on KVM


页首
 用户资料  
 
2 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-16 9:37 

注册: 2008-04-08 9:27
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
79版本一样在安装xp的格式化分区的时候,键盘上下键还是不能用。
注意启动的时候不能家-no-acpi这会导致xp无法启动。
其他的还有待测试。 :em02


_________________
XP on Thinkpad T43
ubuntu on Thinkpad X61 with XP on KVM


页首
 用户资料  
 
3 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-17 22:25 
头像

注册: 2007-11-25 13:29
帖子: 6800
地址: 新疆博乐
系统: Ubuntu 12.04/14.04
送出感谢: 32
接收感谢: 84
还没用过,有空试试也


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来


页首
 用户资料  
 
4 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-18 14:59 

注册: 2008-04-08 9:27
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
用了一段时间,还算稳定,等待进一步的使用。 :em09


_________________
XP on Thinkpad T43
ubuntu on Thinkpad X61 with XP on KVM


页首
 用户资料  
 
5 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-19 9:16 

注册: 2008-01-13 15:09
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
楼上几位,我编译的时候怎么老是提示出错呢?能简单写个教程吗?
我安装的是8。10版本
运行如下命令:
sudo apt-get install gcc libsdl1.2-dev zlib1g-dev libasound2-dev linux-kernel-headers pkg-config libgnutls-dev

出现错误提示如下:

软件包 linux-kernel-headers 是一个由下面的软件包提供的虚拟软件包:
linux-libc-dev 2.6.27-7.16
请您明确地选择一个来进行安装。
E: 软件包 linux-kernel-headers 还没有可供安装的候选者


页首
 用户资料  
 
6 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-19 13:28 

注册: 2008-04-08 9:27
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
seanland 写道:
楼上几位,我编译的时候怎么老是提示出错呢?能简单写个教程吗?
我安装的是8。10版本
运行如下命令:
sudo apt-get install gcc libsdl1.2-dev zlib1g-dev libasound2-dev linux-kernel-headers pkg-config libgnutls-dev

出现错误提示如下:

软件包 linux-kernel-headers 是一个由下面的软件包提供的虚拟软件包:
linux-libc-dev 2.6.27-7.16
请您明确地选择一个来进行安装。
E: 软件包 linux-kernel-headers 还没有可供安装的候选者

这个需要安装的,源里就有,根据你当前的内核版本来更新就行。
编译很简单:
./configure
make
sudo make install
就可以了

如果一直更新的话,8.10的最新内核应该是2.6.27-8了。update一下就可以了。


_________________
XP on Thinkpad T43
ubuntu on Thinkpad X61 with XP on KVM


页首
 用户资料  
 
7 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-25 8:42 

注册: 2008-01-13 15:09
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
chengzh 写道:
seanland 写道:
楼上几位,我编译的时候怎么老是提示出错呢?能简单写个教程吗?
我安装的是8。10版本
运行如下命令:
sudo apt-get install gcc libsdl1.2-dev zlib1g-dev libasound2-dev linux-kernel-headers pkg-config libgnutls-dev

出现错误提示如下:

软件包 linux-kernel-headers 是一个由下面的软件包提供的虚拟软件包:
linux-libc-dev 2.6.27-7.16
请您明确地选择一个来进行安装。
E: 软件包 linux-kernel-headers 还没有可供安装的候选者

这个需要安装的,源里就有,根据你当前的内核版本来更新就行。
编译很简单:
./configure
make
sudo make install
就可以了

如果一直更新的话,8.10的最新内核应该是2.6.27-8了。update一下就可以了。

我编译的时候出错如下:(UBUNTU8。10)
./configure --prefix=/usr/local/kvm --audio-drv-list="alsa oss" --enable-mixemu

Error: zlib check failed
Make sure to have the zlib libs and headers installed.
怎么解决啊


页首
 用户资料  
 
8 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-25 14:34 

注册: 2008-04-08 9:27
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
seanland 写道:
chengzh 写道:
seanland 写道:
楼上几位,我编译的时候怎么老是提示出错呢?能简单写个教程吗?
我安装的是8。10版本
运行如下命令:
sudo apt-get install gcc libsdl1.2-dev zlib1g-dev libasound2-dev linux-kernel-headers pkg-config libgnutls-dev

出现错误提示如下:

软件包 linux-kernel-headers 是一个由下面的软件包提供的虚拟软件包:
linux-libc-dev 2.6.27-7.16
请您明确地选择一个来进行安装。
E: 软件包 linux-kernel-headers 还没有可供安装的候选者

这个需要安装的,源里就有,根据你当前的内核版本来更新就行。
编译很简单:
./configure
make
sudo make install
就可以了

如果一直更新的话,8.10的最新内核应该是2.6.27-8了。update一下就可以了。

我编译的时候出错如下:(UBUNTU8。10)
./configure --prefix=/usr/local/kvm --audio-drv-list="alsa oss" --enable-mixemu

Error: zlib check failed
Make sure to have the zlib libs and headers installed.
怎么解决啊

感觉好像无zlib库,不用带那些参数了,默认的./configure就够用了。


_________________
XP on Thinkpad T43
ubuntu on Thinkpad X61 with XP on KVM


页首
 用户资料  
 
9 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-25 15:51 

注册: 2008-11-09 2:53
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
为什么我MAKE的时候出现这样的信息的
Makefile:2: config.mak: 没有该文件或目录
make: *** 没有规则可以创建目标“config.mak”。 停止。


我/.configure时是得到这样的信息
Install prefix /usr/local
BIOS directory /usr/local/share/qemu
binary directory /usr/local/bin
Manual directory /usr/local/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path /root/kvm-79/qemu
C compiler gcc
Host C compiler gcc
ARCH_CFLAGS -m32
make make
install install
host CPU i386
host big endian no
target list x86_64-softmmu
gprof enabled no
sparse enabled no
profiler no
static build no
-Werror enabled no
SDL support no
curses support no
mingw32 support no
Audio drivers oss
Extra audio cards
Mixer emulation no
VNC TLS support yes
TLS CFLAGS
TLS LIBS -lgnutls
kqemu support no
kvm support yes
CPU emulation yes
brlapi support no
Documentation no
NPTL support yes
vde support no
AIO support yes
KVM support yes
The error log from compiling the libSDL test is:
/tmp/qemu-conf--17494-.c:1:17: error: SDL.h: 没有该文件或目录
/tmp/qemu-conf--17494-.c: 在函数‘main’中:
/tmp/qemu-conf--17494-.c:3: 错误: ‘SDL_INIT_VIDEO’未声明(在此函数内第一次使用)
/tmp/qemu-conf--17494-.c:3: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
/tmp/qemu-conf--17494-.c:3: 错误: 所在的函数内也只报告一次。)
ERROR: QEMU requires SDL or Cocoa for graphical output
To build QEMU without graphical output configure with --disable-gfx-check
Note that this will disable all output from the virtual graphics card
except through VNC or curses.
Usage: ./configure [options]

Options include:
--arch=ARCH architecture to compile for (i386)
--cross-prefix=PREFIX prefix for cross compile
--prefix=PREFIX where to install things (/usr/local)
--with-patched-kernel don't use external module
--with-kvm-trace Enable kvm_trace
--kerneldir=DIR kernel build directory (/lib/modules/2.6.27-8-generic/build)
--qemu-cflags=CFLAGS CFLAGS to add to qemu configuration
--qemu-ldflags=LDFLAGS LDFLAGS to add to qemu configuration

Any additional option is given to qemu's configure verbatim; including:

--enable-sparse enable sparse checker
--disable-sparse disable sparse checker (default)
--disable-werror disable compilation abort on warning
--disable-sdl disable SDL
--enable-cocoa enable COCOA (Mac OS X only)
--enable-mixemu enable mixer emulation
--disable-brlapi disable BrlAPI
--disable-vnc-tls disable TLS encryption for VNC server
--disable-curses disable curses output
--disable-bluez disable bluez stack connectivity
--disable-vde disable support for vde network
--disable-aio disable AIO support
--disable-cpu-emulationdisables use of qemu cpu emulation code
--disable-libfdt disables use of libfdt support for device tree


希望你们教教我,我是新手,谢谢


_________________
生活TIPS网 http://www.minitips.com.cn
UCHOME插件


页首
 用户资料  
 
10 楼 
 文章标题 : Re: KVM-79 released
帖子发表于 : 2008-11-26 10:54 

注册: 2008-01-13 15:09
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
mindong 写道:
为什么我MAKE的时候出现这样的信息的
Makefile:2: config.mak: 没有该文件或目录
make: *** 没有规则可以创建目标“config.mak”。 停止。


我/.configure时是得到这样的信息
Install prefix /usr/local
BIOS directory /usr/local/share/qemu
binary directory /usr/local/bin
Manual directory /usr/local/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path /root/kvm-79/qemu
C compiler gcc
Host C compiler gcc
ARCH_CFLAGS -m32
make make
install install
host CPU i386
host big endian no
target list x86_64-softmmu
gprof enabled no
sparse enabled no
profiler no
static build no
-Werror enabled no
SDL support no
curses support no
mingw32 support no
Audio drivers oss
Extra audio cards
Mixer emulation no
VNC TLS support yes
TLS CFLAGS
TLS LIBS -lgnutls
kqemu support no
kvm support yes
CPU emulation yes
brlapi support no
Documentation no
NPTL support yes
vde support no
AIO support yes
KVM support yes
The error log from compiling the libSDL test is:
/tmp/qemu-conf--17494-.c:1:17: error: SDL.h: 没有该文件或目录
/tmp/qemu-conf--17494-.c: 在函数‘main’中:
/tmp/qemu-conf--17494-.c:3: 错误: ‘SDL_INIT_VIDEO’未声明(在此函数内第一次使用)
/tmp/qemu-conf--17494-.c:3: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
/tmp/qemu-conf--17494-.c:3: 错误: 所在的函数内也只报告一次。)
ERROR: QEMU requires SDL or Cocoa for graphical output
To build QEMU without graphical output configure with --disable-gfx-check
Note that this will disable all output from the virtual graphics card
except through VNC or curses.
Usage: ./configure [options]

Options include:
--arch=ARCH architecture to compile for (i386)
--cross-prefix=PREFIX prefix for cross compile
--prefix=PREFIX where to install things (/usr/local)
--with-patched-kernel don't use external module
--with-kvm-trace Enable kvm_trace
--kerneldir=DIR kernel build directory (/lib/modules/2.6.27-8-generic/build)
--qemu-cflags=CFLAGS CFLAGS to add to qemu configuration
--qemu-ldflags=LDFLAGS LDFLAGS to add to qemu configuration

Any additional option is given to qemu's configure verbatim; including:

--enable-sparse enable sparse checker
--disable-sparse disable sparse checker (default)
--disable-werror disable compilation abort on warning
--disable-sdl disable SDL
--enable-cocoa enable COCOA (Mac OS X only)
--enable-mixemu enable mixer emulation
--disable-brlapi disable BrlAPI
--disable-vnc-tls disable TLS encryption for VNC server
--disable-curses disable curses output
--disable-bluez disable bluez stack connectivity
--disable-vde disable support for vde network
--disable-aio disable AIO support
--disable-cpu-emulationdisables use of qemu cpu emulation code
--disable-libfdt disables use of libfdt support for device tree


希望你们教教我,我是新手,谢谢

我也是新手,同样遇到了你的问题,用个最笨的办法解决了:
在新立得里搜索 libSDL,把所有搜出的包全部安装,再重新安装KVM


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译