今天安装vmware server 1.0.8mware出现问题了。。。

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
yuyou_1985
帖子: 9
注册时间: 2008-04-02 17:11
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

今天安装vmware server 1.0.8mware出现问题了。。。

#1

帖子 yuyou_1985 » 2008-12-02 9:33

本来昨天运行的好好的,后来因为usb的网卡在虚拟机里识别有点问题,就把vmware server给删除了,装上了vmware player测试正常,想换回vmware server, 并进行安装的时候出现了下面的错误:

Building the vmnet module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config1/vmnet-only'
make -C /lib/modules/2.6.24-22-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-22-generic'
CC [M] /tmp/vmware-config1/vmnet-only/driver.o
CC [M] /tmp/vmware-config1/vmnet-only/hub.o
CC [M] /tmp/vmware-config1/vmnet-only/userif.o
CC [M] /tmp/vmware-config1/vmnet-only/netif.o
CC [M] /tmp/vmware-config1/vmnet-only/bridge.o
CC [M] /tmp/vmware-config1/vmnet-only/procfs.o
CC [M] /tmp/vmware-config1/vmnet-only/smac_compat.o
SHIPPED /tmp/vmware-config1/vmnet-only/smac_linux.x386.o
LD [M] /tmp/vmware-config1/vmnet-only/vmnet.o
Building modules, stage 2.
MODPOST 1 modules
WARNING: could not find /tmp/vmware-config1/vmnet-only/.smac_linux.x386.o.cmd for /tmp/vmware-config1/vmnet-only/smac_linux.x386.o
CC /tmp/vmware-config1/vmnet-only/vmnet.mod.o
LD [M] /tmp/vmware-config1/vmnet-only/vmnet.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-22-generic'
cp -f vmnet.ko ./../vmnet.o
make: Leaving directory `/tmp/vmware-config1/vmnet-only'
Unable to make a vmnet module that can be loaded in the running kernel:
insmod: error inserting '/tmp/vmware-config1/vmnet.o': -1 File exists
There is probably a slight difference in the kernel configuration between the
set of C header files you specified and your running kernel. You may want to
rebuild a kernel based on that directory, or specify another directory.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.


前面的vmware player已经卸载了,系统是ubuntu 8.04 LTS, 安装上最新的updates了。。。会不会是内核的问题,太新了之类的。请高手指教。。。
Dell D630 T7250, 2G RAM, 120G HDD...
Windows XP SP2 + VMware Server 1.0.6 + Ubuntu 8.0.4 LTS
回复

回到 “虚拟机和虚拟化”