当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:VM player使用时虚拟机网速太低的问题
帖子发表于 : 2009-02-21 10:55 

注册: 2009-02-21 10:47
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:em01 我安装的双系统,winxp sp2 和 ubuntu8.10.我在xp下使用vm station安装了winxp sp2和redflag两个虚拟机。在xp下使用这两个虚拟机,上网速度还可以。启动到ubuntu里,使用VM player启动winxp里的两个虚拟机,网速特别慢,可以ping通,但打不开网页。如何解决?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:VM player使用时虚拟机网速太低的问题
帖子发表于 : 2009-02-21 10:59 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
是不是设置的虚拟网卡类型不对了啊?


_________________
关注我的blog: ε==3


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:VM player使用时虚拟机网速太低的问题
帖子发表于 : 2009-02-23 12:59 

注册: 2009-02-21 10:47
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:em01 我用的是桥接的方式。把虚拟机文件考到别人的机器上,在window xp环境下,用VM player打开虚拟机,网页正常。但在ubuntu环境下,用VM player打开虚拟机,网页就卡不开。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:VM player使用时虚拟机网速太低的问题
帖子发表于 : 2009-02-23 13:03 

注册: 2009-02-21 10:47
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:em01 我是想用VM player在U盘或是移动硬盘运行一个移动的虚拟机,这个系统可以在windows 或是ubuntu下运行,并能使用网络。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助:VM player使用时虚拟机网速太低的问题
帖子发表于 : 2009-04-21 19:43 

注册: 2009-02-21 10:47
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
经过我的不懈努力,终于把这个问题解决了,问题出在虚拟机的连接网络方式不应该是“桥接”,而是“NAT”。我现在用的是vmplayer2.5.2。安装vmplayer2.5.2后,自动安装两个网卡vmnet1何vmnet8。把虚拟机的网络连接网络方式改为“NAT”,在虚拟机上网络设置,为DHCP(自动获得),DNS也为自动获得。再在虚拟上启动浏览器,就可以上网了,速度特快。关于用于“桥接”方式网速慢的问题,我也不清楚,希望大家给些意见,看过一个网友说可以在ubuntu里设置虚拟机的网速的帖子,但还是有些不明白。这样就可以用一个U盘随身携带你的虚拟机文件了,好像带着一个本本了(还得有宿主机了)。

:em01 有个前提必须保证你的ubuntu系统能上网,这样虚拟机才能上网。在redflag里,我试过了,虚拟机在“桥接”和“NAT”方式都可以上网。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译