当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu8.04.2下VMware Server 1.0.7运行`GCC_3.4' not found
帖子发表于 : 2009-03-06 23:47 

注册: 2007-04-01 8:36
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
使用Vmware遇到了两个错误
    1)
安装完Vmware server后在终端运行vmware后出现
引用:
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4' not found (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4' not found (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4' not found (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)

参考论坛http://forum.ubuntu.org.cn/viewtopic.php?t=17220解决了
代码:
sudo rm usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1
sudo ln -sf /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1


    2)
vmx文件放在ntfs上启动不了
装完虚拟的XP后根分区空间明显不够了,将装了Xp的虚拟机文件夹“Windows XP Professional”移动到另外一块硬盘的Ntfs分区,就启动不了Windows XP Professional虚拟机。但将“Windows XP Professional”放到fat32上却正常!
试着只将最大的文件(虚拟机的磁盘镜像)放到ntfs分区也可以启动,不知道为什么。


_________________
Book:Fujitsu S6240
CPU:PM-740 HDD:Fujitsu80G
RAM:2GB System:Ubuntu 8.04.1
---------------
Linux Is Not Ugly Xp!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译