当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-05-23 17:17 

注册: 2008-01-12 11:55
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我用的是vmware-workstation_6.5.2-156736_i386.deb安装包
在运行vmware之前提示要先编译内核模块:
附件:
Screenshot-VMware Kernel Module Updater.png
Screenshot-VMware Kernel Module Updater.png [ 16.58 KiB | 被浏览 2082 次 ]


开始编译:
附件:
Screenshot-VMware Kernel Module Updater-1.png
Screenshot-VMware Kernel Module Updater-1.png [ 24.82 KiB | 被浏览 2431 次 ]

开始编译不久就报错:
附件:
Screenshot-Error.png
Screenshot-Error.png [ 13.15 KiB | 被浏览 2077 次 ]


/tmp/vmware-root/setup-11350.log文件内容如下:
5月 23 17:21:19.054: app| Log for VMware Workstation pid=13885 version=e.x.p build=build-91182 option=BETA
5月 23 17:21:19.293: app| Logging to /tmp/vmware-root/setup-13885.log
5月 23 17:21:20.988: app| Extracting the sources of the vmmon module.
5月 23 17:21:21.005: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.28-11-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.3.3

不知道问题出在哪里,请大侠们帮我看看


最后由 hoteby 编辑于 2009-05-23 17:41,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-05-23 17:31 

注册: 2008-01-12 11:55
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
启动vmware的过程:
sdyc@sdyc-desktop:~$ /usr/bin/vmware
Logging to /tmp/vmware-sdyc/setup-18243.log
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
VMWARE_LD_LIBRARY_PATH is already set, but it will be overridden.
VMWARE_LD_PRELOAD is already set, but it will be overridden.
VMWARE_PANGO_RC_FILE is already set, but it will be overridden.
VMWARE_GDK_PIXBUF_MODULE_FILE is already set, but it will be overridden.
VMWARE_GTK_IM_MODULE_FILE is already set, but it will be overridden.
VMWARE_FONTCONFIG_PATH is already set, but it will be overridden.
VMWARE_GTK2_RC_FILES is already set, but it will be overridden.
VMWARE_GTK_PATH is already set, but it will be overridden.
Logging to /tmp/vmware-root/setup-18814.logmodinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
GTK Panel of SCIM 1.4.7

modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
Stopping VMware services:
VMware Authentication Daemon done
VM communication interface socket family: done
Virtual machine communication interface done
Virtual machine monitor done
Blocking file system done
Virtual ethernet done
Using 2.6.x kernel build system.
make:进入目录'/tmp/vmware-root/modules/vmmon-only'
make -C /lib/modules/2.6.28-11-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.28-11-generic'
CC [M] /tmp/vmware-root/modules/vmmon-only/linux/driver.o
在包含自 /tmp/vmware-root/modules/vmmon-only/./include/x86.h:21 的文件中,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.h:15,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.c:87:
/tmp/vmware-root/modules/vmmon-only/./include/x86apic.h:83:1: 警告: “APIC_BASE_MSR”重定义
在包含自 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/fixmap_32.h:29 的文件中,
从 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/fixmap.h:5,
从 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/apic.h:8,
从 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/smp.h:13,
从 include/linux/smp.h:30,
从 include/linux/topology.h:33,
从 include/linux/mmzone.h:763,
从 include/linux/gfp.h:4,
从 include/linux/kmod.h:22,
从 include/linux/module.h:13,
从 /tmp/vmware-root/modules/vmmon-only/./include/compat_module.h:13,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.c:12:
/usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/apicdef.h:132:1: 警告: 这是先前定义的位置
在包含自 /tmp/vmware-root/modules/vmmon-only/./include/x86.h:24 的文件中,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.h:15,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.c:87:
/tmp/vmware-root/modules/vmmon-only/./include/x86paging.h:62:1: 警告: “PTE_PFN_MASK”重定义
在包含自 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/paravirt.h:7 的文件中,
从 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/irqflags.h:55,
从 include/linux/irqflags.h:57,
从 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/system.h:11,
从 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/processor.h:17,
从 include/linux/prefetch.h:14,
从 include/linux/list.h:6,
从 include/linux/module.h:9,
从 /tmp/vmware-root/modules/vmmon-only/./include/compat_module.h:13,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.c:12:
/usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/page.h:22:1: 警告: 这是先前定义的位置
在包含自 /tmp/vmware-root/modules/vmmon-only/linux/vmhost.h:13 的文件中,
从 /tmp/vmware-root/modules/vmmon-only/linux/driver.c:107:
/tmp/vmware-root/modules/vmmon-only/./include/compat_semaphore.h:9:27: 错误: asm/semaphore.h:没有该文件或目录
/tmp/vmware-root/modules/vmmon-only/linux/driver.c:177: 错误: 初始值设定项里有未知的字段‘nopage’
/tmp/vmware-root/modules/vmmon-only/linux/driver.c:178: 警告: 从不兼容的指针类型初始化
/tmp/vmware-root/modules/vmmon-only/linux/driver.c: 在函数‘LinuxDriverSyncCallOnEachCPU’中:
/tmp/vmware-root/modules/vmmon-only/linux/driver.c:1383: 错误: 提供给函数‘smp_call_function’的实参太多
/tmp/vmware-root/modules/vmmon-only/linux/driver.c: 在函数‘LinuxDriver_Ioctl’中:
/tmp/vmware-root/modules/vmmon-only/linux/driver.c:1965: 错误: 提供给函数‘smp_call_function’的实参太多
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.28-11-generic'
make[2]: *** [/tmp/vmware-root/modules/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmmon-only] 错误 2
make: *** [vmmon.ko] 错误 2
make:离开目录“/tmp/vmware-root/modules/vmmon-only”
modinfo: could not find module vmmon


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-05-25 11:28 
头像

注册: 2008-11-03 14:06
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
关注中···
没有遇到这问题,也不知道怎么解决


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-06-06 8:36 

注册: 2009-06-05 7:39
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样问题 大虾们解决下吧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-06-08 17:13 

注册: 2009-03-13 20:11
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
VMware官网上有bundle包,使用这个安装没有问题。
建议使用我说的方法,编译来编译去麻烦还解决不了问题,因为你不了解VMware的程序设计,呵呵,明知不可为而为之……


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-06-08 17:19 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
可能是Gcc版本对不上,或是缺少内核dev文件,一直用的Vbox,没搞过VMware,猜测而已。 :em20


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-06-14 14:51 
头像

注册: 2009-04-29 3:50
帖子: 309
送出感谢: 0 次
接收感谢: 0 次
楼主解决了吗?我也遇到了这个问题 :em20


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-06-16 16:52 

注册: 2009-02-20 1:50
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我在fedora下解决了这个问题,你们可以看看
http://communities.vmware.com/thread/20 ... 0&tstart=0
去这下载补丁,并安装。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-06-18 13:24 

注册: 2009-05-03 16:54
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
我也遇到!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-07-02 23:01 

注册: 2008-08-27 16:25
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也遇到这个问题啊,有什么比较好的解决办法吗?哪个大虾分享一下,或者告诉我怎么把这个不能用的卸载掉


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-10-22 15:33 

注册: 2009-04-05 13:54
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
删除方法 sudo ./usr/binvmware-uninstall.pl


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 帮我看看,我的Ubuntu9.04安装完VMware后,不能启动虚拟机
帖子发表于 : 2009-10-22 17:28 

注册: 2009-10-22 17:23
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也有这个不过一闪后黑屏了,用的是VMware6.0简化绿色版


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译