当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-06-11 15:48 

注册: 2007-02-04 16:48
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我在9.04上安装vmware workstation 6.0的时候,安装正常完成,在执行vmware-config.pl时,报了以下错误,恳请高手指导
Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config2/vmmon-only'
make -C /lib/modules/2.6.28-11-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.28-11-generic'
CC [M] /tmp/vmware-config2/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config2/vmmon-only/./include/x86.h:21,
from /tmp/vmware-config2/vmmon-only/linux/driver.h:15,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:84:
/tmp/vmware-config2/vmmon-only/./include/x86apic.h:79:1: warning: "APIC_BASE_MSR" redefined
In file included from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/fixmap_32.h:29,
from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/fixmap.h:5,
from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/apic.h:8,
from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/smp.h:13,
from include/linux/smp.h:30,
from include/linux/topology.h:33,
from include/linux/mmzone.h:763,
from include/linux/gfp.h:4,
from include/linux/kmod.h:22,
from include/linux/module.h:13,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:12:
/usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/apicdef.h:132:1: warning: this is the location of the previous definition
In file included from /tmp/vmware-config2/vmmon-only/./include/x86.h:24,
from /tmp/vmware-config2/vmmon-only/linux/driver.h:15,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:84:
/tmp/vmware-config2/vmmon-only/./include/x86paging.h:61:1: warning: "PTE_PFN_MASK" redefined
In file included from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/paravirt.h:7,
from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/irqflags.h:55,
from include/linux/irqflags.h:57,
from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/system.h:11,
from /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/processor.h:17,
from include/linux/prefetch.h:14,
from include/linux/list.h:6,
from include/linux/module.h:9,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:12:
/usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/page.h:22:1: warning: this is the location of the previous definition
In file included from /tmp/vmware-config2/vmmon-only/linux/vmhost.h:13,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:115:
/tmp/vmware-config2/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: No such file or directory
make[2]: *** [/tmp/vmware-config2/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/tmp/vmware-config2/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.28-11-generic'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config2/vmmon-only'
Unable to build the vmmon module.

ps,已经安装了linux-header


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-08-08 11:17 

注册: 2007-11-14 9:00
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我的也是。郁闷。在看。知道了告诉我一下。谢谢。ruohuyang@gmail.com


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-08-10 21:37 

注册: 2009-07-05 19:43
帖子: 294
送出感谢: 1
接收感谢: 0 次
下载最新的补丁文件


_________________
-----寂寞的存在,孤独的思考----


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-08-17 22:49 

注册: 2009-08-13 23:39
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
同样的问题,是这样的,VMware官网说是该程序现在还不支持9.04所用的内核,9.04应该是2.6.28,目前还不能在这上边make,还是改用VMware6.5吧。我尝试咱们新立得上的相关编译补丁,也不好用,同时,下载了VMware官方的vmware-any-any-update115,也不好用。
都是同样的错误,还是改用6.5把,就是好难用阿。装xp还要我序列号,我装的是深度精简版的,拿来的序列号,郁闷阿 :em20
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.28-14-generic'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-09-03 21:37 
头像

注册: 2008-07-25 11:36
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
这个问题有很多人都说过,我前两天也遇到了,不过没有解决,GOOGLE了一下,说是用最新的vmware-any-any-update116可以,但还是有这个错误!
所以换了6.5.3的,已经可以正常使用了!


附件:
Screenshot.png
Screenshot.png [ 631 KiB | 被浏览 888 次 ]

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-09-09 9:58 

注册: 2009-07-05 19:43
帖子: 294
送出感谢: 1
接收感谢: 0 次
下载这个最新补丁文件vmware-update-2.6.27-5.5.7-2.tar.gz就可以了。


_________________
-----寂寞的存在,孤独的思考----


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-09-09 11:04 

注册: 2009-09-09 10:36
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我正打算装呢,看来要先下个6.5版本了


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-09-22 15:57 
头像

注册: 2009-07-27 11:03
帖子: 239
地址: 广东 深圳
送出感谢: 0 次
接收感谢: 0 次
http://www.insecure.ws/warehouse/vmware ... 7-2.tar.gz 安装这个补丁就可以了。


_________________
服务器运维与架构 ha97.com


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求教在9.04上安装vmware workstation 6.0
帖子发表于 : 2009-10-12 17:54 

注册: 2009-10-12 17:51
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
vmware-update-2.6.27-5.5.7-2.tar.gz的补丁打不上去,内核低了一点。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译