当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-11 16:01 
头像

注册: 2008-08-06 17:27
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
各位老鸟,本人想在vwmare5.5上安装了ubuntu8.10,为了实现跟windows的文件共享,所以想安装一下tools,在安装vmware-tools的时候出现问题

附件:
1.JPG
1.JPG [ 15.53 KiB | 被浏览 1202 次 ]



后来有人说可以安装vmwar-ang-any-update可以解决这个问题,所以有安了any-update,可是安装过程又出现问题

附件:
2.JPG
2.JPG [ 11.13 KiB | 被浏览 1351 次 ]


希望哪位老鸟帮老弟解决一下,非常感谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-11 21:07 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
代码:
sudo apt-get install linux-headers-`uname -r`


_________________
Grub2 基础教程


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-11 22:52 

注册: 2009-06-09 22:04
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
楼主,你的问题解决了吗?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-12 9:10 
头像

注册: 2008-08-06 17:27
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
代码:
sudo apt-get install linux-headers-`uname -r`


貌似有问题呢,帮我再看一看

附件:
文件注释: 1
1.jpg
1.jpg [ 34.08 KiB | 被浏览 1188 次 ]



附件:
2.jpg
2.jpg [ 27.21 KiB | 被浏览 1186 次 ]



再帮老弟看看,还有没有其他方法!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-12 9:55 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
貌似启动的内核是2.6.27-7?

使用2.6.27-14的内核启动再试试。


_________________
Grub2 基础教程


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-12 14:30 

注册: 2009-04-02 9:39
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
1、一定要先安装 build-essential 软件,否则不能够顺利安装
命令:sudo apt-get install build-essential
2、要安装linux-headers 包,这个包要在配置VMware-tools之前装,即可以在安装VMware-tools前装,或者在成功安装了VMware-tools之后配置之前装,否则会提示找不到 C header files,要求你指定路径。可是这个linux-headers包要和你下载的ubuntu版本匹配,可以用命令:uname -a 来查看你安装的版本,
比如我的查看结果是:linux ubuntu 2.6.15-26-386,那么接下来就运行命令:
sudo apt-get install linux-headers-2.6.15-26-386
安装结果就是和我运行的内核匹配的包了。
3、如果没有在安装完成时配置的朋友可以运行它的配置文件来开始配置过程,我安装完1和2两个包后还是遇到了c header files找不到要求我指定路径的提示,我仔细看了后发现提示默认的路径和我安装的linux-headers的路径不同,只要写出新路径就可以继续配置过程了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-14 12:57 

注册: 2008-09-07 12:52
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
这好像是内核没有更新到最新的,
这是在vmare论坛上的一篇文章,不过是fedora的

引用:
vmware-distrib/lib/isoimages/linux.iso
# Create a temporary mount point
mkdir /mnt/vmtools-temp
# Mount the image
mount -o loop linux.iso /mnt/vmtools-temp
# Copy VMware Tools from the mount
cp /mnt/vmtools-temp/VMwareTools-5.5.2-29772.tar.gz /tmp/
# Unmount the image and tidy up
umount /mnt/vmtools-temp
rmdir /mnt/vmtools-temp
rm linux.iso
# Unpack VMware Tools to a temporary directory
cd /tmp/
tar zxvf VMwareTools-5.5.2-29772.tar.gz
7.进入解压目标目录,执行以下代码,一路回车按下来
cd /tmp/vmware-tools-distrib/
./vmware-install.pl
8.直到该步骤,拷贝粘贴第5步的路径,然后一直按回车,直到选择屏幕分辨率。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装vmware-tools出错!帮解决一下!
帖子发表于 : 2009-06-15 11:37 
头像

注册: 2008-08-06 17:27
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
liangdongjuan 写道:
1、一定要先安装 build-essential 软件,否则不能够顺利安装
命令:sudo apt-get install build-essential
2、要安装linux-headers 包,这个包要在配置VMware-tools之前装,即可以在安装VMware-tools前装,或者在成功安装了VMware-tools之后配置之前装,否则会提示找不到 C header files,要求你指定路径。可是这个linux-headers包要和你下载的ubuntu版本匹配,可以用命令:uname -a 来查看你安装的版本,
比如我的查看结果是:linux ubuntu 2.6.15-26-386,那么接下来就运行命令:
sudo apt-get install linux-headers-2.6.15-26-386
安装结果就是和我运行的内核匹配的包了。
3、如果没有在安装完成时配置的朋友可以运行它的配置文件来开始配置过程,我安装完1和2两个包后还是遇到了c header files找不到要求我指定路径的提示,我仔细看了后发现提示默认的路径和我安装的linux-headers的路径不同,只要写出新路径就可以继续配置过程了。


还是不行啊,总是说与内核不匹配,我运行
引用:
uname -a

显示的是2.6.28-11-generic,也安装了相应的包,可是问题依然存在。
附件:
1.jpg
1.jpg [ 24.21 KiB | 被浏览 1150 次 ]



页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译