当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-09 8:01 

注册: 2008-05-13 17:50
帖子: 148
送出感谢: 0 次
接收感谢: 0 次
错误一:
直接点击DEB包安装老是出现
error dependency is not satisfiable libpython2.6

错误二:
如果在命令行下运行sudo dpkg -i virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb
却出现
dpkg:依赖关系问题使得 virtualbox-3.0 的配置工作不能继续:
virtualbox-3.0 依赖于 libpython2.6 (>= 2.6);然而:
未曾安装软件包“libpython2.6”。
virtualbox-3.0 依赖于 libqt4-network (>= 4.5.0~+rc1);然而:
系统中 libqt4-network 的版本为 4.4.3-0ubuntu1.2。
virtualbox-3.0 依赖于 libqtcore4 (>= 4.5.0~+rc1);然而:
系统中 libqtcore4 的版本为 4.4.3-0ubuntu1.2。
virtualbox-3.0 依赖于 libqtgui4 (>= 4.5.0~+rc1);然而:
系统中 libqtgui4 的版本为 4.4.3-0ubuntu1.2。
dpkg:处理 virtualbox-3.0 (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:

我的系统里明明安装有libpython3.0的啊,怎么老是提示要有2.6版本的?
碰到依赖的问题实在是一愁莫展,哪位大侠路见不平拨刀相助一下啊!!!


_________________
你希望在你的葬礼上放什么歌曲
-------------------------------------------------------------------------
1.国歌,起来~~
2.其实不想走~~
3.解脱~~
4.常回家看看~~


页首
 用户资料  
 
2 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-09 9:23 

注册: 2008-05-03 16:43
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
提示不完全,依赖不是错在python上,而是错在libqt-network,libqtcore4上,virtualbox要求的版本比你系统中的版本要高。仔细看错误说明。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-09 10:32 
头像

注册: 2007-05-06 8:19
帖子: 7433
送出感谢: 0 次
接收感谢: 4
rpm的话,可以强行安装,挺有用的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-09 10:33 

注册: 2008-10-18 10:23
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
用aptitude install 应该能自动安装所需要的包吧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-09 22:04 

注册: 2008-05-13 17:50
帖子: 148
送出感谢: 0 次
接收感谢: 0 次
奇怪的是,在另外一个UBUNTU系统下却可以安装


_________________
你希望在你的葬礼上放什么歌曲
-------------------------------------------------------------------------
1.国歌,起来~~
2.其实不想走~~
3.解脱~~
4.常回家看看~~


页首
 用户资料  
 
6 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-10 21:55 
头像

注册: 2006-06-30 7:00
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
还是看virtualbox3.0的下载说明:
deb http://download.virtualbox.org/virtualbox/debian jaunty non-free
wget -q http://download.virtualbox.org/virtualb ... n_vbox.asc -O- | sudo apt-key add -
sudo apt-get install virtualbox-3.0

http://www.virtualbox.org/wiki/Linux_Downloads

我是这么干的。安装没有问题。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-10 21:56 
头像

注册: 2006-06-30 7:00
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
试试这个:
deb http://download.virtualbox.org/virtualbox/debian jaunty non-free
wget -q http://download.virtualbox.org/virtualb ... n_vbox.asc -O- | sudo apt-key add -
sudo apt-get install virtualbox-3.0

http://www.virtualbox.org/wiki/Linux_Downloads


页首
 用户资料  
 
8 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-10 22:46 

注册: 2008-05-13 17:50
帖子: 148
送出感谢: 0 次
接收感谢: 0 次
其实我也是按楼上的朋友的方式试过了,也是不行
不知道到底是怎么回事
我经常喜欢同时安装两个UBUNTU
可以参考学习,但是另一个UBUNTU却可以安装
都不知道自己是不是曾经删除错什么东西还是装多了什么东西:(

现在想起来如果两个UBUNTU有什么区别的话
就是之前一个装过VIRTUALBOX2.X,后面试过彻底删除
另一个还没有装过,所以可以直接安装3.0版的


_________________
你希望在你的葬礼上放什么歌曲
-------------------------------------------------------------------------
1.国歌,起来~~
2.其实不想走~~
3.解脱~~
4.常回家看看~~


页首
 用户资料  
 
9 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-10 23:07 
头像

注册: 2007-07-16 19:43
帖子: 1362
地址: tangshan
送出感谢: 0 次
接收感谢: 0 次
官方的deb包不支持自动安装依赖?


页首
 用户资料  
 
10 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-10 23:08 
头像

注册: 2007-07-16 19:43
帖子: 1362
地址: tangshan
送出感谢: 0 次
接收感谢: 0 次
可以考虑安装 通用的二进制包


页首
 用户资料  
 
11 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-10 23:09 
头像

注册: 2007-07-16 19:43
帖子: 1362
地址: tangshan
送出感谢: 0 次
接收感谢: 0 次
http://www.virtualbox.org/wiki/Linux_Downloads


页首
 用户资料  
 
12 楼 
 文章标题 : Re: SOS,无法安装virtualbox3.0
帖子发表于 : 2009-08-11 0:13 

注册: 2008-11-09 14:58
帖子: 951
送出感谢: 0 次
接收感谢: 0 次
源里不是现成的吗?


_________________
我是菜鸟,我怕啥!顶多重新装一次又怎么样?10几年来WINDOWS我们重新来过了多少次?
其实也就只会装装系统,其他一概不会
http://youngerlak.blog.163.com


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译