当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 10:42 

注册: 2009-04-24 22:41
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我目前的2.2.4一切OK,想升级到到最新的3.0.4。
代码:
sudo dpkg -i virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb
dpkg:关于含有 virtualbox-3.0 的 virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb:
 virtualbox-3.0 冲突于 virtualbox
  virtualbox-2.2 提供了 virtualbox 并已存在而且 已安装完毕。
dpkg:处理 virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb (--install)时出错:
 软件包相互冲突 - 将不安装 virtualbox-3.0
在处理时有错误发生:
 virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb

以为可能不能越级升级,就想着从3.0.0升到3.0.2再到3.0.4。
可连3.0.0现在都升不了,同样的提示冲突。(我不想卸载再安装,因为里面又很多重要东西。)
有人遇到和我一样的情况吗》?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 10:44 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
那就先删了再试试看?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 10:58 

注册: 2009-04-24 22:41
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
LS没仔细看我的原文吧,我不想卸载再安装阿,害怕不保险。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 11:00 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
这个...备份你的虚拟机文件先啦


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 11:00 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
必须卸载,再安装,还要自动编译些东西的。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 11:11 

注册: 2009-04-24 22:41
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
怎么卸载?apt-get remove 吗??


页首
 用户资料  
 
7 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 11:48 
头像

注册: 2009-07-19 21:03
帖子: 576
送出感谢: 0 次
接收感谢: 0 次
先cp你的虚拟磁盘,然后卸载VBox,再装3.0.4,再cp你的虚拟磁盘回去就OK了 :em01


_________________
Man->Wiki->Google->Froum->Get it :-)


页首
 用户资料  
 
8 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 12:36 

注册: 2008-11-13 16:03
帖子: 817
送出感谢: 0 次
接收感谢: 0 次
flyfeel 写道:
我目前的2.2.4一切OK,想升级到到最新的3.0.4。
代码:
sudo dpkg -i virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb
dpkg:关于含有 virtualbox-3.0 的 virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb:
 virtualbox-3.0 冲突于 virtualbox
  virtualbox-2.2 提供了 virtualbox 并已存在而且 已安装完毕。
dpkg:处理 virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb (--install)时出错:
 软件包相互冲突 - 将不安装 virtualbox-3.0
在处理时有错误发生:
 virtualbox-3.0_3.0.4-50677_Ubuntu_jaunty_i386.deb

以为可能不能越级升级,就想着从3.0.0升到3.0.2再到3.0.4。
可连3.0.0现在都升不了,同样的提示冲突。(我不想卸载再安装,因为里面又很多重要东西。)
有人遇到和我一样的情况吗》?



304 就是一陀X,居然要依赖python2。4,

还是300 好


_________________
HP ProBook4321s,I3+ATI
OS : Fedora + Debian

http://box-look.org/


页首
 用户资料  
 
9 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-27 13:30 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
flyfeel 写道:
LS没仔细看我的原文吧,我不想卸载再安装阿,害怕不保险。

没什么不保险的,当时从1.6升2.0的时候就是必须卸了再装的,虚拟机不会有任何变化


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
10 楼 
 文章标题 : Re: virtualbox不能从2.2.4 升级到3.0.4??
帖子发表于 : 2009-08-28 15:10 

注册: 2009-04-24 22:41
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
fzq5012 写道:

304 就是一陀X,居然要依赖python2。4,

还是300 好

奇怪,我装304时确要依赖python2.5!!!!!!!!!!!
可我是python2.6.2啊~~~~
这点也太垃圾了吧?难度要我降级python不成??
我觉得virtualbox从3.0开始就有点讨厌了!!!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译