当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu9.04下安装vmware-server-1.0.9问题
帖子发表于 : 2009-10-14 10:50 

注册: 2009-10-14 10:36
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
环境是ubuntu9.04,kernel是2.6.28-11-generic,已经build头文件,在安装的过程中,在build vmmon module的时候,出现错误。
大致的错误信息我提取了一些


================================================================================================
/tmp/vmware-config1/vmmon-only/./include/x86apic.h:79:1: 警告: “APIC_BASE_MSR”重定义
在包含自 /usr/src/linux-headers-2.6.28-11-generic/arch/x86/include/asm/fixmap_32.h:29 的文件中,
================================================================================================


================================================================================================
/tmp/vmware-config1/vmmon-only/linux/driver.c:146: 错误: 初始值设定项里有未知的字段‘nopage’
/tmp/vmware-config1/vmmon-only/linux/driver.c:147: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config1/vmmon-only/linux/driver.c:150: 错误: 初始值设定项里有未知的字段‘nopage’
/tmp/vmware-config1/vmmon-only/linux/driver.c:151: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config1/vmmon-only/linux/driver.c: 在函数‘LinuxDriver_Ioctl’中:
/tmp/vmware-config1/vmmon-only/linux/driver.c:1670: 错误: 提供给函数‘smp_call_function’的实参太多
make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.28-11-generic'
make: *** [vmmon.ko] 错误 2

================================================================================================


请问,有什么办法解决?谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu9.04下安装vmware-server-1.0.9问题
帖子发表于 : 2009-10-14 12:11 

注册: 2009-10-14 10:36
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
问题解决了:
说明一下:
问题主要在于比较老的vmware产品不被比较新的kernel识别,
简要的解决办法,去http://www.insecure.ws/下载vmware-update-xxxx.tar.gz
xxxx是kernel的版本号,注意的是这里的版本号是实验的版本号,你需要明白kernel的命名,简单的说2.6.27是实验版本,双号的2.6.28是稳定版本,
如果你的kernel是28的,你就下27的那个tar包。
下载后解压:
进入该目录:
sudo gcc -o update update.c
sudo ./runme.pl

问题解决。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu9.04下安装vmware-server-1.0.9问题
帖子发表于 : 2009-10-14 12:12 

注册: 2009-10-14 10:36
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
问题解决了:
说明一下:
问题主要在于比较老的vmware产品不被比较新的kernel识别,
简要的解决办法,去http://www.insecure.ws/下载vmware-update-xxxx.tar.gz
xxxx是kernel的版本号,注意的是这里的版本号是实验的版本号,你需要明白kernel的命名,简单的说2.6.27是实验版本,双号的2.6.28是稳定版本,
如果你的kernel是28的,你就下27的那个tar包。
下载后解压:
进入该目录:
sudo gcc -o update update.c
sudo ./runme.pl

问题解决。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译