[求助]Vmware的Windows没有声音

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

[求助]Vmware的Windows没有声音

#1

帖子 yesilike » 2006-09-19 15:16

Vmware server免费版,出现两个问题:

1)安装Windows xp pro HP oem版后提示需要激活。而我是HP的品牌机,直接安装Windows HP oem时是不需要激活的。
在Vm安装时,是选的iso,而不是CD安装。
去激活时,显示密匙不正确。
2)WWindows没有声音。怎样和ubuntu共用声卡?

求助!
上次由 yesilike 在 2006-09-20 22:00,总共编辑 1 次。
中国采购员 全力推广开源免费的ubuntu.
http://www.buyer.org.cn
图片
成为采购员的最佳捷径!免费的采购知识,采购培训...
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#2

帖子 5451vs5451 » 2006-09-19 18:16

1. 装个免激活版吧。
2. 声音的问题可以 去下一个vmwaredsp。
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

#3

帖子 yesilike » 2006-09-20 12:10

1)只能去下一个其它版的。只是觉得奇怪:正版的居然不能用在vmware上!
2)还是不行。能否说详细一点?
lihui@buyer:~/download/vmwaredsp-1.3$ sudo ./runme.sh
Password:

If you are using ESD, you can start VMware Workstation with 'vmwareesd',
and if you are using aRts, you can start VMware Workstation with 'vmwarearts'.

Enjoy.

lihui@buyer:~/download/vmwaredsp-1.3$ vmwareesd
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
进去了,但还是没声音。
中国采购员 全力推广开源免费的ubuntu.
http://www.buyer.org.cn
图片
成为采购员的最佳捷径!免费的采购知识,采购培训...
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#4

帖子 5451vs5451 » 2006-09-22 10:01

yesilike 写了: 进去了,但还是没声音。
看看右下方那个小喇叭图标上是不是有一个红叉,如果有的话,在上面单击右键,选择connect。
头像
夕阳
帖子: 192
注册时间: 2006-07-31 0:09
来自: 四季都好,若是你在
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 夕阳 » 2006-09-22 12:10

1)只能去下一个其它版的。只是觉得奇怪:正版的居然不能用在vmware上!
你的是个OEM版本的,貌似应该对应的特定的硬件吧,你看看你虚拟出来的硬件和你本身的一样么。呵呵。
Nothing is Sound..
头像
RGVR250
帖子: 49
注册时间: 2005-10-27 19:41
送出感谢: 0
接收感谢: 0

#6

帖子 RGVR250 » 2006-09-23 17:01

声音问题--->

下载这个补丁:vmwaredsp-1.3.tar.gz

http://my.opera.com/xuecan/homes/files/ ... 1.3.tar.gz

  解开,再cd到目录里执行:



# ./runme.sh



  即可。

  然后用“vmwareesd”或者“vmwarearts”来启动 VMWare ,那小红叉就不会再出现了。
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

#7

帖子 yesilike » 2006-09-25 22:23

RGVR250 写了:声音问题--->

下载这个补丁:vmwaredsp-1.3.tar.gz

http://my.opera.com/xuecan/homes/files/ ... 1.3.tar.gz

  解开,再cd到目录里执行:



# ./runme.sh



  即可。

  然后用“vmwareesd”或者“vmwarearts”来启动 VMWare ,那小红叉就不会再出现了。
我就是这样做的,但根本都找不到音频设备,也没有小喇叭。
在设备管理器里面,音频又正常。
附件
Screenshot-6.png
Screenshot-5.png
中国采购员 全力推广开源免费的ubuntu.
http://www.buyer.org.cn
图片
成为采购员的最佳捷径!免费的采购知识,采购培训...
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#8

帖子 5451vs5451 » 2006-09-26 9:04

到Settings里面手动添加一个Sound Adapter
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

#9

帖子 yesilike » 2006-09-26 21:36

是在VM目录下的setting吗?
Add不能用。
附件
Screenshot-7.png
中国采购员 全力推广开源免费的ubuntu.
http://www.buyer.org.cn
图片
成为采购员的最佳捷径!免费的采购知识,采购培训...
头像
huangzuobin
帖子: 176
注册时间: 2006-03-28 2:53
送出感谢: 0
接收感谢: 0

#10

帖子 huangzuobin » 2006-09-28 9:31

安装alsa-oss

代码: 全选

sudo apt-get install alsa-oss
sudo gedit
把vmware的图标托到编辑器里
把运行vmware的命令改成

代码: 全选

aoss vmware
[/code]
xmh0051
帖子: 10
注册时间: 2008-02-14 15:55
送出感谢: 0
接收感谢: 0
联系:

Re:

#11

帖子 xmh0051 » 2008-11-28 18:15

夕阳 写了:
1)只能去下一个其它版的。只是觉得奇怪:正版的居然不能用在vmware上!
你的是个OEM版本的,貌似应该对应的特定的硬件吧,你看看你虚拟出来的硬件和你本身的一样么。呵呵。
修改vmare 的bios
回复

回到 “虚拟机和虚拟化”