当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [分享]新手安装vmware-tools要注意的问题
帖子发表于 : 2006-09-23 22:45 

注册: 2006-05-19 22:04
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我在VMware下装的是ubuntu-alternate-6.06,很成功,但是在安装VMware-tools的时候遇到好多挫折,因为我也是个新手,所以跟以后再安装这个工具的新手们分享几点:
1、一定要先安装 build-essential 软件,否则不能够顺利安装
命令:sudo apt-get install build-essential
2、要安装linux-headers 包,这个包要在配置VMware-tools之前装,即可以在安装VMware-tools前装,或者在成功安装了VMware-tools之后配置之前装,否则会提示找不到 C header files,要求你指定路径。可是这个linux-headers包要和你下载的ubuntu版本匹配,可以用命令:uname -a 来查看你安装的版本,
比如我的查看结果是:linux ubuntu 2.6.15-26-386,那么接下来就运行命令:
sudo apt-get install linux-headers-2.6.15-26-386
安装结果就是和我运行的内核匹配的包了。
3、如果没有在安装完成时配置的朋友可以运行它的配置文件来开始配置过程,我安装完1和2两个包后还是遇到了c header files找不到要求我指定路径的提示,我仔细看了后发现提示默认的路径和我安装的linux-headers的路径不同,只要写出新路径就可以继续配置过程了。

后面就比较顺利了,要求你指定分辨率等,只要安装提醒进行就可以了,配置完重起一下VMware就好了。

我是一个新手,可能以后进行每一个操作都会遇到问题,但是通过查资料看论坛找到办法解决后写写心得说不定能让以后加入的朋友少走些弯路,也是很好的,在这里希望更多的朋友写分享,来分享自己的学习经历。让我们一起努力吧


_________________
linux 小菜鸟,希望有一天能变成大虾


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-14 9:17 

注册: 2006-10-13 11:25
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
谢谢!给新人提供很好的参考


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-17 12:03 

注册: 2006-10-17 11:15
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
十分感谢楼主,呵呵


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-18 15:19 
头像

注册: 2006-07-22 14:41
帖子: 126
地址: 火星
送出感谢: 0 次
接收感谢: 0 次
不错,谢谢楼主了...


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-20 14:44 

注册: 2006-10-08 8:52
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
更新sudo apt-get install build-essential 到 98%不动了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-21 15:20 

注册: 2006-10-12 22:17
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install build-essential
这个就进行不下去了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-28 14:15 

注册: 2006-10-28 0:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install build-essential
为什么黑屏了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-28 15:25 

注册: 2006-01-21 6:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
Edgy下面似乎装不上,装完了没有任何变化,还会提示没有安装VMTOOLS。无语了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-28 21:15 
头像

注册: 2006-08-13 2:04
帖子: 218
送出感谢: 0 次
接收感谢: 0 次
shemar 写道:
Edgy下面似乎装不上,装完了没有任何变化,还会提示没有安装VMTOOLS。无语了。

关于edgy,希望这里可以帮你:
http://www.linuxblog.cn/archives/91


_________________
My Blog


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-02 19:24 

注册: 2006-04-25 17:07
帖子: 370
送出感谢: 0 次
接收感谢: 0 次
学习,收藏了。
谢谢!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-11-03 0:20 

注册: 2006-09-21 21:37
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
太好了,呵呵,正找呢,谢谢lz了。


页首
 用户资料  
 
12 楼 
 文章标题 : 2.6.17-10-generic对应是哪个核心呀?是386或是686吗?
帖子发表于 : 2006-11-04 22:32 

注册: 2006-11-04 22:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我用uname -r时,系统告诉是2.6.17-10-generic,我不明白是什么意思?


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 2.6.17-10-generic对应是哪个核心呀?是386或是686吗?
帖子发表于 : 2006-11-19 1:50 

注册: 2006-11-18 23:51
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
linux_faner 写道:
我用uname -r时,系统告诉是2.6.17-10-generic,我不明白是什么意思?


就是这个版本嘛.... :lol: 我的也是

另:一个绝妙语句
代码:
sudo apt-get install build-essential linux-headers-`uname -r`


注意:符号`uname -r` 在键盘位置数字1左边。而不是单引号。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-11-24 23:32 

注册: 2006-10-23 0:37
帖子: 84
送出感谢: 0 次
接收感谢: 0 次
我是在ubuntu下用VMware Server装Windows的,呵呵,一切顺利


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-11-30 17:22 

注册: 2006-11-30 15:23
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
#apt-get install linux-headers-2.6.15-26-386
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 linux-headers-2.6.15-26-386


源里面只有linux-headers-2.6.15-23-386,楼主怎么更新的??请教!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译