[分享]如何跨过VMware Workstation 安装几乎不可避免的预编译模块这一步骤的障碍

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
quantumfang
帖子: 74
注册时间: 2006-11-14 10:44
送出感谢: 0
接收感谢: 1 次
联系:

[分享]如何跨过VMware Workstation 安装几乎不可避免的预编译模块这一步骤的障碍

#1

帖子 quantumfang » 2006-11-21 20:50

from http://www.linuxsir.org/bbs/showthread.php?p=1520129

论坛内写vmware安装经验的挺多,实际上,有几个帖子一看,就知道他没有真正安装过。安装一下,就会遇到预编译模块不能通过这一严重问题。

我按照linuxsir上的介绍安装成功。再次给出,方便后来人。

1, 下载官方VMware-workstation安装文件VMware-workstation-5.5.1-19175.tar.gz
http://download3.vmware.com/software/wkst/VMware-workstation-5.5.1-19175.tar.gz
2,下载最新的vmware-any-any-update(我下载了http://ftp.cvut.cz/vmware/vmware-any-any-update105.tar.gz
Linux下VMWare的安装,由于内核版本不一,而安装失败。有一个 vmware-any-any-update 的patch,可以解决这个问题.

Vmware-any-any-update,一个名叫Petr Vandrovec (vandrove@vc.cvut.cz)的人制作的。Petr Vandrovec ,From 捷克技术大学(布拉格捷克斯洛伐克技术大学) ,Czech Technical University in Prague http://www.cvut.cz
下载链接
http://ftp.cvut.cz/vmware/

3,解压缩VMware-workstation-5.5.1-19175.tar.gz产生vmware-distrib
4,进入vmware-distrib运行 vmware-install.pl 进行安装。
5,上一步安装到一定步骤基本会报错,这时解压缩 vmware-any-any-update执行runme.pl完成安装
6,执行/usr/bin/vmware启动。(有必要的话运行一下/usr/bin/vmware-config.pl配置一下)
头像
吴广德
帖子: 347
注册时间: 2006-10-26 9:24
系统: Ubuntu 18.04 LTS
来自: 中国-广西-南宁
送出感谢: 2 次
接收感谢: 0

#2

帖子 吴广德 » 2006-11-22 12:09

兄弟,VM5.5.2.29772 + Ubuntu 6.06完全可以直接安装,正常的很,不必那么麻烦的,呵呵
Ubuntu 18.04 LTS使用中......

主板:MSI Z97 gaming 9 ACK
CPU:I7 4790K
内存:DDR3 8G x 2 + 4G x 2 = 24G
硬盘:60G SSD(/) + 500G HD(/home)
显示器:Philips 274E5Q
xcity
帖子: 135
注册时间: 2006-09-20 17:11
送出感谢: 0
接收感谢: 0

#3

帖子 xcity » 2006-11-22 12:44

我很早就开始使用vmware,从windows到linux,从来就没有运行过runme.pl这个script。

vmware在linux下面安装的时候,需要编译对应你当前内核的网卡模块。vmware自带了很多已经编译成功的网卡模块,如果你的内核正好满足要求的情况下,就不用自己编译。如果你的系统很新,可能需要在安装最后阶段编译网卡模块。编译的过程都是自动的,只要你系统上编译的环境是完备的情况下,这个编译根本就不会出现任何错误。
quantumfang
帖子: 74
注册时间: 2006-11-14 10:44
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 quantumfang » 2006-11-23 11:07

我认为,6.06是比较完美的
我用 6.10,需要
还有fedora core 5需要

不是每个系统都这么顺利,所以我说“几乎”,意思是大多数

三楼的大侠有自己更好的办法,佩服
fuhuizn
帖子: 716
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 12 次
联系:

#5

帖子 fuhuizn » 2006-11-26 19:34

vmware workstation5.5.1在6.10下要补丁,
vm5.5.2和vm server都不需要
回复

回到 “虚拟机和虚拟化”