在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
yxyiyt
帖子: 1
注册时间: 2011-05-26 9:46
送出感谢: 0
接收感谢: 0

在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

#1

帖子 yxyiyt » 2011-05-30 9:49

本人一直在Ubuntu下使用 VMware player和VirtualBox。

最近把电脑的操作系统升级到Ubuntu 11.04,安装完成后看linux内核为:(Linux yxyiyt 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux)。在此环境下安装 VMware player 3.1.4非常正常没有任何问题。

但是电脑有时候启动时会出现紫屏(网上有太多电脑有这样的现象),我查了一些资料然后把linux内核升级到2.6.39-0-generic,这个时候Ubuntu 紫屏就没有了,和用Ubuntu 10.04一样非常正常。但是VMware player 3.1.4就不能使用了,VMware player启动时会报“Unable to build kernel module.”, “See log file /tmp/vmware-root/setup-15131.log for details.”,我看了log主要就是找不到2.6.39-0-generic的什么东西。

我现在只能把linux内核降到2.6.38-8-generic,让VMware player 3.1.4能在Ubuntu 11.04正常使用。

我觉得可能是VMware player 3.1.4对2.6.39-0-generic还不支持,需要把什么地方调一下,但是不太会找。寻求好心人的帮助。
1.png
1.png (35.57 KiB) 查看 1235 次
2.png


错误如下:
Nov 09 20:48:40.438: app-140073755526944| Log for VMware Workstation pid=5651 version=7.1.2 build=build-301548 option=Release
Nov 09 20:48:40.438: app-140073755526944| The process is 64-bit.
Nov 09 20:48:40.438: app-140073755526944| Host codepage=UTF-8 encoding=UTF-8
Nov 09 20:48:40.438: app-140073755526944| Logging to /tmp/vmware-root/setup-5651.log
Nov 09 20:48:40.606: app-140073755526944| modconf query interface initialized
Nov 09 20:48:40.606: app-140073755526944| modconf library initialized
Nov 09 20:48:40.645: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.656: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.671: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.690: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.705: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.747: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.749: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.752: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.755: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.758: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.784: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.786: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.789: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.792: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.795: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.804: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.819: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.871: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.875: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.879: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.881: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.884: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.893: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.908: app-140073755526944| Your GCC version: 4.5
Nov 09 20:48:40.974: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.977: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.980: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.983: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:40.986: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:41.319: app-140073755526944| Trying to find a suitable PBM set for kernel 2.6.39-0-generic.
Nov 09 20:48:41.320: app-140073755526944| Building module vmmon.
Nov 09 20:48:41.320: app-140073755526944| Extracting the sources of the vmmon module.
Nov 09 20:48:41.343: app-140073755526944| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.39-0-generic/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.5.1
头像
remeber
论坛版主
帖子: 13005
注册时间: 2009-01-06 15:18
来自: 人间
送出感谢: 1 次
接收感谢: 22 次

Re: 在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

#2

帖子 remeber » 2011-05-30 9:56

不贴图真不知道还有错误。
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞
liujunout
帖子: 18
注册时间: 2009-01-28 9:09
送出感谢: 0
接收感谢: 0

Re: 在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

#3

帖子 liujunout » 2011-05-31 16:22

我也是,升级到11.04后,就出现了这个问题,同求解决方法。 :em05
liukunda
帖子: 10
注册时间: 2010-08-19 14:03
送出感谢: 0
接收感谢: 0

Re: 在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

#4

帖子 liukunda » 2011-05-31 21:50

我也是 所以删掉了 :em06
头像
ganni
帖子: 22
注册时间: 2011-06-06 10:51
送出感谢: 0
接收感谢: 0

Re: 在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

#5

帖子 ganni » 2011-07-08 15:33

怎么安装呀 :em06
当你需要困难时,我就会伸出援手.
wdmcja
帖子: 13
注册时间: 2010-10-18 17:34
送出感谢: 0
接收感谢: 0

Re: 在Ubuntu 11.04下安装VMware Player 3.1.4产生的问题求助

#6

帖子 wdmcja » 2011-07-11 15:44

遇到同样的问题,是vmware的问题,不支持最新的内核 ,需下至少的7.14版本的vmware才可以.....
回复

回到 “虚拟机和虚拟化”