当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 19:20 

注册: 2013-03-29 19:16
帖子: 6
系统: ubuntu12.10
送出感谢: 0 次
接收感谢: 0 次
root@zhou-HP-Pavilion-G4-NoteBook-PC:~# dpkg -i virtualbox-4.2_4.2.10-84104~Ubuntu~quantal_amd64.deb
dpkg: considering removing virtualbox in favour of virtualbox-4.2 ...
dpkg: no, cannot proceed with 卸载 virtualbox (--auto-deconfigure will help):
virtualbox-dkms 依赖于 virtualbox (>= 4.1.18-dfsg-1ubuntu1.1)
即将卸载 virtualbox。

dpkg: regarding virtualbox-4.2_4.2.10-84104~Ubuntu~quantal_amd64.deb containing virtualbox-4.2:
virtualbox-4.2 冲突于 virtualbox
virtualbox (版本为 4.1.18-dfsg-1ubuntu1.1)已存在并且 已安装。

dpkg: error processing virtualbox-4.2_4.2.10-84104~Ubuntu~quantal_amd64.deb (--install):
软件包相互冲突 - 将不安装 virtualbox-4.2
在处理时有错误发生:
virtualbox-4.2_4.2.10-84104~Ubuntu~quantal_amd64.deb


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 20:39 
头像

注册: 2011-06-07 14:20
帖子: 3866
系统: Mint18
送出感谢: 17
接收感谢: 65
先卸载virtualbox


_________________
wiki: ubuntu 技巧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 21:03 

注册: 2013-03-29 19:16
帖子: 6
系统: ubuntu12.10
送出感谢: 0 次
接收感谢: 0 次
已经在软件中心卸载了


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 21:08 

注册: 2013-03-29 19:16
帖子: 6
系统: ubuntu12.10
送出感谢: 0 次
接收感谢: 0 次
[img]/home/zhou/桌面/2013-03-29%2021:05:57的屏幕截图.png[/img]


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 21:22 

注册: 2013-03-29 19:16
帖子: 6
系统: ubuntu12.10
送出感谢: 0 次
接收感谢: 0 次
root@zhou-HP-Pavilion-G4-NoteBook-PC:~# dpkg -r virtualbox
dpkg: dependency problems prevent removal of virtualbox:
virtualbox-dkms 依赖于 virtualbox (>= 4.1.18-dfsg-1ubuntu1.1).

dpkg: error processing virtualbox (--remove):
依赖问题 - 不会执行卸载
在处理时有错误发生:
virtualbox
root@zhou-HP-Pavilion-G4-NoteBook-PC:~# dpkg -P virtualbox
dpkg: dependency problems prevent removal of virtualbox:
virtualbox-dkms 依赖于 virtualbox (>= 4.1.18-dfsg-1ubuntu1.1).

dpkg: error processing virtualbox (--purge):
依赖问题 - 不会执行卸载
在处理时有错误发生:
virtualbox


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 21:39 
头像

注册: 2011-06-07 14:20
帖子: 3866
系统: Mint18
送出感谢: 17
接收感谢: 65
代码:
sudo apt-get autoremove virtualbox-dkms virtualbox


_________________
wiki: ubuntu 技巧


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 不能安装virtualbox-4.2,新人求助!
帖子发表于 : 2013-03-29 22:14 

注册: 2013-03-29 19:16
帖子: 6
系统: ubuntu12.10
送出感谢: 0 次
接收感谢: 0 次
谢谢大神,成功解决!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译