当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : virtualbox的声音问题
帖子发表于 : 2007-03-23 16:35 
头像

注册: 2007-03-18 16:39
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
开了virtualbox后只能在虚拟机中使用声音,而真机中打开音乐或电影会提示找不到音频,或是卡死,不知大家有没有遇到此情况,怎么解决?我的系统是hiweed1.0,虚拟机中是winxp。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-23 22:29 
头像

注册: 2006-06-15 22:44
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
我的系统和你一样,但虚拟机中没有声音,也不知道是什么问题


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-25 9:44 

注册: 2007-03-01 22:54
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
虚拟机里面需要声音么?
我的虚拟机只是用来看看别人的word。别的都在linux里面做阿,要娱乐,还是用win吧


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-25 13:16 
头像

注册: 2007-03-18 16:39
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
发现vmware也有类似的问题:主机和虚拟计不能同时用声音。是我的混音设定有问题吗?
vmware还好,虚拟机中没发声时主机还可以用声音,vbox就不行了,虚拟机打开后主机再开音乐就死掉。
而且vbox没有关声卡的按钮。

要不是这个只认window$的学习光盘和讨厌的qq验证码,我才不想用虚拟机呢。
贴一下我的混音配置和错误,望高手解决:


附件:
文件注释: xfce的混音设定和音量属性,混音下面还有送个mic选项勾上了
Screenshot4.png
Screenshot4.png [ 432.56 KiB | 被浏览 3011 次 ]

文件注释: 虚拟机发声主机出错
Screenshot2.png
Screenshot2.png [ 253.49 KiB | 被浏览 2923 次 ]

文件注释: 主机下用音乐,虚拟机下错误
Screenshot1.png
Screenshot1.png [ 300.28 KiB | 被浏览 2871 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-25 13:20 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
enable audio ,我选的是oss audio driver ,xp sp2声音正常


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-25 13:37 
头像

注册: 2007-03-18 16:39
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
to楼上的,试过了无用,xp下声音已正常,只是xp和linux不能同时用声音,好像已是可以的?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-25 13:41 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
wonder 写道:
to楼上的,试过了无用,xp下声音已正常,只是xp和linux不能同时用声音,好像已是可以的?


我喜欢回帖不看帖


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-03-29 8:24 

注册: 2006-11-02 13:12
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
确实有这个问题
不知道怎么搞定
原来不知道,直到最近被迫在win下用word写论文
先是发现常常gaim不出声
ps -e一下发现积累了几十个aplay进程
音乐也听不到,只好win下用千千静听
1.36,1.38都一样
似乎也没搜索到啥有用的信息
有人知道如何解决嘛?还是等升级?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-02 20:58 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
我的完全没问题,驱动用alsa,两个系统可以同时发声,一边在主机上听音乐,一边开vbox,还可以听到xp的启动声音呢。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-02 21:39 

注册: 2006-11-02 13:12
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
gmlbh 写道:
我的完全没问题,驱动用alsa,两个系统可以同时发声,一边在主机上听音乐,一边开vbox,还可以听到xp的启动声音呢。

能不能把host版本,alsa版本写下来?
是不是只装了alsa-base包?还有没有装其他的alsa?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-04 16:02 

注册: 2006-12-16 10:19
帖子: 81
送出感谢: 1
接收感谢: 0 次
host和guest不能同时开声音
我也这样


_________________
Linux桌面中文网|http://linuxdesktop.cn/


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-04-04 16:23 
头像

注册: 2005-10-19 17:33
帖子: 2052
送出感谢: 0 次
接收感谢: 0 次
主机和Virtualbox的声音都用alsa
OSS的确很难多程序共享声卡


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-04-26 15:06 

注册: 2006-05-07 14:39
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
virtualBox用oss的话,不法混音。造成开vbox时,host上面的一些音频播放和视频软件要么卡死,要么就不出声。
如果virtualBox换成ALSA时,可以两头都发音。但vbox里面如果用QQ等音频对话时,QQ等软件会死掉。
现在还没找到解决的办法。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-12-08 23:22 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
问题是我下午全用OSS能行,现在却不行了……


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-02-29 13:20 
头像

注册: 2006-02-10 16:36
帖子: 2654
系统: Xubuntu14.04/Deepin
送出感谢: 13
接收感谢: 25
我也遇到这样的问题,而且是有时可以虚拟机宿主机同时使用声卡,有时候却不能,到现在也没有发现什么规律。虚拟机一直使用什么alsa声音驱动。主机是自动检测。


_________________
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译