当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : How to Install VMWare Server 1.0.2 on Ubuntu 7.04 Feisty(64)
帖子发表于 : 2007-04-05 15:22 

注册: 2006-02-27 20:45
帖子: 24
地址: 石家庄
系统: Ubuntu 13.04
送出感谢: 1
接收感谢: 0 次
Info:
Can we install Windows Xp on Ubuntu Feisty 64bit, the answer is right, but what should we do? The first thing is to install VMWare, and we will discuss the procedures in this article:

Requirments:
AMD64 Hardware
Ubuntu 7.04 Feisty Fawn OS
Windows XP with sp2 Setup CD
Internet Connection (at least 1 MB)

Procedures:

    1.We should have installed Ubuntu 7.04 Feisty Fawn on AMD74 Platform Successfully.

    2.We also have to downlaod VMware Server 1.0.2 Build 39867. (we can get it free from Vmware.com)

    3.Before setup, we have to install a few dependencies firstly.
代码:
sudo apt-get install linux-headers-`uname -r` build-essential xinetd


    4.Execute the installation script
代码:
sudo ./vmware-install.pl


    5.Problem & Solution:

    5.1. cannot find /bin directory error.
We can accept default if we don't know what to do, the only thing we should pay more attention is the directory where the Virtual Machines are stored. We must type “vmware/bin” or “vm/bin” instead of default“vm” or “vmware” directory, otherwise we will be told that cannot find the bin problem.

    5.2. unable to build vmmon module error.
We might see the following errors:
引用:
Unable to build the vmmon module.

The solution is :
代码:
cd /usr/lib/vmware/modules/source   

# /usr/lib/... may differ according to the actual setup directory.
代码:
sudo cp vmmon.tar vmmon.tar.old
                    sudo tar xvf vmmon.tar
                    sudo gedit vmmon-only/include/compat_kernel.h

Find line 21 ,
引用:
static inline _syscall1(int, compat_exit, int, exit_code);

replace with:
引用:
#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19)
static inline _syscall1(int, compat_exit, int, exit_code);
#endif

Then,
代码:
tar cvf vmmon.tar vmmon-only
                  rm -rf vmmon-only


    5.3. timestamp problem & solution:
引用:
Unable to get the last modification timestamp of the destination file /etc/vmware/ssl/rui.key.

Solution:
代码:
sudo apt-get install ia32-libs
                       sudo /usr/bin/vmware-config.pl


    6. Finish

At last, the VMWare Server is successfully installed.

Reference:

1. Step By Step Get Started
http://www.ubuntuforums.org/showthread.php?t=183209

2. Get Serial Number
http://register.vmware.com/content/download.html

3. Problem & Solution
http://blog.eshangrao.com/index.php/200 ... eisty-2620
http://ubuntuforums.org/showthread.php?t=337040
http://ubuntuforums.org/showthread.php?p=2331389


_________________
瞬间无意的相逢,
不觉深深已眷恋。
-------------------------------------------
http://laonianrenshouji.taobao.com
-------------------------------------------


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-08 8:35 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
我翻译一下。

如何在Ubuntu 7.04 Feisty(64bit)上安装VMWare Server 1.0.2
Info:
我们是否可以在Ubuntu Feisty 64bit上安装Windows XP呢?答案是肯定的,但是我们该怎么做呢?首先是安装VMWare,我们将在下面的这篇文章里讨论安装步骤。

要求:
支持AMD64bit的硬件
Ubuntu 7.04 Feisty Fawn 操作系统
Windows XP 带 sp2 包的安装盘
网络连接(最少1MB)

步骤:

1.我们首先要在AMD64bit平台上成功安装Ubuntu 7.04 Feisty Fawn。

2.下载VMWare Server 1.0.2 Build 39867.(可以从Vmware.com获得)

3.安装之前,我们先要安装一些依赖包。
代码:
sudo apt-get install linux-headers-`uname -r` build-essential xinetd


4.执行安装脚本
代码:
sudo ./vmware-install.pl


5.问题&解决方法

5.1 找不到/bin目录
如果我们不知道怎么做,我们可以以默认方式安装。唯一要注意的是虚拟机安装的目录。我们必须以“vmware/bin” 或者 “vm/bin”来代替默认的“vmware”或者“vm”目录,否则我们将遇到找不到bin目录的问题。

5.2 不能编译vmmon模块的错误
我们可能看到如下的错误提示:
引用:
Unable to build the vmmon module.


解决方法:
代码:
cd /usr/lib/vmware/modules/source


# /usr/lib/... 可能不同于实际安装的目录。

代码:
sudo cp vmmon.tar vmmon.tar.old
sudo tar xvf vmmon.tar
sudo gedit vmmon-only/include/compat_kernel.h


找到第21行,

引用:
static inline _syscall1(int, compat_exit, int, exit_code);


用下面的来替换

引用:
#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19)
static inline _syscall1(int, compat_exit, int, exit_code);
#endif


然后,

代码:
sudo tar cvf vmmon.tar vmmon-only
sudo rm -rf vmmon-only


5.3 时间截止问题和解决方法
我们可能看到如下的错误提示:

引用:
Unable to get the last modification timestamp of the destination file /etc/vmware/ssl/rui.key.


解决方法:
代码:
sudo apt-get install ia32-libs
sudo /usr/bin/vmware-config.pl


6. 完成

最后,VMWare Server安装成功

参考
1. Step By Step Get Started
http://www.ubuntuforums.org/showthread.php?t=183209

2. Get Serial Number
http://register.vmware.com/content/download.html

3. Problem & Solution
http://blog.eshangrao.com/index.php/200 ... eisty-2620
http://ubuntuforums.org/showthread.php?t=337040
http://ubuntuforums.org/showthread.php?p=2331389


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-05 21:14 
头像

注册: 2007-03-24 14:18
帖子: 188
送出感谢: 0 次
接收感谢: 0 次
这样的贴子竟沉然了。


_________________
喜欢黑暗并非厌恶光明


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-14 18:24 

注册: 2007-04-13 13:16
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我装好了vmware server,可是想通过iso映像文件安装xp,却是出现“non-bootable disk 80”的错误;
用另一个win2003的iso映像安装却无法显示怎么安装,黑黑的一片。有人知道怎么回事吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-06-23 17:41 

注册: 2007-01-25 20:12
帖子: 40
送出感谢: 0 次
接收感谢: 1
收藏!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译