当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 54 篇帖子 ]  前往页数 上一页  1, 2, 3, 4  下一页
作者 内容
16 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 12:17 
头像

注册: 2011-03-20 13:12
帖子: 4400
地址: 山东省寿光县
系统: Debian
送出感谢: 105
接收感谢: 966
fengtou 写道:
,解决方案是目前只能安装Fedora吗?

只要设法使用尽可能新的内核/graphics stack 即可


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户


页首
 用户资料  
 
17 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 12:19 

注册: 2009-08-04 16:33
帖子: 16403
送出感谢: 21
接收感谢: 1779
引用:
解决方案是目前能安装Fedora吗?

1. http://askubuntu.com/a/679709
The simplest solution for the time being the author has found (and you are probably not going to like this) was to run Fedora instead.
1-1. simplest 就表示有好幾個 裡面最簡單的一個

2. 這個暫時解決方案 就比較複雜一點
http://www.phoronix.com/scan.php?page=n ... Fixed-Mode


页首
 用户资料  
 
18 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 12:24 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
vickycq 写道:
fengtou 写道:
,解决方案是目前只能安装Fedora吗?

只要设法使用尽可能新的内核/graphics stack 即可


我的host-ubuntu-mate已经是最新的了,内核已经算是最新了吧?
还是要重新编译内核?
内核/graphics stack是什么意思?


页首
 用户资料  
 
19 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 12:28 

注册: 2009-08-04 16:33
帖子: 16403
送出感谢: 21
接收感谢: 1779
引用:
Intel:i5-6500CPU

引用:
product: Sky Lake Integrated Graphics [8086:1912]

試試
Intel 團隊 提供的 i915 適用於 16.04 (Release Date: 30 Aug, 2016 Version: 2.0.2)
https://01.org/linuxgraphics/downloads/ ... -os-v2.0.2
i915-4.6.3-4.4.0-dkms
https://01.org/linuxgraphics/downloads/ ... ck-release
http://blog.ffwll.ch/2016/03/neat-drmi9 ... or-46.html

還有其它配套程式 可以下載
https://01.org/linuxgraphics/downloads/ ... ck-release


页首
 用户资料  
 
20 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 12:46 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
poloshiao 写道:
引用:
Intel:i5-6500CPU

引用:
product: Sky Lake Integrated Graphics [8086:1912]

試試
Intel 團隊 提供的 i915 適用於 16.04 (Release Date: 30 Aug, 2016 Version: 2.0.2)
https://01.org/linuxgraphics/downloads/ ... -os-v2.0.2
i915-4.6.3-4.4.0-dkms
https://01.org/linuxgraphics/downloads/ ... ck-release
http://blog.ffwll.ch/2016/03/neat-drmi9 ... or-46.html

還有其它配套程式 可以下載
https://01.org/linuxgraphics/downloads/ ... ck-release


刚安装了
Intel® Graphics Update Tool 2.0.2 for Ubuntu* 16.04, 64-bit
但还是不行。

我现在是应该先把ubuntu-mate的4.4内核先升级到4.6内核,在重装一次上面的tool,对吧?


页首
 用户资料  
 
21 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 12:52 

注册: 2009-08-04 16:33
帖子: 16403
送出感谢: 21
接收感谢: 1779
引用:
但还是不行

不行 範圍太大 無法幫忙
把你的數據或回應 全部複製 貼上來


页首
 用户资料  
 
22 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 13:22 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
poloshiao 写道:
引用:
但还是不行

不行 範圍太大 無法幫忙
把你的數據或回應 全部複製 貼上來


已经升级内核到了4.7,也已经安装了intel的工具包,
但是一楼的问题依旧,vbox的回应和和smplayer的回应和原来一样无进展,
所以没有再重新发图。


页首
 用户资料  
 
23 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 14:12 
头像

注册: 2012-11-14 9:34
帖子: 511
系统: UM 16.04.2/17.04
送出感谢: 1
接收感谢: 34
fengtou 写道:
poloshiao 写道:
引用:
现在不是安装的问题

virtualbox 是 Ubuntu 套件庫供應 由 Ubuntu 團隊維護
virtualbox-5.1 是 Virtualbox 套件庫供應 由 Virtualbox 團隊維護
裡面打包的內容 可能大不同

建議
最近幾個版本 最好從 Virtualbox 套件庫安裝 問題比較少


两种安装我都试过,也重装过xubuntu尝试,还是不行,怀疑是硬件问题,
新的Intel:i5-6500CPU在看电影方面也有问题,但对新硬件我确实一窍不通,现在不知道怎办?
花费了不少钱升级,结果现在什么都用不到,之前还好好的除了慢点以外。


我们也在一台skylake机器上装过VirtualBox,完全没有问题。请参阅我们的装设步骤:

viewtopic.php?f=65&t=479549

" 文章标题 : 在UbuntuMate 16.04.1里装 VirtualBox 5.1.x"

另外,跟Skylake有关的"bpo"只是在3D加速时才用到,虽然已加入了Linux4.7核心,但目前跟VirtualBox可能会有冲突。我们根据一贯作风,能不加的元件,一概不加。


最后由 Ping-Wu 编辑于 2016-09-19 17:02,总共编辑了 1 次

页首
 用户资料  
 
24 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 16:52 

注册: 2009-08-04 16:33
帖子: 16403
送出感谢: 21
接收感谢: 1779
http://askubuntu.com/a/715006
Installing Linux Mint 17.3 Rosa solved it!
Mint 17.3 enabled i915_bpo driver automatically.

試試
Linux Mint 17.3 Rosa
https://www.linuxmint.com/release.php?id=26


页首
 用户资料  
 
25 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 17:36 
头像

注册: 2012-11-14 9:34
帖子: 511
系统: UM 16.04.2/17.04
送出感谢: 1
接收感谢: 34
poloshiao 写道:
http://askubuntu.com/a/715006
Installing Linux Mint 17.3 Rosa solved it!
Mint 17.3 enabled i915_bpo driver automatically.


i915_bpo driver在UbuntuMate 16.04.1里也有,请见附图:

附件:
lshw.png
lshw.png [ 51.77 KiB | 被浏览 780 次 ]



不过如前所述,Linix 4.4 核心里的i915_bpo driver没有3D加速功能。这个问题可以解决,但结果可能跟VirtualBox会不相容。(即: 不要理会error message.)

poloshiao 写道:
千万不要! :em09 :em09 :em09


页首
 用户资料  
 
26 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 18:50 

注册: 2009-08-04 16:33
帖子: 16403
送出感谢: 21
接收感谢: 1779
引用:
Intel:i5-6500CPU

1. viewtopic.php?p=3175714#p3175714
Intel 團隊 提供的 i915 適用於 16.04 (Release Date: 30 Aug, 2016 Version: 2.0.2)

2. i5-6500 在支援名單內
2-1. https://01.org/linuxgraphics/downloads/ ... ck-release
SUPPORTED HARDWARE
6th Generation Intel Core processors with Intel HD Graphics - Skylake
2-2. http://ark.intel.com/products/codename/ ... ylake#@All
請使用 6500 搜尋


页首
 用户资料  
 
27 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 19:24 

注册: 2013-05-26 6:58
帖子: 2008
系统: Debian 9
送出感谢: 845
接收感谢: 25
那个命令执行失败后提示看dmesg
dmesg的信息发出来看一下?
注意一定是先执行那个命令,然后立即执行dmesg
不然可能会看到不相关的信息


_________________
Linux桌面优化综合贴[2017.09.18](欢迎各位补充或指正误区)
[2016.03.10]会C语言但看不懂英文文档的点这里,一个用C语言编写的简陋学习工具
单硬盘通过iso文件实机安装Debian的方法
重启或操作fcitx时失去响应的一个解决方法,不妨试试看


页首
 用户资料  
 
28 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 22:18 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
Ping-Wu 写道:
fengtou 写道:
poloshiao 写道:
引用:
现在不是安装的问题

virtualbox 是 Ubuntu 套件庫供應 由 Ubuntu 團隊維護
virtualbox-5.1 是 Virtualbox 套件庫供應 由 Virtualbox 團隊維護
裡面打包的內容 可能大不同

建議
最近幾個版本 最好從 Virtualbox 套件庫安裝 問題比較少


两种安装我都试过,也重装过xubuntu尝试,还是不行,怀疑是硬件问题,
新的Intel:i5-6500CPU在看电影方面也有问题,但对新硬件我确实一窍不通,现在不知道怎办?
花费了不少钱升级,结果现在什么都用不到,之前还好好的除了慢点以外。


我们也在一台skylake机器上装过VirtualBox,完全没有问题。请参阅我们的装设步骤:

http://forum.ubuntu.org.cn/viewtopic.php?f=65&t=479549

" 文章标题 : 在UbuntuMate 16.04.1里装 VirtualBox 5.1.x"

另外,跟Skylake有关的"bpo"只是在3D加速时才用到,虽然已加入了Linux4.7核心,但目前跟VirtualBox可能会有冲突。我们根据一贯作风,能不加的元件,一概不加。



现在的问题不是不能安装VBOX,是已经装好了,但是只要启动虚拟电脑任务时就报错,报错图片在一楼已经贴出。
另外就是用smplayer看电影只能看原始尺寸,这个i5-6000的intel cpu确实很烦人。


页首
 用户资料  
 
29 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-19 22:22 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
poloshiao 写道:
http://askubuntu.com/a/715006
試試
Linux Mint 17.3 Rosa
https://www.linuxmint.com/release.php?id=26


试了一下Linux Mint 18,还是老样子


页首
 用户资料  
 
30 楼 
 文章标题 : Re: 为什么vbox不能启动任务?
帖子发表于 : 2016-09-20 0:17 
头像

注册: 2012-11-14 9:34
帖子: 511
系统: UM 16.04.2/17.04
送出感谢: 1
接收感谢: 34
fengtou 写道:
Ping-Wu 写道:
fengtou 写道:
poloshiao 写道:
引用:
现在不是安装的问题

virtualbox 是 Ubuntu 套件庫供應 由 Ubuntu 團隊維護
virtualbox-5.1 是 Virtualbox 套件庫供應 由 Virtualbox 團隊維護
裡面打包的內容 可能大不同

建議
最近幾個版本 最好從 Virtualbox 套件庫安裝 問題比較少


两种安装我都试过,也重装过xubuntu尝试,还是不行,怀疑是硬件问题,
新的Intel:i5-6500CPU在看电影方面也有问题,但对新硬件我确实一窍不通,现在不知道怎办?
花费了不少钱升级,结果现在什么都用不到,之前还好好的除了慢点以外。


我们也在一台skylake机器上装过VirtualBox,完全没有问题。请参阅我们的装设步骤:

viewtopic.php?f=65&t=479549

" 文章标题 : 在UbuntuMate 16.04.1里装 VirtualBox 5.1.x"

另外,跟Skylake有关的"bpo"只是在3D加速时才用到,虽然已加入了Linux4.7核心,但目前跟VirtualBox可能会有冲突。我们根据一贯作风,能不加的元件,一概不加。



现在的问题不是不能安装VBOX,是已经装好了,但是只要启动虚拟电脑任务时就报错,报错图片在一楼已经贴出。
另外就是用smplayer看电影只能看原始尺寸,这个i5-6000的intel cpu确实很烦人。


安装后不能启动,干啥? 当然执行虚拟电脑任务时也没有问题。

《补充》 这个error message "modprobe xboxdrv failed" 看起来很显然的是VirtualBox 的 kernel module (xboxdrv)的 source code 没有被根据“目前”的核心编译,因此与系统不相容。没有module,当然不能启动。解决的办法很多,但最简单的,我觉得还是规规矩矩的装Virtualbox。

另外"就是用smplayer看电影只能看原始尺寸,这个i5-6000的intel cpu确实很烦人"。Skylake 太新,又是封闭系统,Linux 核心无法马上跟上,这是可以理解的事。图形驱动器,更是要拖更长一段时间。如我在另帖提到的,AMD已开始开放他们的硬体,我们当然不可能期待Intel也这么做,不过也许我们应该对AMD的机器多一点注意。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 54 篇帖子 ]  前往页数 上一页  1, 2, 3, 4  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译