[问题]在ubuntu7.04 64位下安装VirtualBox出错

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
chpn
帖子: 415
注册时间: 2007-02-28 11:33
送出感谢: 0
接收感谢: 0

[问题]在ubuntu7.04 64位下安装VirtualBox出错

#1

帖子 chpn » 2007-04-18 23:48

在网上下载的VirtualBox-1.3.8_mdv2007.1-1.i586.rpm ,只能下这个包,另外还有一个是suse下的 ,其它的全是32位系统的包

chpn@chpn-desktop:~$ sudo rpm -ihv '/home/chpn/VirtualBox-1.3.8_mdv2007.1-1.i586.rpm'
error: 依赖性检测失败:
/bin/sh 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
bash 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libICE.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libIDL-2.so.0 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libSDL-1.2.so.0 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libSM.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libX11.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libXcursor.so.1 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libXext.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libasound.so.2 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6(GLIBC_2.0) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6(GLIBC_2.1) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6(GLIBC_2.1.2) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6(GLIBC_2.1.3) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6(GLIBC_2.2) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libc.so.6(GLIBC_2.3) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libcrypto.so.0.9.8 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libdl.so.2 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libdl.so.2(GLIBC_2.0) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libdl.so.2(GLIBC_2.1) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libgcc_s.so.1 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libgcc_s.so.1(GCC_3.0) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libgcc_s.so.1(GLIBC_2.0) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libglib-2.0.so.0 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libm.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libm.so.6(GLIBC_2.0) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libm.so.6(GLIBC_2.1) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libpng12.so.0 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libpthread.so.0 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libpthread.so.0(GLIBC_2.0) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libpthread.so.0(GLIBC_2.1) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libpthread.so.0(GLIBC_2.2) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libpthread.so.0(GLIBC_2.3.2) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libqt-mt.so.3 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
librt.so.1 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
librt.so.1(GLIBC_2.2) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libstdc++.so.6 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libstdc++.so.6(GLIBCXX_3.4) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libutil.so.1 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libuuid.so.1 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libxalan-c.so.110 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libxerces-c.so.27 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
libz.so.1 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要
rtld(GNU_HASH) 被 VirtualBox-1.3.8_mdv2007.1-1.i586 所需要


有谁知道,怎么样解决才能装上,刚安上64位的ubuntu速度满快的,想装个虚拟机,有朋友要视频的时候可以在虚拟机中的QQ上视频。另外有一些软件在linux下还找不到替代的也必需运行xp系统,现在心头有点急
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 skyx » 2007-04-19 1:16

晕,源里有

哦,64位的啊, 不知道

64位支持超大内存和超大硬盘, 现在适合做server

我估计32位还能风光二到三年。
chpn
帖子: 415
注册时间: 2007-02-28 11:33
送出感谢: 0
接收感谢: 0

#3

帖子 chpn » 2007-04-19 1:26

在源里没有找到
头像
yhlfh
帖子: 579
注册时间: 2006-09-02 20:42
来自: 东海明珠
送出感谢: 1 次
接收感谢: 2 次

#4

帖子 yhlfh » 2007-04-19 15:45

首先,i586, i686,不管是几86的,总归是86,也就是x86,就是32位,所以你下载这个本来就是错误的。
vbox是用于x86架构的虚拟机,它主页上写得很清楚。
什么事情不能干啊,你说来听听?
64位下虚拟机可以用qemu+kqemu
Life is like a box of chocolates, you never know what you're going to get.
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#5

帖子 windwiny » 2007-04-19 15:51

ubuntu 用 rpm 包???? 搞错没有

用 32 位的 deb包不行?
chpn
帖子: 415
注册时间: 2007-02-28 11:33
送出感谢: 0
接收感谢: 0

#6

帖子 chpn » 2007-04-19 18:11

32位的安装不起,64位的没有deb包
回复

回到 “虚拟机和虚拟化”