[问题]已经挂上NTFS-3G了 为什么VMWARE无法开启NTFS分区里的虚拟机? 在线等

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
头像
yanzilme
帖子: 253
注册时间: 2006-11-01 3:21
送出感谢: 0
接收感谢: 0

[问题]已经挂上NTFS-3G了 为什么VMWARE无法开启NTFS分区里的虚拟机? 在线等

#1

帖子 yanzilme » 2007-05-18 11:49

我把虚拟机拉到LINUX 的分区开启没问题,ntfs-3g也确定有挂上可正常读写
但是如果直接开启ntfs 分区上的虚拟机却会出现错误?
请问这何解?

谢谢
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#2

帖子 Element » 2007-05-18 14:54

权限问题?
用sudo开启虚拟机试试
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
yanzilme
帖子: 253
注册时间: 2006-11-01 3:21
送出感谢: 0
接收感谢: 0

#3

帖子 yanzilme » 2007-05-23 13:48

拜托帮我看一下
我的ntfs 可以挂上读写正常
但是无法开启ntfs 下的vm 创建的虚拟机
但是拉到ext3 的话是可以执行的
请邦我看一下是哪里出了问题,谢谢!
附件
Screenshot.jpg
头像
yanzilme
帖子: 253
注册时间: 2006-11-01 3:21
送出感谢: 0
接收感谢: 0

#4

帖子 yanzilme » 2007-05-27 12:00

顶!!
都没有人知道是怎么回事吗?
头像
ofewiofewo
帖子: 547
注册时间: 2007-06-02 14:56
送出感谢: 0
接收感谢: 0

#5

帖子 ofewiofewo » 2007-06-18 12:01

昨天用vmware一样遇到这个问题,到vmware.com的community搜了一通
似乎是需要在.vmx手工设置参数,希望这个参数有用:

代码: 全选

mainMem.useNamedFile=FALSE
Virtual machine fails to boot

I have some of my vms running on a NTFS filesystem mounted on a linux box using a ntfs-3g driver. The net effect is that the disk performance is relatively slow. Same could be said of USB 1.1 hard drives and network mounted drives. If you are running your VMs from any of these and your virtual machine fails to boot, try adding the following line to your *.vmx configuration file.

mainMem.useNamedFile = "False"

Hope you find these tips useful.
头像
yanzilme
帖子: 253
注册时间: 2006-11-01 3:21
送出感谢: 0
接收感谢: 0

#6

帖子 yanzilme » 2007-06-21 0:48

ofewiofewo 写了:昨天用vmware一样遇到这个问题,到vmware.com的community搜了一通
似乎是需要在.vmx手工设置参数,希望这个参数有用:

代码: 全选

mainMem.useNamedFile=FALSE
Virtual machine fails to boot

I have some of my vms running on a NTFS filesystem mounted on a linux box using a ntfs-3g driver. The net effect is that the disk performance is relatively slow. Same could be said of USB 1.1 hard drives and network mounted drives. If you are running your VMs from any of these and your virtual machine fails to boot, try adding the following line to your *.vmx configuration file.

mainMem.useNamedFile = "False"

Hope you find these tips useful.
谢谢!
这招真的有用!
给您磕头了 :D
回复

回到 “虚拟机和虚拟化”