[问题]vbox安装成功,但是没有声音?[截图]已解决

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

[问题]vbox安装成功,但是没有声音?[截图]已解决

#1

帖子 anddylf » 2007-06-07 22:48

研究了一下午的时间,终于把vbox成功的安装到了ubuntu7.04里了,好兴奋。新建一个虚拟机,并安装了deep in5.5 xp,非常不错!
但是,随着很多程序都成功安装以后,想听听歌,但是才发现这个系统没有声音,查看控制面板,发现不是声卡的问题,提示是说我没有声音播放设备,我有两个音箱啊,在ubuntu下可是正常有声的!这是什么原因呢?
附件
3.png
4.png
上次由 anddylf 在 2007-06-08 7:44,总共编辑 2 次。
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

补充一个问题

#2

帖子 anddylf » 2007-06-07 22:52

主机:ubuntu
guest:deep in 5.5 xp
在寝室和同学共用一个路由上网,以前我们几个都是xp的时候,用飞鸽传书来传文件,相当快了!所以,如果在我的guest上也想用飞鸽,但是尝试了一下,不能发现网络上的其他计算机!这就没有办法用飞鸽啊!请问高手们,如何才能使用飞鸽,可能是要设置一下主机和guest的网络设置,但是不太会!望高手指导! :o
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

努力要把问题搞清楚!

#3

帖子 anddylf » 2007-06-07 23:58

应该是虚拟机上没有检测到声卡导致的原因吧-因为在设备管理器上没有看到声卡那一长串的字符,所以有此推测。。。。。。
附件
5.png
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

进一步研究!

#4

帖子 anddylf » 2007-06-08 0:00

用xp的direct诊断工具检查,确证了我的想法是正确的
附件
6.png
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 anddylf » 2007-06-08 0:05

怎么办呢?找了半天,终于在虚拟机工作站上发现点令人兴奋的东西
附件
7.png
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 anddylf » 2007-06-08 0:09

重新启动虚拟机,再次打开设备管理器,呵呵,这回看到那一长串的字符了,说明这回应该是正确识别了声卡了!高兴啊!
附件
8.png
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 anddylf » 2007-06-08 0:16

然而,老天爷好像在考验我的耐心,当我高高兴兴的打开wmp来听音乐的时候,彻底傻了,还是没有声音啊!怎么回事呢?再次打开direct诊断工具,点击测试提示用户验证软件上有故障 :? ?这是什么意思?是说我下的deep in 5.5本身有问题吗?还是别的什么问题,不懂了?关键是应该如何解决呢?还是此题无解啊?待高手赐教!谢谢
附件
9.png
头像
Louis
帖子: 148
注册时间: 2006-11-28 3:31
来自: HangZhou
送出感谢: 0
接收感谢: 0

#8

帖子 Louis » 2007-06-08 5:36

你是不是在设置里没选声卡驱动啊?不是选Null Audio Driver,选择ALSA Audio Driver或者OSS Audio Driver。
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 anddylf » 2007-06-08 7:43

Louis 写了:你是不是在设置里没选声卡驱动啊?不是选Null Audio Driver,选择ALSA Audio Driver或者OSS Audio Driver。


高人啊!就是错在这里了!一语点醒梦中人 :P :wink:
谢谢,问题解决!
头像
anddylf
帖子: 266
注册时间: 2007-05-26 13:13
送出感谢: 0
接收感谢: 0
联系:

Re: 补充一个问题

#10

帖子 anddylf » 2007-06-08 7:56

anddylf 写了:主机:ubuntu
guest:deep in 5.5 xp
在寝室和同学共用一个路由上网,以前我们几个都是xp的时候,用飞鸽传书来传文件,相当快了!所以,如果在我的guest上也想用飞鸽,但是尝试了一下,不能发现网络上的其他计算机!这就没有办法用飞鸽啊!请问高手们,如何才能使用飞鸽,可能是要设置一下主机和guest的网络设置,但是不太会!望高手指导! :o


其实,问题还有一点点了,如果这个问题也能完美解决的话,哈哈,那就太爽了!
不过人好像不能太贪心,哈?
如果哪位高手路过,碰巧知道有解决办法的话,还希望赐教,谢谢!!!!!!!
gzlsl
帖子: 74
注册时间: 2007-10-19 10:27
送出感谢: 1 次
接收感谢: 0

#11

帖子 gzlsl » 2007-11-11 2:50

anddylf 写了:
Louis 写了:你是不是在设置里没选声卡驱动啊?不是选Null Audio Driver,选择ALSA Audio Driver或者OSS Audio Driver。


高人啊!就是错在这里了!一语点醒梦中人 :P :wink:
谢谢,问题解决!


为什么我两者都选了,还是没有声音哦?启动XP时提示:No audio devices could not be opened.
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

Re: 补充一个问题

#12

帖子 jimmin » 2007-11-11 3:37

anddylf 写了:
anddylf 写了:主机:ubuntu
guest:deep in 5.5 xp
在寝室和同学共用一个路由上网,以前我们几个都是xp的时候,用飞鸽传书来传文件,相当快了!所以,如果在我的guest上也想用飞鸽,但是尝试了一下,不能发现网络上的其他计算机!这就没有办法用飞鸽啊!请问高手们,如何才能使用飞鸽,可能是要设置一下主机和guest的网络设置,但是不太会!望高手指导! :o


其实,问题还有一点点了,如果这个问题也能完美解决的话,哈哈,那就太爽了!
不过人好像不能太贪心,哈?
如果哪位高手路过,碰巧知道有解决办法的话,还希望赐教,谢谢!!!!!!!


http://www.oceanboo.cn/read.php?55
chenpinyou
帖子: 53
注册时间: 2008-02-23 10:37
送出感谢: 0
接收感谢: 0

#13

帖子 chenpinyou » 2008-03-18 18:13

gzlsl 写了:
anddylf 写了:
Louis 写了:你是不是在设置里没选声卡驱动啊?不是选Null Audio Driver,选择ALSA Audio Driver或者OSS Audio Driver。


高人啊!就是错在这里了!一语点醒梦中人 :P :wink:
谢谢,问题解决!


为什么我两者都选了,还是没有声音哦?启动XP时提示:No audio devices could not be opened.



我也是,都没有声音啊
头像
20051234512345
帖子: 91
注册时间: 2007-12-19 12:02
送出感谢: 0
接收感谢: 0

#14

帖子 20051234512345 » 2008-04-03 14:20

:?:
代晓珂
帖子: 5
注册时间: 2008-04-07 18:42
送出感谢: 0
接收感谢: 0

#15

帖子 代晓珂 » 2008-04-11 10:24

问题已经解决,多谢!
回复

回到 “虚拟机和虚拟化”