当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已经解决]在ubuntu 7.04中安装vmware server失败
帖子发表于 : 2007-07-20 0:18 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
主要是这里,请教解决方法(补充,在安装VMware-server-1.0.3-44356.tar.gz之前,成功安装了VMware-player-2.0.0-45731.i386.tar.gz,不知道两者是不是有冲突?):

代码:
Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the mime type icons?
[/usr/share/icons]

What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

/usr/share/applications/vmware-server.desktop: warning: The 'Application' category is not defined by the desktop entry specification.  Please use one of "AudioVideo", "Audio", "Video", "Development", "Education", "Game", "Graphics", "Network", "Office", "Settings", "System", "Utility" instead
/usr/share/applications/vmware-console-uri-handler.desktop: warning: The 'Application' category is not defined by the desktop entry specification.  Please use one of "AudioVideo", "Audio", "Video", "Development", "Education", "Game", "Graphics", "Network", "Office", "Settings", "System", "Utility" instead
Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel.  Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.20-16-generic/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.20-16-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.20-16-generic'
  CC [M]  /tmp/vmware-config0/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config0/vmmon-only/linux/driver.c:80:
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘compat_exit’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘exit_code’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: warning: type defaults to ‘int’ in declaration of ‘_syscall1’
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-16-generic'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

linux@ubuntu:~/vmware-server-distrib$


最后由 relaxssl 编辑于 2007-07-26 14:45,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-20 0:41 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
我原来成功安装的vmware player不能使用了,估计是两者有冲突。

以前在windows下安装vmware workstations,一般都会自动安装vmware player,我以为他们都兼容呢。

后记:后来全新安装了ubuntu,再安装vm server还是这个错误,看来不是vm player的问题。


最后由 relaxssl 编辑于 2007-07-26 12:59,总共编辑了 2 次

页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-20 0:52 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
现在想卸载掉,该如何卸载呢?

(在安装VMware-server-1.0.3-44356.tar.gz之前,成功安装了VMware-player-2.0.0-45731.i386.tar.gz)

用了make uninstall,make uninstaller都不成功
代码:
linux@ubuntu:~/vmware-server-distrib$ sudo make uninstall
Password:
make: *** No rule to make target `uninstall'.  Stop.
linux@ubuntu:~/vmware-server-distrib$ sudo make uninstaller
make: *** No rule to make target `uninstaller'.  Stop.
linux@ubuntu:~/vmware-server-distrib$

这个卸载和安装其实是同一个命令,因为在同一个文档中。


最后由 relaxssl 编辑于 2007-07-26 12:17,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-20 8:56 

注册: 2007-04-28 22:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样的问题。

E: /var/cache/apt/archives/vmware-server_1.0.3-1_i386.deb: 子进程·pre-installation script·返回了错误号·1


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-20 8:57 

注册: 2007-04-28 22:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
谁能帮解决一下捏,郁闷中。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-22 11:06 

注册: 2007-07-22 11:03
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
可以先将vmware player卸载,然后将/usr/lib/vmware目录删除。就可以安装vmware server了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-22 12:26 

注册: 2007-04-28 22:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
没有
/usr/lib/vmware
这个目录
我卸载是--purge掉的


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-22 13:19 

注册: 2007-04-28 22:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
解决了
/etc/vmware
没有删除


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-26 12:13 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
suozhu_chen 写道:
可以先将vmware player卸载,然后将/usr/lib/vmware目录删除。就可以安装vmware server了。

新安装的系统接着安装vm server也同样是这样的情况,如此看来这个是不已经安装了vmware player的问题。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-26 12:21 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
代码:
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘compat_exit’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘exit_code’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: warning: type defaults to ‘int’ in declaration of ‘_syscall1’
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-16-generic'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

这一段中的错误究竟想表达的是什么呢?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-07-26 13:11 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
Alexander Griesser on 2007-07-13 09:28:50 wrote:
Unfortunately, the vmmon module is not part of the ESX vmware tools and
therefore I couldn't test it, but vmware-any-any-update109 seems to make it
work again. It can be downloaded from

http://ftp.cvut.cz/vmware/

Please check for the latest version of vmware-any-any-update in this directory,
extract it and run "runme.pl" to patch your installed sources accordingly.

On my system it compiled flawlessly.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-07-26 13:15 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Unfortunately on those links there is no real help, so please if your are getting to this post because you have that same error, just remember to download the Patch for vmware [3]

untar it, and the execute the

runme.pl file.

Just remember to install all the necessary software before trying to install VMware, if you need help with this.

Follow this Instructions
Source URL: http://www.go2linux.org/installing-vmwa ... -on-feisty

Links:
[1] http://www.go2linux.org/node/44
[2] http://jaws.go2linux.org/archivos/vmwar ... 109.tar.gz
[3] http://jaws.go2linux.org/archivos/vmwar ... 109.tar.gz
[4] http://www.go2linux.org/node/30


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-26 13:25 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
Yesterday I updated my Ubuntu from Edgy to Feisty, just one day after doing it from Dapper Drake, and that because on Edgy my Intel Pro/Wireless stop working, but now with Feisty seems to be working again, anyway my VMware Server stop working and the vmware-config.pl did not success to compile the module for my Kernel 2.6.20-12-generic.

so I applied the same steps I did for my Debian Etch configuration, and it worked, here is the how to.

Installing VMware Server on Debian Etch


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-07-26 14:45 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
成功解决。

引用:
To install VMware server on Debian Etch (4.0) you first need to have Etch installed on you host PC, you can achieve this by using the netinst CD available at:

http://www.debian.org/devel/debian-installer/

Once you have it installed you can proceed with this How To install VMware server on Debian Etch

1.- First install some software needed (as root)

apt-get install libx11-6 libx11-dev libxtst6 xinetd wget

apt-get install linux-headers-`uname -r` build-essential

apt-get install binutils-doc make manpages-dev autoconf automake1.9 libtool flex bison gdb libc6-dev-amd64 lib64gcc1 gcc-2.95-doc [这一步有一个步骤如果输入y确定会自动终止,要直接enter才能继续。]

apt-get install gcc

apt-get install g++
(Thanks to Marga: read here

2.- Get the Software

You can get the vmware server here: http://www.vmware.com/download/server/

and do not forget to obtain the serial number by registering here: http://register.vmware.com/content/registration.html

3.- Installation

You can use wget, to get the appropiate code, or any mean you prefer, once you have the .tar.gz file

tar xvzf [package_downloaded]

cd vmware-server-distrib
./vmware-install.pl

here you just need to press enter, enter, enter to all questions, unless you want a more presonalized configuration, i.e. if you have two NICs and want both of the bridged to vmnet0 and vmnet2 as in my case, just follow the instructions in the script.

4.- Patching the software

As Etch has a newer version of Kernel the VMware server needs to be patched, here is how.

-- Get the code

Download from here: http://jaws.go2linux.org/archivos/vmwar ... 109.tar.gz

-- Unpack it

tar xvzf vwmare-any-any-update108.tar.gz

-- Change to its directory

cd vwmare-any-any-update108

-- Run the script that is going to patch the VMWare.

./runme.pl

5.- Automatic start vmware at start

update-rc.d vmware defaults 20

Enjoy your vmware server installed on your Debian 4.0 Etch


根据这个步骤安装成功后,在程序里却没有快捷启动图标了,哪位告诉人来补充一下。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译