[分享]最新gutsy安装vmware-server 1.0.3

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
alteeno
帖子: 254
注册时间: 2006-01-18 18:11
送出感谢: 0
接收感谢: 0

[分享]最新gutsy安装vmware-server 1.0.3

#1

帖子 alteeno » 2007-07-24 12:14

1、从www.vmware.com下载vmware-server安装包(tar.gz)格式。并安装完成,选择不配置(即使配置也会出错,暂不管它)。
2、从http://archive.canonical.com/ubuntu/pool/main/v/vmware-server/下载vmware-server-kernel-source包,根据情况选择i386或amd64包,并安装。
3、从http://platan.vc.cvut.cz/ftp/pub/vmware下载最新的vmware-any-any-update-112,使用tar解压,并将其中的vmnet.tar拷贝到/usr/src备用。
4、cd /usr/src
sudo tar xvf vmnet.tar
sudo tar xjvf vmware-server.tar.bz2
sudo mv vmnet-only/* modules/vmnet-only/
sudo tar cjvf vmware-server.tar.bz2
sudo modules-assistand build vmware-server
sudo dpkg -i “生成的vmware-server-kernel-modules包”
5、进入vmware-any-any-update-112的解压目录
sudo ./runme.pl
根据提示完成配置。
6、正常运行vmware-server即可。

本方法的关键是:使用vmware-any-any-update中的vmnet.tar替换vmare-server-kernel-modules和vmware-server中的vmnet.tar文件。
即使linux内核更新,也可以更新的vmware-any-any-update来解决问题。
已在kubuntu 7.10 64位系统下测试通过。
TurboSeven
帖子: 21
注册时间: 2006-12-05 10:29
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 TurboSeven » 2007-07-29 21:16

sudo ./runme.pl
Unable to open the installer database /etc/vmware/locations in read-mode.

Execution aborted.


我看了etc下没有vmware这个目录,于是也创建了,但是还是有这个错误
头像
jjxblue
帖子: 45
注册时间: 2007-07-13 13:02
送出感谢: 0
接收感谢: 0

#3

帖子 jjxblue » 2007-07-30 20:38

可以直接下载deb安装吗,这样不是更方便
alteeno
帖子: 254
注册时间: 2006-01-18 18:11
送出感谢: 0
接收感谢: 0

#4

帖子 alteeno » 2007-07-31 15:04

Linux内核随时更新,不时随时都有适合你的deb包的。比如2.6.22-8,-9都没有相应的vmware-server-kernel-modules的。
至于二楼的问题,不知有没有正确安装vmware-server呢?
dengying201
帖子: 20
注册时间: 2007-04-05 22:29
来自: 重庆
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 dengying201 » 2007-10-22 23:18

占个位置先,方便以后查阅~~
头像
yanzilme
帖子: 253
注册时间: 2006-11-01 3:21
送出感谢: 0
接收感谢: 0

#6

帖子 yanzilme » 2007-10-23 3:16

我下载了1.0.4的rpm包
用alien转成了deb安装,但是找不到vm的图示
要怎么建立图示到菜单呢?
回复

回到 “虚拟机和虚拟化”