当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [老资料了,掠过]ubuntu 7.04下安裝vmware workstation 6.0 45731
帖子发表于 : 2007-07-28 16:01 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
發表於 2007-7-4 22:56 資料 文集 短消息 QQ 淘寶旺旺
ubuntu 7.04下安裝vmware workstation 6.0 45731

1 問題
好不容易把vmwar workstation 6 linux版給down下來的,180M的傢夥,安裝,配置,一切順利。但是,重啟機器後,就發現需要重新配置!

/usr/bin/vmware-config.pl

而且,每次都是這樣!

今天發現:這個問題的原因就是vmware的服務被啟動了兩次導致的。一次是為vmware-player服務啟動,一次是vmware服務啟動,而第二次的服務啟動會失敗,從而在 /etc/vmwar/ 目錄下創建一個 not_configured 文件。本人把vmware和vmware-player都安裝了,不知道隻安裝 vmware而不安裝 vmware-player會不會出現這個問題

如果你這個時候,Ctrl+Alt+F8 ,切換到控制台,你就看到了vmware啟動兩次的log,後面一次出現了失敗。

2 解決問題

解決的方法就是先刪除那個not_configured 文件,然後刪除不需要的 vmware-player的服務,如果存在的話

$ sudo rm /etc/vmware/not_configured
$ sudo update-rc.d -f vmware-player remove

重啟,問題消失

附注:我測試了一下,對 vmware-player的運行沒有影響。


最后由 relaxssl 编辑于 2008-05-09 2:52,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-28 16:04 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
http://www.lingsmm.com/blog/2007/05/ubu ... build.html


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-28 16:10 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
http://www.xxlinux.com/linux/article/ac ... /8732.html

引用:
安装 VMware Workstation (VMware-workstation-6.0.0-45731.i386.tar.gz)
Linux Serial Number: WC5FW-V0CFX-4804A-4WTNL

1. 将软件包解压缩,得到名为 vmware-distrib 的文件包。
2. 安装前期必备软件
sudo apt-get install build-essential

sudo apt-get install gcc-3.4
sudo apt-get install linux-headers-`uname -r`
export CC=gcc-3.4

可能是新版的缘故,上面这三行好像不安装也可以。

3.进入到vmware所在目录
运行安装脚本 sudo ./vmware-install.pl
安装提示一步步往下做,默认为回车键或Y


页首
 用户资料  
 
4 楼 
 文章标题 : 受限驱动
帖子发表于 : 2007-07-31 0:33 

注册: 2006-04-14 1:12
帖子: 88
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
按照楼主的方法装好了。在受限驱动管理器的列表里面多了两个受限驱动。
Vmware Virtual Machine Monitor,Vmware Virtua Networking Driver

启动windowxp也是超慢无笔,日志里面显示设备busy

这个不知道如何解决呢?[/img]


_________________
图片
the flying flower
that
changes the colour of my day


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-31 0:43 
头像

注册: 2006-05-09 9:59
帖子: 513
地址: 四川成都
送出感谢: 1
接收感谢: 0 次
安装 VMware Tools , 设备忙的情况很正常, 比如,用quodlibet正在放歌的时候,vmware里的xp就不能发声了。


_________________
http://kuan.fm xiaosilent's Blog


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-01 1:40 

注册: 2006-04-14 1:12
帖子: 88
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
那两个受限设备有影响么?


_________________
图片
the flying flower
that
changes the colour of my day


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-22 0:49 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
vision 写道:
那两个受限设备有影响么?

似乎对使用没有影响,我一直这么使用,速度非常的快,如果你愿意当小白,建议你使用7.10,在7.10大部分的硬件问题都解决了,特别是A卡的驱动。
至于vm的速度,非常的好,比windows好。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-30 9:49 

注册: 2005-12-08 18:03
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
需要序列号 怎么弄呀 我也装好了


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-09-26 11:07 

注册: 2007-01-20 16:03
帖子: 48
地址: 浙江杭州
送出感谢: 0 次
接收感谢: 0 次
大家参考一下
好久没有用Windows了,昨天有一个软件需要在windows下运行,就想想用vmware workstation安装一个,可是在编译到vmmond模块的时候却出现了这样的错误:

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.20-5-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.20-5-generic'
CC [M] /tmp/vmware-config0/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config0/vmmon-only/linux/driver.c:80:
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘compat_exit’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘exit_code’
/tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: warning: type defaults to ‘int’ in declaration of ‘_syscall1’
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-5-generic'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

以上的compat_kernel.h定义与2.6.20的内核有不兼容的地方,那我们就来修改compat_kernel.h使其与compat_kernel.h与内核兼容就可以了。

首先备份原始文件,然后解压vmmon.tar:

cd /usr/lib/vmware/modules/source
sudo cp vmmon.tar vmmon.tar.old
sudo tar xvf vmmon.tar
sudo gedit vmmon-only/include/compat_kernel.h

将21行:

static inline _syscall1(int, compat_exit, int, exit_code);

替换为:

#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19)
static inline _syscall1(int, compat_exit, int, exit_code);
#endif

然后重新打包vmmon.tar:

tar cvf vmmon.tar vmmon-only
rm -rf vmmon-only

继续编译,vmmon模块是编译通过了,可是vmnet模块又出现了如下的错误:

make[1]: Entering directory `/usr/src/linux-headers-2.6.20-5-generic'
CC [M] /tmp/vmware-config1/vmnet-only/driver.o
CC [M] /tmp/vmware-config1/vmnet-only/hub.o
CC [M] /tmp/vmware-config1/vmnet-only/userif.o
/tmp/vmware-config1/vmnet-only/userif.c: In function ‘VNetCopyDatagramToUser’:
/tmp/vmware-config1/vmnet-only/userif.c:629: error: ‘CHECKSUM_HW’ undeclared (first use in this function)
/tmp/vmware-config1/vmnet-only/userif.c:629: error: (Each undeclared identifier is reported only once
/tmp/vmware-config1/vmnet-only/userif.c:629: error: for each function it appears in.)
make[2]: *** [/tmp/vmware-config1/vmnet-only/userif.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config1/vmnet-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-5-generic'
make: *** [vmnet.ko] 错误 2
make: Leaving directory `/tmp/vmware-config1/vmnet-only'
Unable to build the vmnet module.

现在是vmnet的问题,同样的我们要修改不兼容的代码,然后重新编译。

首先备份原始的vmnet.tar,并解压:

cd /usr/lib/vmware/modules/source
sudo cp vmnet.tar vmnet.tar.old
sudo tar xvf vmnet.tar
sudo gedit vmnet-only/userif.c和bridge.c

将其中的CHECKSUM_HW替换成CHECKSUM_COMPLETE。

然后重新打包:

tar cvf vmnet.tar vmmon-only
rm -rf vmnet-only

再次编译就一切OK了!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-09-26 15:38 
头像

注册: 2007-05-19 23:18
帖子: 314
地址: 广东珠海
送出感谢: 0 次
接收感谢: 0 次
在那下装vmware workstation 6.0 45731 ??!!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-09-26 15:44 

注册: 2006-10-28 11:05
帖子: 312
送出感谢: 0 次
接收感谢: 0 次
我的是执行完安装文件后,程序自动执行配置程序,配置完后直接可用,没任何手动配置


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-09-30 18:25 
头像

注册: 2006-07-08 14:41
帖子: 730
送出感谢: 0 次
接收感谢: 0 次
多一句话,安装前,必须卸载用apt方式从源下载安装的vmware player(如果之前有安装过的话),另,如果不小心还安装过vmware tools,也请一起卸载。那个工具是给虚拟机用的。。。请新手注意。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-03-23 1:25 
头像

注册: 2007-03-15 16:58
帖子: 2796
地址: 湖北武汉
送出感谢: 2
接收感谢: 4
安装完,但是连哪里打开他都不知道!


_________________
引用:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译