[问题]我在LINUX下安装虚拟机出现的问题

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
easoncai
帖子: 47
注册时间: 2007-08-05 14:06
送出感谢: 0
接收感谢: 0

[问题]我在LINUX下安装虚拟机出现的问题

#1

帖子 easoncai » 2007-08-20 13:25

[root@localhost tmp]# ./VirtualBox_1.3.2_Linux_x86.run install
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.....
VirtualBox Version 1.3.2 (Sun Jan 14 15:25:08 CET 2007) installation
Please install the header files for your current Linux kernel.
The VirtualBox installer needs the GNU compiler to be installed.
Problems were found which would prevent VirtualBox from installing.
Please correct these problems and try again.


请大侠帮忙
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ct » 2007-08-20 14:15

其官方网站上有1.40的deb包可以下载到.
Please install the header files for your current Linux kernel.
缺kernel header
easoncai
帖子: 47
注册时间: 2007-08-05 14:06
送出感谢: 0
接收感谢: 0

#3

帖子 easoncai » 2007-08-20 14:19

我知道缺那个kernel header,就是不知道在哪找阿??
没有这个我根本安装不了阿?
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 ct » 2007-08-20 15:03

linux-headers-2.6.22-9 - Header files related to Linux kernel version 2.6.22
linux-headers-2.6.22-9-386 - Linux kernel headers for version 2.6.22 on i386
linux-headers-2.6.22-9-generic - Linux kernel headers for version 2.6.22 on x86/x86_64
easoncai
帖子: 47
注册时间: 2007-08-05 14:06
送出感谢: 0
接收感谢: 0

#5

帖子 easoncai » 2007-08-20 16:15

我下载了一个文件kernel-2.6.15-1.2054_FC5.src.rpm
是这个吗?
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 ct » 2007-08-20 16:20

sudo apt-get install linux-headers-2.6.22-9
fc5的ubuntu估计用不了,何况内核版本号也不对.
easoncai
帖子: 47
注册时间: 2007-08-05 14:06
送出感谢: 0
接收感谢: 0

#7

帖子 easoncai » 2007-08-20 16:26

是阿。
我下载的那个是FC5的。很麻烦阿!!!!
回复

回到 “虚拟机和虚拟化”