vbox因共享文件夹无法启动,求助!

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
萨秋
帖子: 19
注册时间: 2007-09-07 23:29
送出感谢: 0
接收感谢: 0
联系:

vbox因共享文件夹无法启动,求助!

#1

帖子 萨秋 » 2007-10-30 17:22

为使用U盘,而在ubuntu里连接了个U盘到虚拟机的XP里作为映像磁盘,结果U盘使用后拨下来后,关掉vbox重启后出现“Shared folder host path '/media/disk' is not accessible.”没法启动了。

上网找了找说是可以在终端里删除所有共享文件夹,但是用
sudo vboxmanage sharedfolder remove "win" -name "U" 的命令老提示如下:

VirtualBox Command Line Management Interface Version 1.5.0_OSE
(C) 2005-2007 innotek GmbH
All rights reserved.

[!] FAILED calling aVirtualBox->FindMachine(Bstr(argv[1]), machine.asOutParam()) at line 5957!
[!] Primary RC = 0x80070057
[!] Full error info present: true , basic error info present: true
[!] Result Code = 0x80070057
[!] Text = Could not find a registered machine named 'win'
[!] Component = VirtualBox, Interface: IVirtualBox, {76b25f3c-15d4-4785-a9d3-adc6a462beec}
[!] Callee = IVirtualBox, {76b25f3c-15d4-4785-a9d3-adc6a462beec}

看着像说我的虚拟主机名不是win,可我记得当时只取的这名,还叫作win.vdi的文件,实在不明白了,哪位朋友帮忙解释解决一下。附件是出问题的截图。

唉,之前在vbox模拟XP用了几天了还真不错,呵呵,还以为蛮简单哩。
附件
Screenshot.png
头像
blackiron
帖子: 887
注册时间: 2007-05-25 16:47
来自: 上海
送出感谢: 0
接收感谢: 0

#2

帖子 blackiron » 2007-10-30 18:11

那肯定是啊,你U盘都不在了,它当然会出这样的问题


使用U盘不用这样做吧,最简单的方法,把U盘插入后,系统会自动挂载它,然后把它解挂,在虚拟机窗口右下角U盘插头图标上,在右键菜单中选择你的U盘,这样就把U盘挂到客户机里去了
萨秋
帖子: 19
注册时间: 2007-09-07 23:29
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 萨秋 » 2007-10-30 18:14

哦,这样搞啊。
谢谢谢谢!

可朋友能不能告诉一下现在这个状况如何解决,是不是把共享文件夹全删除了就可以了。
上面我用remove删除方法不行吗,还有如何知道我的虚拟 主机名怎么查看啊,总之,就是如何解决现在的这个问题,呵呵!
萨秋
帖子: 19
注册时间: 2007-09-07 23:29
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 萨秋 » 2007-10-30 18:44

忘记说了,我原先设置/home分区大小(单独分区的)的时候太小,所以,在模拟机里安装好XP后将原先的vdi文件换到了/opt下,不知道这是不是vboxmanage无法辩认主机名的缘故。但是,我一直在用啊,基本也没碰到什么问题,只是今天用U盘时自作聪明的加了个连接,唉!
ino1
帖子: 266
注册时间: 2006-10-28 18:05
送出感谢: 0
接收感谢: 0

#5

帖子 ino1 » 2007-10-30 20:17

配置文件在~/.VirtualBox/Machines/下面,先备份一个,再用文本编辑器编辑一下吧,类似下面这样的语句:

代码: 全选

 <SharedFolders>
        <SharedFolder hostPath="/media/win_d" name="win_d"/>
      </SharedFolders>
P4M 2.4GHz 256+512MDDR IGP340M共享64M
越来越喜欢beryl了,把我的桌面扩展得好大呀!
萨秋
帖子: 19
注册时间: 2007-09-07 23:29
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 萨秋 » 2007-10-30 20:52

啊,谢谢楼上的,照你说法,俺把那个无用的sharefolder删除了,启动就没问题了。

但我还是不明白,明明主机名设的就是win,为何在终端里用命令时老提示无法找到,唉,不明白!

不过,还是谢谢热心朋友相助。 :)
bigben446
帖子: 108
注册时间: 2007-09-12 14:45
送出感谢: 8 次
接收感谢: 1 次

#7

帖子 bigben446 » 2008-06-24 10:08

有一个更好的小tip:

启动xp之前,将要在xp下面挂载的磁盘在ubuntu下面打开一下,虚拟机里里面的xp就可以自动识别了(不能识别那个磁盘就打开哪个磁盘,刷新一下就可以了,百试不爽)

至于原因我不知道阿
回复

回到 “虚拟机和虚拟化”