当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于VMWARE中,PING不通网关,但可以PING通物理机(桥接模式)
帖子发表于 : 2007-12-19 11:43 

注册: 2007-07-08 12:02
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
以下的我的现象:
我的NB是T60,双网卡:一个有线,一个无线。
物理机是UBUNTU 8.04,虚拟机是WINDOWS XP.
两个网卡:有线是eth0 无线是eth1,网络是DHCP
虚拟机也启用了两个网卡,都是桥接模式。

当我使用有线时,VMWARE很正常,XP能够获得IP,并正常 上网。
但当我使用无线时,则,XP不能获得IP。当我强制设置一个IP(和物理机是同一个网段)时,XP可以PING通我的物理机,
但不能PING通网关。


谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-05 11:56 

注册: 2007-11-22 20:01
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
vmware workstation 对无线网卡的桥接问题,找了一天才找到解决方案:
http://ubuntuforums.org/showthread.php?t=574427

works for me...
anyway.. here is the interesting part:
(1) Download Hauke-m's patched vmnet.tar file from here:

http://www.hauke-m.de/fileadmin/vmware/vmnet.tar

(2) Go to /usr/lib/vmware/modules/source and rename the original vmnet.tar to vmnetOLD.tar or something like that.

(3) Copy Hauke-m's patched vmnet.tar to /usr/lib/vmware/modules/source/.

(4) Run vmware-config.pl.

That should do it.
------------------------------------------------------------------------------------------

P.S. 通过后发现虚拟机guest os运行变得巨慢,不用急:
http://forum.ubuntu.org.cn/viewtopic.ph ... 546b2c4c97

代码:
代码:
cat /sys/module/processor/parameters/max_cstate

我的笔记本里这个值是8,解决方法很简单,只要一行命令:
代码:
echo 1 > /sys/module/processor/parameters/max_cstate
[/code]

PS:最好加在/etc/rc.local中。


附件:
文件注释: vmnet.tar
ubuntu8.04 2.6.24-20-generic
vmware-workstation 6.03 build-80004

vmnet(2).tar [520 KiB]
被下载 44 次
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译