当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 下终端 VIM不支持 语法高亮
帖子发表于 : 2008-08-07 22:53 

注册: 2008-01-26 22:29
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
我安装的是默认的VIM版本,但是输入:syntax enable,却说本版本的VIM不支持语法高亮,要下载哪个版本或者怎么设置啊,另外,在这个默认的VIM里我输入daw命令也不支持,怎么回事


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-08 1:12 
头像

注册: 2008-05-01 11:36
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get install vim-full

这样安装的就是完整版
现在打开vim或gvim输入
代码:
:syntax enable

就不会出错了
顺便去 http://www.vim.org/scripts/script.php?script_id=625
下载打包的主题包, 安装之后会自动生成菜单,非常方便~

顺便说下, 即使是完整版的vim也不能够在终端下使用全部色彩主题,很多漂亮的主题
是仅限gvim使用的,原因是终端的色彩有限~~不过现在又有多少人在终端下工作呢? :D


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-08 10:52 

注册: 2008-01-26 22:29
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
谢谢了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-08 11:00 

注册: 2007-05-06 10:12
帖子: 1994
送出感谢: 0 次
接收感谢: 0 次
vim-full

Vi IMproved - enhanced vi editor (transitional package)
This package is simply a transitional package from vim-full to vim-gnome.

只是装上了gvim....


最后由 xeoc 编辑于 2008-08-08 16:49,总共编辑了 1 次

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-08 16:45 
头像

注册: 2008-05-01 11:36
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
晕,transitional package指的是过渡包吧……
4楼的应该用的也是8.04,在8.04里安装vim-full相当于vim-gnome


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译