当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Help:: ubuntu8.04+emacs22中文显示
帖子发表于 : 2008-10-10 19:49 

注册: 2008-08-24 11:46
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
以前用xterm的时候,都能够显示中文,但是今天我一开机,xterm下就不能显示中文了,不知道为什么?

我运行
代码:
$locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE=zh_CN.GBK
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
$cd /usr/lib/locale
$ls
en_AU.utf8  en_DK.utf8  en_IE.utf8  en_PH.utf8   en_ZA.utf8  zh_HK.utf8
en_BW.utf8  en_GB.utf8  en_IN       en_SG.utf8    en_ZW.utf8  zh_SG.utf8
en_CA.utf8  en_HK.utf8  en_NZ.utf8  en_US.utf8  zh_CN.utf8  zh_TW.utf8
$export LC_CTYPE="zh_CN.UFT-8"


在xterm下还是不能显示中文。
当我重新打开一个xterm时,要重新设置LC_CTYPE,locale命令下的LC_CTYPE回到了原来的zh_CN.GBK,这样才能在emacs下打中文。
同时在$ 下写的.emacs怎么在#用户下没有效果??

还有一个错误:
代码:
$emacs
(emacs:6140): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

怎么显示这样的错误??

求各位高手指点迷津!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译