当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : emacs与其他程序拷贝文字出现问题
帖子发表于 : 2008-11-09 19:30 

注册: 2007-09-08 12:51
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
现在emacs用得不错,但还是有一点点问题,就是与其他程序之间拷贝文字时有时会出现问题,就是会缺少10%的内容,但其他文字均是正常,这是怎么回事,应该如何解决。

.emacs中文字的设置是:
代码:
(set-fontset-font (frame-parameter nil 'font)
              'unicode '("WenQuanYi zenhei" . "unicode-bmp"))

.Xresources文件内容是:
代码:
Emacs.Font:fontset-chinese
#   Emacs.Fontset-0:-*-DejaVu Sans Mono-medium-r-*-*-14-*-*-*-c-*-fontset-chinese,\
   chinese-gb2312:-*-wenquanyi zenhei-*-*-normal--*-*-*-*-*-*-iso10646-1,\
   chinese-big5-1:-*-wenquanyi zenhei-*-*-normal--*-*-*-*-*-*-iso10646-1,\
   chinese-big5-2:-*-wenquanyi zenhei-*-*-normal--*-*-*-*-*-*-iso10646-1
Xft.antialias: 1
Xft.hinting: 1
Xft.hintstyle: hintfull
Xft.rgba: rgb
# 这行一般没有什么必要,特别是 CRT 用户,而且貌似还要结合 cleartype 的补丁使用。

Emacs.FontBackend: xft


附件:
文件注释: emacs中的文字效果,看起来很漂亮
screenshot-2008-11-09-19-32-59.png
screenshot-2008-11-09-19-32-59.png [ 112.53 KiB | 被浏览 224 次 ]

文件注释: 拷贝后的文字效果,缺少了许多字
screenshot-2008-11-09-19-32-40.png
screenshot-2008-11-09-19-32-40.png [ 10.18 KiB | 被浏览 263 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 : Re: emacs与其他程序拷贝文字出现问题
帖子发表于 : 2008-12-06 14:12 

注册: 2007-09-08 12:51
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
发现如果将Emacs的运行环境设置为zh_CN.UTF-8就可以解决这个问题。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译