libgtk2.0-dev装不了,还能编译emacs么?

Vim、Emacs配置和使用
回复
头像
qinglangee
帖子: 137
注册时间: 2008-10-25 5:04
送出感谢: 1 次
接收感谢: 0

libgtk2.0-dev装不了,还能编译emacs么?

#1

帖子 qinglangee » 2008-11-19 22:05

我编译emacs的时候因为要装libgtk2.0-dev,但安装时
报这个:
libgtk2.0-dev:
依赖: libatk1.0-dev but it is not going to be installed
依赖: libcairo2-dev but it is not going to be installed
依赖: libglib2.0-dev but it is not going to be installed
依赖: libgtk2.0-0 (=2.12.9-3ubuntu2) but 2.12.9-3ubuntu4 is to be installed
依赖: libpango1.0-dev but it is not going to be installed

我又试了下安装 libatk1.0-dev
又报
libatk1.0-dev:
依赖: libglib2.0-dev but it is not going to be installed

再装libglib2.0-dev
再报
libglib2.0-dev:
依赖: libglib2.0-0 (=2.16.3-1) but 2.16.3-1ubuntu3 is to be installed

好像已以安装的 2.16.3-1ubuntu3比要安装的 libglib2.0-0 (=2.16.3-1)新一些的原因吧
反正libglib2.0-dev装不了了,后面依赖的一堆也装不了了

这种情况下该怎么办呢,我发现别人装libgtk2.0-dev没遇到这么些问题啊
sschenri
帖子: 8
注册时间: 2008-03-25 10:30
送出感谢: 0
接收感谢: 0

Re: libgtk2.0-dev装不了,还能编译emacs么?

#2

帖子 sschenri » 2008-11-19 23:51

建议这么安装emacs:sudo apt-get install emacs-snapshot
头像
qinglangee
帖子: 137
注册时间: 2008-10-25 5:04
送出感谢: 1 次
接收感谢: 0

Re: libgtk2.0-dev装不了,还能编译emacs么?

#3

帖子 qinglangee » 2008-11-20 7:42

能解释下什么意思么,我听说23的对中文支持比较好
回复

回到 “Vim和Emacs”