当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 奇怪!!在kubuntu8.10 emacs 的shell 模式显示乱码,怎么解决?
帖子发表于 : 2008-12-18 22:09 

注册: 2007-04-29 13:15
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
编辑模式可以可以输入中文,显示中文。但是M-x shell 后输入中英文,显示也没问题;但是ls,不论中英文显示一片乱码,ls|sort 正常显示。
解决???


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 奇怪!!在kubuntu8.10 emacs 的shell 模式显示乱码,怎么解决?
帖子发表于 : 2008-12-19 2:41 

注册: 2006-10-06 21:10
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
听起来象是颜色代码的问题? 在配置文件中
(ansi-color-for-comint-mode-on)
试试看.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 奇怪!!在kubuntu8.10 emacs 的shell 模式显示乱码,怎么解决?
帖子发表于 : 2008-12-19 8:47 

注册: 2007-04-29 13:15
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上。shell模式下 ls ,这次英文可以显示了,但是中文却不行。
我的.emacs 设置是
(set-language-environment 'Chinese-GB)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 奇怪!!在kubuntu8.10 emacs 的shell 模式显示乱码,怎么解决?
帖子发表于 : 2008-12-19 9:05 

注册: 2007-04-29 13:15
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
解决了 ,.emacs如下
(set-language-environment 'Chinese-GB)
(ansi-color-for-comint-mode-on)
(prefer-coding-system 'utf-8)

---------------------------------------------------
????????????
但是
不知道 (set-language-environment 'Chinese-GB) 和(prefer-coding-system 'utf-8)是否有相同冲突的地方,是否后面的设置否定了前面的中文环境设置?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 奇怪!!在kubuntu8.10 emacs 的shell 模式显示乱码,怎么解决?
帖子发表于 : 2010-05-17 13:22 

注册: 2008-08-09 8:44
帖子: 96
送出感谢: 0 次
接收感谢: 0 次
好啊完美解决了我的问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译