新手emacs23编译求助

Vim、Emacs配置和使用
回复
sybase2008
帖子: 109
注册时间: 2006-01-23 16:41
送出感谢: 0
接收感谢: 0

新手emacs23编译求助

#1

帖子 sybase2008 » 2006-06-22 19:30

configure的时候提示
What window system should Emacs use? none
What toolkit should Emacs use? none
Where do we find X Windows header files? NONE
Where do we find X Windows libraries? NONE
Does Emacs use -lXaw3d? no
Does Emacs use -lXpm? no
Does Emacs use -ljpeg? no
Does Emacs use -ltiff? no
Does Emacs use -lungif? no
Does Emacs use -lpng? no
Does Emacs use X toolkit scroll bars? no

不知道具体还要apt-get install什么?
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2006-06-23 1:38

装上 gtk2的开发包后可以用
./configure --prefix=/usr/ --with-x-toolkit=gtk
然后
make bootstarp
make info
sudo make install
就ok了。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
sybase2008
帖子: 109
注册时间: 2006-01-23 16:41
送出感谢: 0
接收感谢: 0

#3

帖子 sybase2008 » 2006-06-23 11:03

apt-get install gtk2??
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zhan » 2006-06-23 17:33

你先试试直接行不行,不行的话,可能是没有 libgtk2.0-dev这个包了。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
sybase2008
帖子: 109
注册时间: 2006-01-23 16:41
送出感谢: 0
接收感谢: 0

#5

帖子 sybase2008 » 2006-06-24 7:48

你先试试直接行不行,不行的话,可能是没有 libgtk2.0-dev这个包了。

我试过了,还是不行呀,奇怪,别人怎么没有问题!
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 zhan » 2006-06-24 14:47

你看看基本的开发环境装了没有
sudo apt-get install build-essential
sudo apt-get build-dep emacs
如果还有问题的话,贴出 configure的代码提示看看。
另:我正在写一个关于 emacs23的安装配置贴,准备置顶,欢迎交流!
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
hf_linux
帖子: 9
注册时间: 2006-04-26 11:23
送出感谢: 0
接收感谢: 0

#7

帖子 hf_linux » 2006-06-27 16:28

既然是新手,干吗自己编译啊。apt-get install不好吗?
也许库里面不是最新的,但是新手也用不到最新的那些特性。

现在有现成的软件绝对不自己编译,浪费时间
回复

回到 “Vim和Emacs”