Emacs23 配置指南

Vim、Emacs配置和使用
回复
nkskytiger
帖子: 49
注册时间: 2007-08-11 16:57
送出感谢: 0
接收感谢: 0

Re: 我的问题

#121

帖子 nkskytiger » 2008-04-21 11:25

jsxthncn 写了:

代码: 全选

vivid@vivid-desktop:~/emacs$ ./configure --prefix=/usr --enable-font-backend --with-xft --with-freetype --with-gtk 
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for AIX... no
checking whether gcc understands -Wno-pointer-sign... yes
checking whether ln -s works... yes
checking how to run the C preprocessor... gcc -E
checking for a BSD-compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking for install-info... /usr/sbin/install-info
checking for install-info... (cached) /usr/sbin/install-info
checking for install-info... (cached) /usr/sbin/install-info
checking for gzip... /bin/gzip
checking for makeinfo... no
configure: error: makeinfo >= 4.6 is required 

是不是还有什么依赖的包?[/quote]

you are required to install textinfo

sudo aptitude install textinfo
cvgmt
帖子: 322
注册时间: 2007-02-26 2:29
来自: 广东
送出感谢: 0
接收感谢: 0

#122

帖子 cvgmt » 2008-06-05 21:37

用 export CVS_RSH="ssh"
cvs -z3 -d:pserver:anonymous@cvs.sv.gnu.org:/cvsroot/emacs co -r emacs-unicode-2 emacs

下载后,当./configure 时提示

******************************************************************
* *
* The Emacs "emacs-unicode-2" branch has been merged into *
* the CVS trunk, and is now obsolete. You should probably *
* use the CVS trunk instead. *
* *
* To switch a CVS checkout to the trunk, use the command: *
* *
* cvs update -A *
* *
******************************************************************

是否说明下载的 “emacs-unicode-2” 要改过来,否则白下了这么久。

另外,是否要加 sudo apt-get install libungif4g
cvgmt
帖子: 322
注册时间: 2007-02-26 2:29
来自: 广东
送出感谢: 0
接收感谢: 0

#123

帖子 cvgmt » 2008-06-10 8:46

该用 cvs -z3 -d:pserver:anonymous@cvs.savannah.gnu.org:/sources/emacs co emacs 吧,见 http://savannah.gnu.org/cvs/?group=emacs
今天刚刚编译成功,版本是 emacs 23.0.60.1 GTK+version 2.12.9,试用了一下,发现不错啊,终于可以用上最新的版本了。

可以参考 http://www.emacswiki.org/cgi-bin/wiki/XftGnuEmacs,包括下载,依赖的包,编译办法,安装和使用 xft 等,一次就能成功。
spadgeletov
帖子: 92
注册时间: 2008-04-01 0:10
送出感谢: 0
接收感谢: 0

#124

帖子 spadgeletov » 2008-08-23 19:32

vim真的比较辛苦,要在命令模式、末行模式和编辑模式下转来装去~
真希望EMACS能搭救我~
谢谢你的精彩帖子
chzhcn
帖子: 7
注册时间: 2007-07-23 23:29
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#125

帖子 chzhcn » 2009-03-18 9:37

建议楼主加上这个环境

代码: 全选

 sudo apt-get install libjpeg-dev libgif-dev libtiff4-dev
我在编译时提示缺包不能configure过,网上有个sofeng朋友的blog给出了解决方案,确实是这几个包
luther_5015133
帖子: 22
注册时间: 2009-03-17 12:26
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#126

帖子 luther_5015133 » 2009-04-23 12:31

谢谢了!不错!
fdshenjia
帖子: 5
注册时间: 2008-09-06 11:42
送出感谢: 0
接收感谢: 0
联系:

Re: Emacs23 配置指南

#127

帖子 fdshenjia » 2009-06-13 13:41

谢谢楼主, 真的很详细!
头像
非主流1987
帖子: 427
注册时间: 2008-05-09 23:50
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#128

帖子 非主流1987 » 2009-06-13 14:11

:em04 又一篇好东西给人挖出来了···
剑影若兰
帖子: 8
注册时间: 2009-05-01 22:49
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#129

帖子 剑影若兰 » 2009-07-08 11:16

编译时还正常,但是make bootstrape时出现了如下的错误:
make[2]: *** 没有规则可以创建“compile-main”需要的目标“/home/wxs/emacs/lisp/org/org-agenda.elc”。 停止。
make[2]:正在离开目录 `/home/wxs/emacs/lisp'
make[1]: *** [lisp] 错误 2
make[1]:正在离开目录 `/home/wxs/emacs'
make: *** [bootstrap] 错误 2
那位能给解答一下。

又及:配置编译环境时有一步是sudo apt-get build-dep emacs21,这里会让人进行设置,我不知道这是什么东西就没有进行设置,是不是和这个有关?
xyh00001
帖子: 14
注册时间: 2009-05-04 20:05
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#130

帖子 xyh00001 » 2009-07-29 17:48

挺好,受益匪浅
头像
colinger
帖子: 57
注册时间: 2008-12-22 13:05
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#131

帖子 colinger » 2009-07-30 19:22

不错,多謝!!!
头像
beiluo
帖子: 41
注册时间: 2008-10-19 20:38
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#132

帖子 beiluo » 2009-08-03 20:44

谢谢楼主!编译成功了!!
intkids
帖子: 6
注册时间: 2007-09-28 18:59
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#133

帖子 intkids » 2009-09-08 18:08

Error messages

*

configure: error: You do not seem to have makeinfo >= 4.6, and your
source tree does not seem to have pre-built manuals in the `info' directory.
Either install a suitable version of makeinfo, or re-run configure
with the `--without-makeinfo' option to build without the manuals.

Solution:

$ sudo apt-get install texinfo

*

configure: error: The following required libraries were not found:
libjpeg libgif/libungif libtiff
Maybe some development libraries/packages are missing?
If you don't want to link with them give
--with-jpeg=no --with-gif=no --with-tiff=no
as options to configure

Solution:

$ sudo apt-get install libjpeg-dev libgif-dev libtiff4-dev

放在这里,以后用的时候来这里找!
头像
mikeandmore
帖子: 109
注册时间: 2005-10-13 18:29
送出感谢: 0
接收感谢: 0

Re: Emacs23 配置指南

#134

帖子 mikeandmore » 2009-12-06 10:04

现在可以直接装emacs23了。源里有包了
头像
幻白狼
帖子: 491
注册时间: 2010-05-27 9:28
送出感谢: 0
接收感谢: 1 次

Re: Emacs23 配置指南

#135

帖子 幻白狼 » 2010-06-23 17:11

我一直想用emacs啊,我用的是

代码: 全选

sudo apt-get install emacs
请问,这样安装不好么? :em06
回复

回到 “Vim和Emacs”