gvim不能右键单击打开文件了

Vim、Emacs配置和使用
回复
firefly
帖子: 22
注册时间: 2006-05-23 1:52
送出感谢: 0
接收感谢: 0
联系:

gvim不能右键单击打开文件了

#1

帖子 firefly » 2006-07-07 1:00

前几天用得还好好的,今天突然用右键单击打不开文件了。
可是在终端bash下用vim及gvim确一点问题都没有,看出错信息
“处理BufReadCmd 自动命令 “file://*”时发生错误”

好像是脚本的自动执行出错,因此将~/.vimrc 删掉,将
/etc/vim/vimrc,/etc/vim/gvimrc也恢复成原来的样子,
去掉自己的所有插件,还是不管用。
后来去掉系统/vim70/plugin 整个文件夹,倒是不会报错了,可是打开文件时,
每次都显示为新目录,如下:
"/Desktop/%E6%96%B0%BB%B6" [新目录] 0.0-1

仍然看不了,太打击积极性了!
谁能从两者(从bash和gnome右键)启动的不同原理,对上述情况予以解决吗?多谢大侠们![/img]
firefly
帖子: 22
注册时间: 2006-05-23 1:52
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 firefly » 2006-07-27 9:18

:cry: 没有人回答吗?
上面好像有位兄弟有类似的情况,但他是插件设置有问题,不太一样.
希望有人能帮帮小弟.......
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#3

帖子 hbsld » 2006-07-29 19:35

我以前遇到的问题是适应了一个错误的参数。

在找到答案以前,我在google的groups上发帖问了一下,有哥老外的答复是这样的:

There's always the possibility that not your .vimrc but some system-wide
file cause your problems. So you shoud try starting with *empty*
$HOME/.vimrc and $HOME/.gvimrc files to test if your problems still occur.
If all else fails you can narrow down the problem yourself:
Recursively comment out half of your rc-files (and then half of the part
where the problem occured and so on...) until you found the problematic
setting.

When you are finished doing that, either you know how to fix the problem
yourself or the regulars of this newsgroup at least know what the exact
problem is.

你按照他说的,慢慢试试看。
yingtaoting
帖子: 14
注册时间: 2007-06-26 11:22
送出感谢: 0
接收感谢: 0

#4

帖子 yingtaoting » 2007-07-10 8:37

试着修改 /usr/share/applications/gvim.desktop
把里边的
Exec=gvim -f %U
修改为
Exec=gvim -f %f
头像
rhfcaesar
帖子: 2996
注册时间: 2005-11-17 15:45
来自: 湖北
送出感谢: 0
接收感谢: 1 次

#5

帖子 rhfcaesar » 2007-07-10 11:10

楼上正解。
回复

回到 “Vim和Emacs”