gvim没有办法从右键菜单启动。

Vim、Emacs配置和使用
回复
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

gvim没有办法从右键菜单启动。

#1

帖子 hbsld » 2006-07-20 12:00

我的vim现在变的非常奇怪了。
症状:
1、在一个文本文件的右键菜单中没有办法启动gvim,在监视器中有gvim这个进程,进程的参数为:
gvim -f file:///home/username/1.txt
但是这个进程始终是占用6.8M的内存,然后就没有反应了,也不出来vim的窗口。

2、在终端中使用gvim -f 1.txt来打开1.txt的话,会将1.txt中的内容完全的清楚。后来我发现只有使用
gvim -u NONE -U NONE 1.txt 才能正常的打开1.txt。

3、从应用程序中可以打开gvim,而且在这个gvim中可以正常的打开文件。

我的vimrc如下:

代码: 全选

if has('multi_byte') && v:version > 602
if v:lang =~? '^\(zh\)\|\(ja\)\|\(ko\)'
        set ambiwidth=double
    endif
endif

:set fileformat=unix
:set guioptions-=T
":set guifont=TlwgMono\ Bold\ 11
:color torte
:set number
:set nocompatible
:set ruler
:set hlsearch
:set incsearch
:set ignorecase smartcase
:set backspace=indent,eol,start
:set autowrite
:set browsedir=buffer
:set textwidth=80

set fileencoding=chinese
:set formatoptions+=mM
:set fileencodings=ucs-bom,utf-8,chinese
:set statusline=%<%f\ %h%m%r%=%k[%{(&fenc==\"\")?&enc:&fenc}%{(&bomb?\",BOM\":\"\")}]\ %-14.(%l,%c%V%)\ %P
set ambiwidth=double

:set lines=36
:set columns=105
:set wrap
filetype plugin indent on
:syntax enable

:set autoindent
:set expandtab
:set softtabstop=4
:set tabstop=4
:set shiftwidth=4
:set foldcolumn=4
:set foldmethod=syntax
:set foldlevel=8
:highlight FoldColumn guibg=black guifg=yellow

let fortran_fold=1
let fortran_fold_conditionals=1
let fortran_more_precise=1
let fortran_do_enddo=1
au! BufRead,BufNewFile *.f90,*.f95 let bfortran_do_enddo=1
au! BufRead,BufNewFile *.f90,*.f95 let fortran_free_source=1 

let g:LargeFile=5
map mh h
map mj j
map mk k
map ml l
map mH H
map mJ J
map mK K
map mL L
map m, 5+
map m. 5-
map <F2> :nohl

map <F3> 1_mjzR
map <F4> 1_mkzR
map mm 100_
map mdf ] 
map mc :close

map zs g
map ms :tabnew ~/.vimrc

map mq :wqall

map mo :browse tabnew

map mp :browse sp

map mx :Matrix

map my "+y
map mp "+p
头像
Strange
帖子: 1823
注册时间: 2006-05-19 9:54
来自: Shanghai
送出感谢: 2 次
接收感谢: 10 次

#2

帖子 Strange » 2006-07-20 13:19

不要用-f参数试试
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#3

帖子 hbsld » 2006-07-20 15:54

不加-f参数也不行,可以从右键菜单启动,但是文件的内容就会完全被清空。
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#4

帖子 hbsld » 2006-07-22 21:53

找到原因了。

是由于"set fileencoding=chinese"造成的。
将这行注释掉就可以了。
头像
Strange
帖子: 1823
注册时间: 2006-05-19 9:54
来自: Shanghai
送出感谢: 2 次
接收感谢: 10 次

#5

帖子 Strange » 2006-07-23 22:52

fileencoding和清空有关系?
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#6

帖子 hbsld » 2006-07-24 1:03

关键是后面的那个“chinese”选项。
这个代码我是从ibm的网站上找到的。
它上面说,如果安装的gvim中包括iconv选项的话, 就有“chinese”这个别名用。

但是,在我的机子上看来是不行。
头像
ulixer
帖子: 231
注册时间: 2006-03-02 23:51
送出感谢: 0
接收感谢: 1 次

#7

帖子 ulixer » 2006-09-06 11:01

建议把 chinese 加到 fileencodings里,utf-8的后面,latin1的前面,
可能是这样 fileencodings=ucs-bom,utf-8,chinese,latin1
这样用vim读GB编码就不会乱码了
回复

回到 “Vim和Emacs”