vim-gnome的依赖是不是有问题?

Vim、Emacs配置和使用
回复
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

vim-gnome的依赖是不是有问题?

#1

帖子 lyreopera » 2005-08-15 20:58

vim-gnome:
依赖: vim (=1:6.3-046+1ubuntu7) 但是 1:6.3-046+1ubuntu7.1 将会被安装
附件
Screenshot.png
……
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#2

帖子 lyreopera » 2005-08-15 22:11

怀疑我的源是不是有点问题:


代码: 全选

deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn ubuntu.org.cn main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted
deb-src http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse



想装bmp-dev提示:
beep-media-player-dev:
依赖: xlibs-dev 但是此软件包将不会被安装
依赖: libgtk2.0-dev 但是此软件包将不会被安装
……
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#3

帖子 yonsan » 2005-08-15 22:35

估计不是源的问题!!
我的源和你的一样吧!
便我用apt-get 没问题.
你试试apt-get吧!
附件
ok.png
I will be back!
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#4

帖子 lyreopera » 2005-08-15 23:54

见鬼了……

这里:

zlib1g-dev:
依赖: zlib1g (=1:1.2.2-4ubuntu1) 但是 1:1.2.2-4ubuntu1.2 将会被安装


原来是源里的zlib1g和zlib1g-dev版本不一致……
……
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#5

帖子 lyreopera » 2005-08-16 0:01


http://packages.ubuntu.com/
下载安装了zlib1g-dev_1.2.2-4ubuntu1.2_i386.deb,

问题解决。
……
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#6

帖子 lyreopera » 2005-08-16 0:04

gvim也是这个问题,

依赖包和软件包版本不一致,

怎么以前没听说过有这问题……

!@#¥%……&*(*
……
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yongyi » 2005-08-16 0:08

lyreopera兄弟能apt-get 之后太兴奋了,怎么遇到这么多BT 状况:)
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#8

帖子 firehare » 2005-08-16 10:28

不会呀,源上的zlib1g-dev同zlib1g的版本是一样的呀,都是1.2.2-4ubuntu1.2,兄弟有没有在apt-get install之前先apt-get update呀?
我心无畏,源自于我心无知。
图片
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#9

帖子 lyreopera » 2005-08-16 10:38

我只能这么猜测,

昨天源只更新了zlib1g而没更新zlib1g-dev,

而我碰巧在这时候apt-get update了,

所以出问题了,

今天源是更新完了。
……
头像
bluebell
帖子: 264
注册时间: 2005-05-08 21:28
送出感谢: 0
接收感谢: 0

#10

帖子 bluebell » 2005-08-16 10:39

明显是混用official 和 backports源的结果。
我一般只用official的三个源。从来没出依赖问题。
(想找其它软件,就把其它源加入,但不升级,只安装想要的东西,然后立刻注销。)
Ubuntu 5.10 Breezy Badger
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#11

帖子 firehare » 2005-08-16 10:46

这也是一个比较好的方法,我用Ubuntu做服务器时,就是只用了官方的源,基本没有问题出现!
我心无畏,源自于我心无知。
图片
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#12

帖子 lyreopera » 2005-08-16 10:51

这个……我不懂啦,

我是按新手指南设置的……

official 和 backports是怎么回事呢?啥区别?
……
回复

回到 “Vim和Emacs”